aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2013-06-24 22:32:11 +0800
committerale <ale@FreeBSD.org>2013-06-24 22:32:11 +0800
commit48d5fb51023dbbe8f2a70121c289e1849e7e14eb (patch)
treefd816d2c8b34ef7db2d6bcabe7358eaa7fb2d04f /mail
parent19160cd533a64299fc9d3710c4d21307ce72df91 (diff)
downloadfreebsd-ports-gnome-48d5fb51023dbbe8f2a70121c289e1849e7e14eb.tar.gz
freebsd-ports-gnome-48d5fb51023dbbe8f2a70121c289e1849e7e14eb.tar.zst
freebsd-ports-gnome-48d5fb51023dbbe8f2a70121c289e1849e7e14eb.zip
Welcome PHP 5.5!
Future steps: - rename current php5 ports to php54 - make php55 the default one after an exp-run
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/php55-imap/Makefile10
-rw-r--r--mail/php55-imap/files/patch-config.m442
3 files changed, 53 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 7ca63082a2f3..6cde65af10cd 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -484,6 +484,7 @@
SUBDIR += php5-imap
SUBDIR += php52-imap
SUBDIR += php53-imap
+ SUBDIR += php55-imap
SUBDIR += phplist
SUBDIR += phpmailer
SUBDIR += phpmailer2
diff --git a/mail/php55-imap/Makefile b/mail/php55-imap/Makefile
new file mode 100644
index 000000000000..bcfe09c05117
--- /dev/null
+++ b/mail/php55-imap/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= mail
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -imap
+
+.include "${MASTERDIR}/Makefile"
diff --git a/mail/php55-imap/files/patch-config.m4 b/mail/php55-imap/files/patch-config.m4
new file mode 100644
index 000000000000..ab7120b2c8c8
--- /dev/null
+++ b/mail/php55-imap/files/patch-config.m4
@@ -0,0 +1,42 @@
+--- config.m4.orig 2010-02-07 14:06:54.000000000 +0100
++++ config.m4 2010-03-08 11:56:24.000000000 +0100
+@@ -103,6 +103,8 @@
+ PHP_ARG_WITH(imap-ssl,for IMAP SSL support,
+ [ --with-imap-ssl[=DIR] IMAP: Include SSL support. DIR is the OpenSSL install prefix], no, no)
+
++PHP_ARG_WITH(pcre-dir, pcre install prefix,
++[ --with-pcre-dir IMAP: pcre install prefix], no, no)
+
+ if test "$PHP_IMAP" != "no"; then
+ PHP_SUBST(IMAP_SHARED_LIBADD)
+@@ -119,6 +121,30 @@
+ fi
+ done
+
++ dnl This is PECL build, check if bundled PCRE library is used
++ old_CPPFLAGS=$CPPFLAGS
++ CPPFLAGS=$INCLUDES
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=yes
++ ],[
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=pecl
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++ ],[
++ PHP_PCRE_REGEX=no
++ ])
++ ])
++
+ dnl Check for c-client version 2004
+ AC_EGREP_HEADER(mail_fetch_overview_sequence, $IMAP_INC_DIR/mail.h, [
+ AC_DEFINE(HAVE_IMAP2004,1,[ ])