aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormatthew <matthew@FreeBSD.org>2015-08-28 17:23:53 +0800
committermatthew <matthew@FreeBSD.org>2015-08-28 17:23:53 +0800
commit4cce68f9ac83a33b7d827de426955820c4e3e36d (patch)
tree40a739ef04006637921e8fe9f0e22babc5724c1b /mail
parente5d6a37fbee28223e1f6aa6cd9c56ab84cc35dd9 (diff)
downloadfreebsd-ports-gnome-4cce68f9ac83a33b7d827de426955820c4e3e36d.tar.gz
freebsd-ports-gnome-4cce68f9ac83a33b7d827de426955820c4e3e36d.tar.zst
freebsd-ports-gnome-4cce68f9ac83a33b7d827de426955820c4e3e36d.zip
* Add a fix for where libopendkim fails to cope with a header line
which is wrapped immediately after the header name. This has been reported upstream: http://sourceforge.net/p/opendkim/bugs/230/ * Update pkg-descr -- all of the ADSP stuff has gone from opendkim now. PR: 202668 Approved by: freebsd-ports@dan.me.uk (maintainer)
Diffstat (limited to 'mail')
-rw-r--r--mail/opendkim/Makefile1
-rw-r--r--mail/opendkim/files/patch-libopendkim_dkim-canon.c11
-rw-r--r--mail/opendkim/pkg-descr3
3 files changed, 13 insertions, 2 deletions
diff --git a/mail/opendkim/Makefile b/mail/opendkim/Makefile
index 1905c042cb83..ca7072cd6c67 100644
--- a/mail/opendkim/Makefile
+++ b/mail/opendkim/Makefile
@@ -3,6 +3,7 @@
PORTNAME= opendkim
PORTVERSION= 2.10.3
+PORTREVISION= 1
CATEGORIES= mail security
MASTER_SITES= SF/${PORTNAME} \
SF/${PORTNAME}/Previous%20Releases \
diff --git a/mail/opendkim/files/patch-libopendkim_dkim-canon.c b/mail/opendkim/files/patch-libopendkim_dkim-canon.c
new file mode 100644
index 000000000000..6f5f5439580a
--- /dev/null
+++ b/mail/opendkim/files/patch-libopendkim_dkim-canon.c
@@ -0,0 +1,11 @@
+--- libopendkim/dkim-canon.c.orig 2015-08-26 08:37:01 UTC
++++ libopendkim/dkim-canon.c
+@@ -388,7 +388,7 @@ dkim_canon_header_string(struct dkim_dst
+ }
+
+ /* skip all spaces before first word */
+- while (*p != '\0' && DKIM_ISWSP(*p))
++ while (*p != '\0' && DKIM_ISLWSP(*p))
+ p++;
+
+ space = FALSE; /* just saw a space */
diff --git a/mail/opendkim/pkg-descr b/mail/opendkim/pkg-descr
index d292b9de115c..148e2b14a375 100644
--- a/mail/opendkim/pkg-descr
+++ b/mail/opendkim/pkg-descr
@@ -1,8 +1,7 @@
OpenDKIM is an open source implementation of the DKIM (Domain Keys Identified
Mail) sender authentication system proposed by the E-mail Signing Technology
Group (ESTG), now standardized by the IETF (RFC4871). It also includes
-implementations of the Author Domain Signing Practises (ADSP, RFC5617) and
-Vouch By Reference (VBR, RFC5518) proposed standards.
+an implementations of the Vouch By Reference (VBR, RFC5518) proposed standard.
The OpenDKIM package consists of a library that implements the DKIM service
and a milter-based filter application that can plug in to any milter-aware