aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-12-01 05:26:35 +0800
committeradamw <adamw@FreeBSD.org>2014-12-01 05:26:35 +0800
commit54d796860c296977c7fb81e961f70b875009889e (patch)
treedadba1a53b4c0a50e8998dee93d735cfa9c5c7ee /mail
parent844b61251659df2376b5a06e11353135141315f1 (diff)
downloadfreebsd-ports-gnome-54d796860c296977c7fb81e961f70b875009889e.tar.gz
freebsd-ports-gnome-54d796860c296977c7fb81e961f70b875009889e.tar.zst
freebsd-ports-gnome-54d796860c296977c7fb81e961f70b875009889e.zip
Add a patch from SA bug #7107, to quiet warnings due to bad usage of $^V
that show up during sa-learn, sa-compile, etc. Note that other warnings can still show up, ex.: zoom: rule __FOR_SALE_PRC_100K will loop on SpamAssassin older than 3.3.2 running under Perl 5.12 or older, Bug 6558 While here, go with the @dir new world order. SA is not poudriere clean at this time; /var/spool/spamd is the homedir of user spamd, so I am pretty sure it shouldn't be listed with @dir. QA sees this as a leftover dir. PR: 195524 Submitted by: Bernard Spil
Diffstat (limited to 'mail')
-rw-r--r--mail/spamassassin/Makefile2
-rw-r--r--mail/spamassassin/files/patch-bug710735
-rw-r--r--mail/spamassassin/pkg-plist11
3 files changed, 40 insertions, 8 deletions
diff --git a/mail/spamassassin/Makefile b/mail/spamassassin/Makefile
index 4ee4ff5eb029..3a711601dd11 100644
--- a/mail/spamassassin/Makefile
+++ b/mail/spamassassin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= spamassassin
PORTVERSION= 3.4.0
-PORTREVISION?= 14 # also bump japanese/spamassassin
+PORTREVISION?= 15 # also bump japanese/spamassassin
CATEGORIES?= mail perl5
MASTER_SITES= ${MASTER_SITE_APACHE:S/$/:apache/} ${MASTER_SITE_PERL_CPAN:S/$/:cpan/}
MASTER_SITE_SUBDIR= spamassassin/source/:apache Mail/:cpan
diff --git a/mail/spamassassin/files/patch-bug7107 b/mail/spamassassin/files/patch-bug7107
new file mode 100644
index 000000000000..e04844012b85
--- /dev/null
+++ b/mail/spamassassin/files/patch-bug7107
@@ -0,0 +1,35 @@
+--- lib/Mail/SpamAssassin/Conf/Parser.pm 2014/11/27 18:51:04 1642206
++++ lib/Mail/SpamAssassin/Conf/Parser.pm 2014/11/27 18:54:32 1642207
+@@ -533,6 +533,9 @@
+ elsif ($token eq 'version') {
+ $eval .= $Mail::SpamAssassin::VERSION." ";
+ }
++ elsif ($token eq 'perl_version') {
++ $eval .= $]." ";
++ }
+ elsif ($token =~ /^\w[\w\:]+$/) { # class name
+ my $u = untaint_var($token);
+ $eval .= '"' . $u . '" ';
+--- lib/Mail/SpamAssassin/Conf.pm 2014/11/27 18:51:04 1642206
++++ lib/Mail/SpamAssassin/Conf.pm 2014/11/27 18:54:32 1642207
+@@ -3886,6 +3886,20 @@
+ version, and z is maintenance version. So 3.0.0 is C<3.000000>, and 3.4.80 is
+ C<3.004080>.
+
++=item perl_version
++
++This will be replaced with the version number of the currently-running
++perl engine. Note: The version used is in the $] version format which is
++C<x.yyyzzz>, where x is major version, y is minor version, and z is maintenance
++version. So 5.8.8 is C<5.008008>, and 5.10.0 is C<5.010000>. Use to protect rules
++that incorporate RE syntax elements introduced in later versions of perl, such
++as the C<++> non-backtracking match. For example:
++
++ # Avoid lint error on older perl installs
++ if perl_version >= 5.010000
++ body INVALID_RE_SYNTAX_IN_PERL_5_8_8 /\w++/
++ endif
++
+ =item plugin(Name::Of::Plugin)
+
+ This is a function call that returns C<1> if the plugin named
diff --git a/mail/spamassassin/pkg-plist b/mail/spamassassin/pkg-plist
index 5f70c0ad445a..c6ce39115189 100644
--- a/mail/spamassassin/pkg-plist
+++ b/mail/spamassassin/pkg-plist
@@ -200,14 +200,11 @@ man/man1/spamd.1.gz
%%DATADIR%%/languages
%%DATADIR%%/sa-update-pubkey.txt
%%DATADIR%%/user_prefs.template
-@dirrm %%DATADIR%%
-@dirrmtry %%ETCDIR%%
-@dirrmtry etc/mail
@unexec rm -rf /var/lib/spamassassin/2* 2>&1 >/dev/null || true
-@dirrmtry /var/lib/spamassassin
-@dirrmtry /var/lib
-@dirrmtry /var/db/spamassassin
+@dir /var/lib/spamassassin
+@dir /var/lib
+@dir /var/db/spamassassin
@unexec [ -d /var/db/spamassassin ] && echo "If you are no longer using SpamAssassin, remove /var/db/spamassassin"
@unexec pw usershow "%%USER%%" 2>/dev/null 1>&2 && echo "To delete %%USER%% permanently, 'rmuser %%USER%%'"
@@ -215,7 +212,7 @@ man/man1/spamd.1.gz
@owner %%USER%%
@group %%GROUP%%
-@dirrmtry /var/run/spamd
+@dir /var/run/spamd
@group
@owner