aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorvsevolod <vsevolod@FreeBSD.org>2016-11-16 17:53:55 +0800
committervsevolod <vsevolod@FreeBSD.org>2016-11-16 17:53:55 +0800
commit5a36f4df8dd0d671da8af2e0834dc09b1a00d74f (patch)
tree50b622f719a3e4a4121cbef8819d4e03ea4a914f /mail
parent89965a0fdb19f6333058c7fb79d90781a2cbe351 (diff)
downloadfreebsd-ports-gnome-5a36f4df8dd0d671da8af2e0834dc09b1a00d74f.tar.gz
freebsd-ports-gnome-5a36f4df8dd0d671da8af2e0834dc09b1a00d74f.tar.zst
freebsd-ports-gnome-5a36f4df8dd0d671da8af2e0834dc09b1a00d74f.zip
- Remove obsolete libmemcached dependency
- Add DKIM signing option PR: 212302 Submitted by: Alexander Moisseev <moiseev at mezonplus.ru>
Diffstat (limited to 'mail')
-rw-r--r--mail/rmilter/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/mail/rmilter/Makefile b/mail/rmilter/Makefile
index 6b5f15eece2c..59d89e99c9d7 100644
--- a/mail/rmilter/Makefile
+++ b/mail/rmilter/Makefile
@@ -2,6 +2,7 @@
PORTNAME= rmilter
PORTVERSION= 1.9.2
+PORTREVISION= 1
CATEGORIES= mail
MAINTAINER= vsevolod@FreeBSD.org
@@ -9,9 +10,7 @@ COMMENT= Milter that performs rspamd, clamav, and other checks
LICENSE= BSD2CLAUSE
-LIB_DEPENDS= libpcre.so:devel/pcre \
- libopendkim.so:mail/opendkim \
- libmemcached.so:databases/libmemcached
+LIB_DEPENDS= libpcre.so:devel/pcre
BROKEN_armv6= Fails to configure in cmake
BROKEN_mips= Fails to compile: error: Unsupported word size
@@ -27,16 +26,24 @@ USE_GNOME= glib20
USERS= _rmilter
GROUPS= _rmilter
-CMAKE_ARGS+= -DENABLE_DKIM=ON
-
WITH_SENDMAIL_BASE= yes
+OPTIONS_DEFINE= DKIM
+OPTIONS_DEFAULT= DKIM
+
+DKIM_DESC= DKIM signing support
+DKIM_LIB_DEPENDS= libopendkim.so:mail/opendkim
+
.include <bsd.port.pre.mk>
# Workaround to prevent bsd.milter.mk from breaking the build with the recent clang
WITHOUT_MILTER_LDFLAGS= yes
.include "${PORTSDIR}/mail/sendmail/bsd.milter.mk"
+.if ! ${PORT_OPTIONS:MDKIM}
+CMAKE_ARGS+= -DENABLE_DKIM=OFF
+.endif
+
post-patch:
${SED} ${SUB_LIST:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${WRKSRC}/freebsd/rmilter > ${WRKDIR}/rmilter