aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-05-10 05:36:02 +0800
committerjylefort <jylefort@FreeBSD.org>2005-05-10 05:36:02 +0800
commit5f393b7dad258797bf0ea90e4aed1d18c82ef3ff (patch)
tree0248851d273276e2fc6c180551fb123e2e3ea787 /mail
parent682da29fefd5054c1070dd6f3e593e25e052fc16 (diff)
downloadfreebsd-ports-gnome-5f393b7dad258797bf0ea90e4aed1d18c82ef3ff.tar.gz
freebsd-ports-gnome-5f393b7dad258797bf0ea90e4aed1d18c82ef3ff.tar.zst
freebsd-ports-gnome-5f393b7dad258797bf0ea90e4aed1d18c82ef3ff.zip
- Update to 4.0.7
- Use OPTIONS PR: ports/80794 Submitted by: Radim Kolar <hsn@netmag.cz>
Diffstat (limited to 'mail')
-rw-r--r--mail/qpopper/Makefile106
-rw-r--r--mail/qpopper/distinfo8
-rw-r--r--mail/qpopper/files/extra-patch-popper::main.c27
-rw-r--r--mail/qpopper/files/extra-patch-popper::pop_init.c18
-rw-r--r--mail/qpopper/files/patch-aa21
-rw-r--r--mail/qpopper/files/patch-popper::pop_updt.c16
-rw-r--r--mail/qpopper/pkg-descr2
-rw-r--r--mail/qpopper/pkg-message1
8 files changed, 48 insertions, 151 deletions
diff --git a/mail/qpopper/Makefile b/mail/qpopper/Makefile
index f18c9cd96d6c..2621b0543e01 100644
--- a/mail/qpopper/Makefile
+++ b/mail/qpopper/Makefile
@@ -6,31 +6,18 @@
#
PORTNAME= qpopper
-PORTVERSION= 4.0.5
-PORTREVISION= 2
+PORTVERSION= 4.0.7
CATEGORIES= mail ipv6
-MASTER_SITES= ftp://ftp.qualcomm.com/eudora/servers/unix/popper/%SUBDIR%/
-MASTER_SITE_SUBDIR= . old
+MASTER_SITES= ftp://ftp.qualcomm.com/eudora/servers/unix/popper/ \
+ http://core.ring.gr.jp/archives/net/mail/qpopper/
DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Berkeley POP 3 server (now maintained by Qualcomm)
-.if !defined(WITHOUT_SSL)
-USE_OPENSSL= yes
-.endif
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 400014 && !defined(WITHOUT_IPV6)
-PATCH_SITES= http://www.imasy.or.jp/~ume/ipv6/
-PATCHFILES= qpopper4.0.5-ipv6-20030313.diff.gz
-PATCH_DIST_STRIP= -p1
-.endif
-
-USE_AUTOCONF_VER= 213
+USE_AUTOCONF_VER= 259
USE_REINPLACE= yes
-GNU_CONFIGURE= yes
+USE_OPENSSL= yes
CONFIGURE_ENV= LIBS="-lcrypt -lmd -lutil -L${LOCALBASE}/lib" \
OS_DEFS="-DSETPROCTITLE ${OS_DEFS}"
CONFIGURE_ARGS= --enable-nonauth-file=${POPUSERS_FILE} \
@@ -56,48 +43,32 @@ SAMPLE_EXT= .sample
#
PKGDEINSTALL= ${PKGINSTALL}
-pre-everything::
-.if defined(APOP_ONLY)
- @${ECHO_MSG} "==> The APOP_ONLY option is deprecated, please use"
- @${ECHO_MSG} " WITH_APOP_ONLY instead."
- @${ECHO_MSG} "==> The APOP_ONLY option will work in this version but"
- @${ECHO_MSG} " not on future ones."
-.endif
-.if defined(FULL_POPD_DEBUG)
- @${ECHO_MSG} "==> The FULL_POPD_DEBUG option is deprecated, please"
- @${ECHO_MSG} " use WITH_FULL_POPD_DEBUG instead."
- @${ECHO_MSG} "==> The FULL_POPD_DEBUG option will work in this version but"
- @${ECHO_MSG} " not on future ones."
-.endif
- @${ECHO_MSG} ""
- @${ECHO_MSG} "You may use the following build options:"
- @${ECHO_MSG} ""
- @${ECHO_MSG} "WITH_APOP_ONLY=yes builds with APOP authentication only"
- @${ECHO_MSG} "WITHOUT_APOP=yes builds without APOP authentication"
- @${ECHO_MSG} "WITH_DOCUMENTATION=yes installs pdf documentation"
- @${ECHO_MSG} "WITH_DRAC=yes builds with Dynamic Relay Authorization"
- @${ECHO_MSG} " Control support"
- @${ECHO_MSG} "WITHOUT_IPV6=yes builds without IPv6 support"
- @${ECHO_MSG} "WITH_FULL_POPD_DEBUG=yes builds with more verbose debugging"
- @${ECHO_MSG} "WITH_PAM=yes builds with PAM authentication"
- @${ECHO_MSG} "WITH_POPPASSD=yes builds the poppassd daemon"
- @${ECHO_MSG} "WITHOUT_QPOPAUTH_SETUID=yes does not install qpopauth setuid to pop user"
- @${ECHO_MSG} "WITH_SAMPLE_POPUSERS_FILE=yes builds a default (otherwise,"
- @${ECHO_MSG} " use an empty file) reject file"
- @${ECHO_MSG} "WITH_SHY_ENABLED=yes enables shy mode, don't present"
- @${ECHO_MSG} " qpopper version number in POP3 session"
- @${ECHO_MSG} "WITHOUT_SSL=yes builds without SSL/TLS support"
- @${ECHO_MSG} "WITH_STANDALONE_MODE=yes builds qpopper to be run without inetd"
- @${ECHO_MSG} "WITHOUT_U_OPTION=yes forbids daemon command line option"
- @${ECHO_MSG} " -u which allows, after a user authenticates,"
- @${ECHO_MSG} " process options to be read from a file called"
- @${ECHO_MSG} " .qpopper-options in the user's home directory"
- @${ECHO_MSG} " This file can be owned by and writable by the"
- @${ECHO_MSG} " user. If improperly written, may cause a buffer"
- @${ECHO_MSG} " overflow which may remove such user's mail box"
- @${ECHO_MSG} "WITH_Y_OPTION=yes enables daemon command line option"
- @${ECHO_MSG} " -y which allows the user to specify a different"
- @${ECHO_MSG} " logging facility"
+OPTIONS= APOP_ONLY "build with APOP authentication only" off \
+ APOP "build with APOP" on \
+ DOCUMENTATION "install pdf documentation" off \
+ DRAC "build with Dynamic Relay Authorization" off \
+ IPV6 "build with IPv6 support" on \
+ FULL_POPD_DEBUG "build with more verbose debugging" off \
+ PAM "build with PAM authentication" off \
+ POPPASSD "build the poppassd daemon" off \
+ QPOPAUTH_SETUID "install qpopauth setuid to pop user" on \
+ SAMPLE_POPUSERS "build a default reject file" off \
+ SHY_ENABLED "hide qpopper version in POP3 banner" off \
+ SSL "build with SSL/TLS support" on \
+ STANDALONE_MODE "build qpopper to be run without inetd" off \
+ U_OPTION "include support for user .qpopper-options" on
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 400014
+WITHOUT_IPV6= yes
+.endif
+
+.if !defined(WITHOUT_IPV6)
+PATCH_SITES= http://home.tiscali.cz:8080/~cz210552/bsdports/tarballs/
+PATCHFILES= qpopper4.0.7-inet6-20030313.diff.gz
+PATCH_DIST_STRIP= -p2
+.endif
.if defined(WITHOUT_APOP)
QPOPAUTH= "@comment "
@@ -108,7 +79,7 @@ MAN8+= qpopauth.8
QPOPAUTH= ""
# If WITH_APOP_ONLY variable present in the environment, qpopper builds
# with APOP authentication only.
-.if defined(APOP_ONLY) || defined(WITH_APOP_ONLY)
+.if defined(WITH_APOP_ONLY)
OS_DEFS+= -DAPOP_ONLY
.endif
.endif
@@ -128,7 +99,7 @@ BUILD_DEPENDS+= ${LOCALBASE}/lib/libdrac.a:${PORTSDIR}/mail/drac
# If WITH_FULL_POPD_DEBUG variable present in the environment, qpopper builds
# with more verbose debugging. See also -d option to qpopper.
-.if defined(FULL_POPD_DEBUG) || defined(WITH_FULL_POPD_DEBUG)
+.if defined(WITH_FULL_POPD_DEBUG)
CONFIGURE_ARGS+= --enable-debugging
.endif
@@ -160,15 +131,6 @@ CONFIGURE_ARGS+= --enable-shy
CONFIGURE_ARGS+= --enable-standalone
.endif
-# If WITH_Y_OPTION variable present, qoppper daemon will
-# accept -y command line option which allows the user to specify a
-# different logging facility.
-.if defined(WITH_Y_OPTION)
-EXTRA_PATCHES+= \
- ${FILESDIR}/extra-patch-popper::pop_init.c \
- ${FILESDIR}/extra-patch-popper::main.c
-.endif
-
# The default is to build without SSL/TLS support.
.if !defined(WITHOUT_SSL)
CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
@@ -221,7 +183,7 @@ post-install: install-conf-file
# <clefevre@citeweb.net>.
install-conf-file:
@if [ ! -f ${CONF_DIR}/${CONF_FILE}${SAMP_SUFX} ]; then \
- if [ -f /etc/ftpusers ] && [ -n "${WITH_SAMPLE_POPUSERS_FILE}" ]; then \
+ if [ -f /etc/ftpusers ] && [ -n "${WITH_SAMPLE_POPUSERS}" ]; then \
${INSTALL} -c -o ${POP_USER} -g ${POP_GROUP} -m ${POP_MODE_CONF} \
/etc/ftpusers ${POPUSERS_FILE}${SAMPLE_EXT} ; \
else \
diff --git a/mail/qpopper/distinfo b/mail/qpopper/distinfo
index 7fbc3ae4cdf6..63ab98c8e1a9 100644
--- a/mail/qpopper/distinfo
+++ b/mail/qpopper/distinfo
@@ -1,4 +1,4 @@
-MD5 (qpopper4.0.5.tar.gz) = e00853280c9e899711f0b0239d3d8f86
-SIZE (qpopper4.0.5.tar.gz) = 2281284
-MD5 (qpopper4.0.5-ipv6-20030313.diff.gz) = 1d4b68ab55b95fb1d12528c505f24e5a
-SIZE (qpopper4.0.5-ipv6-20030313.diff.gz) = 53985
+MD5 (qpopper4.0.7.tar.gz) = c9e818cfca00cc196d4b883804f8c905
+SIZE (qpopper4.0.7.tar.gz) = 2350782
+MD5 (qpopper4.0.7-inet6-20030313.diff.gz) = 78d67bc88491219b83d1b4d323801a49
+SIZE (qpopper4.0.7-inet6-20030313.diff.gz) = 9015
diff --git a/mail/qpopper/files/extra-patch-popper::main.c b/mail/qpopper/files/extra-patch-popper::main.c
deleted file mode 100644
index 0eb9258666a8..000000000000
--- a/mail/qpopper/files/extra-patch-popper::main.c
+++ /dev/null
@@ -1,27 +0,0 @@
---- popper/main.c.orig Thu Jan 2 00:38:40 2003
-+++ popper/main.c Tue Dec 14 11:32:49 2004
-@@ -343,6 +343,24 @@
- trace_name, fileno(trace_file) );
- break;
-
-+ case 'y': /* log facility */
-+ {
-+ POP config;
-+ POP *p = &config;
-+ if ( set_option ( p, "log-facility", optarg ) == POP_SUCCESS ) {
-+ closelog();
-+#ifdef SYSLOG42
-+ openlog ( pname, 0 );
-+#else
-+ openlog ( pname, POP_LOGOPTS, p->log_facility );
-+#endif
-+ } else {
-+ fprintf ( stderr, "Error setting '-y' to %s\n", optarg );
-+ return 1;
-+ }
-+ }
-+ break;
-+
- default:
- break;
- }
diff --git a/mail/qpopper/files/extra-patch-popper::pop_init.c b/mail/qpopper/files/extra-patch-popper::pop_init.c
deleted file mode 100644
index 00a417d87f1b..000000000000
--- a/mail/qpopper/files/extra-patch-popper::pop_init.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- popper/pop_init.c.orig Sun Dec 1 13:49:35 2002
-+++ popper/pop_init.c Sun Dec 1 13:51:24 2002
-@@ -907,6 +907,7 @@
- fprintf ( stderr, "Error setting '-y' to %s\n", optarg );
- errflag++;
- }
-+ break;
-
- default: /* Unknown option received */
- errflag++;
-@@ -979,6 +980,7 @@
- "[-u] "
- "[-U] "
- "[-v] "
-+ "[-y log-facility] "
- "\n",
- argmessage[0],
- xB, /* -B (or not) */
diff --git a/mail/qpopper/files/patch-aa b/mail/qpopper/files/patch-aa
index e681f96fddde..81dd6f5ae4c3 100644
--- a/mail/qpopper/files/patch-aa
+++ b/mail/qpopper/files/patch-aa
@@ -1,9 +1,6 @@
-
-$FreeBSD$
-
---- popper/Makefile.in.orig Wed Apr 4 03:23:22 2001
-+++ popper/Makefile.in Fri Apr 13 19:03:27 2001
-@@ -106,9 +106,9 @@
+--- popper/Makefile.in.orig Tue Apr 26 05:14:37 2005
++++ popper/Makefile.in Sat May 7 20:37:09 2005
+@@ -119,9 +119,9 @@
pop_msg.o pop_parse.o pop_pass.o pop_quit.o \
pop_rset.o pop_send.o pop_stat.o pop_updt.o \
pop_user.o pop_xtnd.o pop_xmit.o popper.o \
@@ -15,8 +12,8 @@ $FreeBSD$
+ pop_extend.o scram.o hmac.o pop_util.o \
get_sub_opt.o msg_ptr.o drac.o pop_config.o pop_tls.o \
pop_tls_openssl.o pop_tls_sslplus.o sslplus_utils.o \
- main.o pop_cache.o genpath.o
-@@ -119,17 +119,17 @@
+ main.o pop_cache.o genpath.o
+@@ -132,17 +132,17 @@
pop_msg.c pop_parse.c pop_pass.c pop_quit.c \
pop_rset.c pop_send.c pop_stat.c pop_updt.c \
pop_user.c pop_xtnd.c pop_xmit.c popper.c \
@@ -28,19 +25,19 @@ $FreeBSD$
+ pop_extend.c scram.c hmac.c pop_util.c \
get_sub_opt.c msg_ptr.c drac.c pop_config.c pop_tls.c \
pop_tls_openssl.c pop_tls_sslplus.c sslplus_utils.c \
- main.c pop_cache.c genpath.c
+ main.c pop_cache.c genpath.c
-POPAUTHOBJS = base64.o scram.o md5.o \
+POPAUTHOBJS = scram.o \
- hmac.o popauth.o
+ hmac.o popauth.o
-POPAUTHSRCS = base64.c scram.c md5.c \
+POPAUTHSRCS = scram.c \
hmac.c popauth.c
INCLUDES = ${srcdir}/popper.h \
-@@ -180,7 +180,7 @@
- ${LIBS}
+@@ -195,7 +195,7 @@
+ ${LIBS} ${LDFLAGS}
popauth: ${POPAUTHOBJS}
- ${CC} -o popauth ${POPAUTHOBJS} ${NETWORK_LIBS} ${DBM_LIBS} \
diff --git a/mail/qpopper/files/patch-popper::pop_updt.c b/mail/qpopper/files/patch-popper::pop_updt.c
deleted file mode 100644
index 32465704ca44..000000000000
--- a/mail/qpopper/files/patch-popper::pop_updt.c
+++ /dev/null
@@ -1,16 +0,0 @@
---- popper/pop_updt.c.orig Tue Dec 14 17:18:10 2004
-+++ popper/pop_updt.c Tue Dec 14 17:18:57 2004
-@@ -531,11 +531,13 @@
- if ( fputs ( buffer, md ) == EOF )
- break;
-
-+ if ( p->bUpdate_status_hdrs ) {
- sprintf ( buffer, "X-UIDL: %s", mp->uidl_str );
- if ( fputs ( buffer, md ) == EOF )
- break;
- length += strlen ( buffer ) + 1; /* for CRLF */
- lines ++;
-+ }
-
- for ( status_written = 0, inheader = 1;
- fgets ( buffer, MAXMSGLINELEN, p->drop );
diff --git a/mail/qpopper/pkg-descr b/mail/qpopper/pkg-descr
index 4485bee07a73..690c374d3561 100644
--- a/mail/qpopper/pkg-descr
+++ b/mail/qpopper/pkg-descr
@@ -3,4 +3,4 @@ such as Eudora.
Don't forget to edit /etc/inetd.conf to enable the server after installation.
-WWW: http://www.eudora.com/qpopper/
+WWW: http://www.eudora.com/products/unsupported/qpopper/index.html
diff --git a/mail/qpopper/pkg-message b/mail/qpopper/pkg-message
index f54fdfea9d01..b41a75718797 100644
--- a/mail/qpopper/pkg-message
+++ b/mail/qpopper/pkg-message
@@ -4,4 +4,3 @@ To enable the qpopper-daemon, add the following line to your /etc/inetd.conf:
pop3 stream tcp nowait root /usr/local/libexec/qpopper qpopper -s
****************************************************************************
-