aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2013-02-08 01:06:44 +0800
committerpawel <pawel@FreeBSD.org>2013-02-08 01:06:44 +0800
commit66c5ab8b95acfae3d68e5e938ffaa43fcc73ea94 (patch)
treeac0c5e20bfde8b2d6f9250961d390ca6728ec25a /mail
parentb5e7b8bbfe6e15ab740ec3ecc974c9bf0c042ecc (diff)
downloadfreebsd-ports-gnome-66c5ab8b95acfae3d68e5e938ffaa43fcc73ea94.tar.gz
freebsd-ports-gnome-66c5ab8b95acfae3d68e5e938ffaa43fcc73ea94.tar.zst
freebsd-ports-gnome-66c5ab8b95acfae3d68e5e938ffaa43fcc73ea94.zip
Remove PTHREAD_CFLAGS and PTHREAD_LIBS from my ports
Diffstat (limited to 'mail')
-rw-r--r--mail/claws-mail/Makefile3
-rw-r--r--mail/libetpan/Makefile4
2 files changed, 3 insertions, 4 deletions
diff --git a/mail/claws-mail/Makefile b/mail/claws-mail/Makefile
index 271c5f98a019..02b99be04861 100644
--- a/mail/claws-mail/Makefile
+++ b/mail/claws-mail/Makefile
@@ -48,12 +48,11 @@ MAKE_JOBS_SAFE= yes
MAN1= claws-mail.1
-CFLAGS+= ${PTHREAD_CFLAGS}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE} --disable-dbus
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -pthread"
OPTIONS_DEFINE= BOGOFILTER COMPFACE DEBUG DILLO ENCHANT GPGME IPV6 JPILOT LDAP \
MANUAL SPAMASSASSIN STARTUP THEMES
diff --git a/mail/libetpan/Makefile b/mail/libetpan/Makefile
index 0c8e1b969da3..f50c99f37974 100644
--- a/mail/libetpan/Makefile
+++ b/mail/libetpan/Makefile
@@ -23,8 +23,8 @@ USE_ICONV= yes
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -pthread
OPTIONS_DEFINE= IPV6
OPTIONS_SINGLE= CRYPTO