aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-11-20 11:55:23 +0800
committermarino <marino@FreeBSD.org>2016-11-20 11:55:23 +0800
commit6a4b72066599538c7d02376906dce2e94d5c032e (patch)
tree16528a307b9bf6d0717f9227c8d867d109ee2b09 /mail
parent27eede0566d4186e133848f2d1d3e2d9df8b000b (diff)
downloadfreebsd-ports-gnome-6a4b72066599538c7d02376906dce2e94d5c032e.tar.gz
freebsd-ports-gnome-6a4b72066599538c7d02376906dce2e94d5c032e.tar.zst
freebsd-ports-gnome-6a4b72066599538c7d02376906dce2e94d5c032e.zip
mail/spamdyke: Fix OPENSSL configuration, cleanup
After fixing a configure phase failure to find openssl headers, fix alignment, remove excess blank lines and pet portlint.
Diffstat (limited to 'mail')
-rw-r--r--mail/spamdyke/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/mail/spamdyke/Makefile b/mail/spamdyke/Makefile
index 11895d7b798d..b665cbaf8fb0 100644
--- a/mail/spamdyke/Makefile
+++ b/mail/spamdyke/Makefile
@@ -12,27 +12,26 @@ COMMENT= Qmail filter for monitoring and intercepting SMTP connections
LICENSE= GPLv2
-BROKEN_powerpc64= Does not build
-
RUN_DEPENDS= ${LOCALBASE}/bin/tcprules:sysutils/ucspi-tcp
-WRKSRC= ${WRKDIR}/${DISTNAME}/spamdyke
+BROKEN_powerpc64= Does not build
USES= cpe qmail tar:tgz
-
+WRKSRC= ${WRKDIR}/${DISTNAME}/spamdyke
GNU_CONFIGURE= yes
-
ALL_TARGET= spamdyke
-
USE_GCC= any
-OPTIONS_DEFINE= TLS DEBUG DEBUG_EXCESSIVE DOCS
+OPTIONS_DEFINE= TLS DEBUG DEBUG_EXCESSIVE DOCS
OPTIONS_DEFAULT= TLS
-DEBUG_DESC= Enable debugging output
+DEBUG_DESC= Enable debugging output
DEBUG_EXCESSIVE_DESC= Enable excessive debugging output
-TLS_CONFIGURE_ENABLE= tls
-TLS_USE= OPENSSL=yes
+TLS_CONFIGURE_ENABLE= tls
+TLS_USES= ssl
+TLS_LDFLAGS= -L${OPENSSLLIB}
+TLS_CFLAGS= -I${OPENSSLINC}
+
DEBUG_CONFIGURE_ENABLE= debug-output
DEBUG_EXCESSIVE_CONFIGURE_ENABLE= excessive-output