aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2011-02-14 00:09:40 +0800
committerarved <arved@FreeBSD.org>2011-02-14 00:09:40 +0800
commit6ff797d0a45eaf0e6501cc424ec282b523238702 (patch)
treec75fadec74200399e9bb39774242279926e2889e /mail
parent0ccd504c2be45e0aea49235d1ec246c56d799732 (diff)
downloadfreebsd-ports-gnome-6ff797d0a45eaf0e6501cc424ec282b523238702.tar.gz
freebsd-ports-gnome-6ff797d0a45eaf0e6501cc424ec282b523238702.tar.zst
freebsd-ports-gnome-6ff797d0a45eaf0e6501cc424ec282b523238702.zip
Build with bind97 instead of libbind.
PR: 154090 Submitted by: Hirohisa Yamaguchi <umq@ueo.co.jp> Reported by: HAMADA Takeshi <hamm@crimson-jp.org>
Diffstat (limited to 'mail')
-rw-r--r--mail/enma/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/mail/enma/Makefile b/mail/enma/Makefile
index 43b4477f02c6..777db5bc897a 100644
--- a/mail/enma/Makefile
+++ b/mail/enma/Makefile
@@ -7,13 +7,14 @@
PORTNAME= enma
PORTVERSION= 1.1.0
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= SF/${PORTNAME}/ENMA/${PORTVERSION}
MAINTAINER= umq@ueo.co.jp
COMMENT= A sender authentication milter supporting SPF and Sender ID
-BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/dns/libbind:checksum
+BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/dns/bind97:checksum
.if defined(WITH_POSTFIX_MILTER) || defined(WITH_POSTFIX) || defined(WITH_POSTFIX_CURRENT)
CONF_SUB= ${REINPLACE_CMD} -e '/milter\.postfix/s/false/true/' ${WRKSRC}/enma/etc/enma.conf.sample
@@ -24,7 +25,7 @@ RUN_DEPENDS+= ${LOCALBASE}/libexec/postfix/smtpd:${PORTSDIR}/mail/postfix
.endif
.endif
-BIND_PATH_CMD= cd ${PORTSDIR}/dns/libbind && ${MAKE} -V WRKSRC
+BIND_PATH_CMD= cd ${PORTSDIR}/dns/bind97 && ${MAKE} -V WRKSRC
BIND_SRC_DIR= ${BASENAME} $$(${BIND_PATH_CMD})
HAS_CONFIGURE= yes
@@ -51,10 +52,16 @@ WITH_OPENSSL_PORT= yes
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
pre-configure:
- cd ${PORTSDIR}/dns/libbind && ${MAKE} -DBATCH patch && \
+ cd ${PORTSDIR}/dns/bind97 && ${MAKE} -DBATCH patch && \
${LN} -s $$(${BIND_PATH_CMD}) ${WRKSRC}/build && \
cd ${WRKSRC}/build/$$(${BIND_SRC_DIR}) && \
- ./configure --prefix=${WRKSRC}/build/tmp_build --enable-threads && ${MAKE} && ${MAKE} install
+ ./configure --prefix=${WRKSRC}/build/tmp_build --enable-threads && \
+ cd ${WRKSRC}/build/$$(${BIND_SRC_DIR})/lib/dns && \
+ ${MAKE} include/dns/enumtype.h include/dns/enumclass.h && \
+ cd ${WRKSRC}/build/$$(${BIND_SRC_DIR})/lib/bind9 && \
+ ${MAKE} && ${MAKE} install
+ ${REINPLACE_CMD} -e 's/-lbind/-lbind9/' ${WRKSRC}/configure \
+ ${WRKSRC}/enma/bin/Makefile.in ${WRKSRC}/enma/src/Makefile.in
$$(${CONF_SUB})
post-install: