aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-08-01 13:46:22 +0800
committerbapt <bapt@FreeBSD.org>2013-08-01 13:46:22 +0800
commit831193a625c4ef7ed64f9945433e3e641c952f7f (patch)
tree609cb3f62678beb8355ae0894c5abeabe2d93d9e /mail
parent139b33c54eae02e13d7c810cc741291199d8c8b3 (diff)
downloadfreebsd-ports-gnome-831193a625c4ef7ed64f9945433e3e641c952f7f.tar.gz
freebsd-ports-gnome-831193a625c4ef7ed64f9945433e3e641c952f7f.tar.zst
freebsd-ports-gnome-831193a625c4ef7ed64f9945433e3e641c952f7f.zip
Fix build with clang
Trim header Remove leading indefinite article tab -> space in pkg-descr optionsng USE_GMAKE -> USES=gmake
Diffstat (limited to 'mail')
-rw-r--r--mail/wmpop3lb/Makefile26
-rw-r--r--mail/wmpop3lb/pkg-descr2
2 files changed, 11 insertions, 17 deletions
diff --git a/mail/wmpop3lb/Makefile b/mail/wmpop3lb/Makefile
index ddd3d987a8c9..1aad5f9ff9b5 100644
--- a/mail/wmpop3lb/Makefile
+++ b/mail/wmpop3lb/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: wmpop3lb
-# Date created: 2007-07-06
-# Whom: Otavio Fernandes <otaviof@gmail.com>
-#
+# Created by: Otavio Fernandes <otaviof@gmail.com>
# $FreeBSD$
-#
PORTNAME= wmpop3lb
PORTVERSION= 2.4.2
@@ -14,36 +10,34 @@ MASTER_SITE_SUBDIR= distfiles
DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= otaviof@gmail.com
-COMMENT= A WindowMaker dock app for multi POP3 accounts mailbox checking
+COMMENT= WindowMaker dock app for multi POP3 accounts mailbox checking
-USE_GMAKE= yes
+USES= gmake
USE_XORG= xext xpm
+USE_CSTD= gnu89
CFLAGS+= -I${LOCALBASE}/include
PLIST_FILES= bin/wmpop3lb
PORTDOCS= CHANGE_LOG COPYING INSTALL README
-WRKSRC_BUILD= ${WRKSRC}/wmpop3
-
-.include <bsd.port.pre.mk>
+BUILD_WRKSRC= ${WRKSRC}/wmpop3
post-patch:
@${REINPLACE_CMD} -e "s,cc ,${CC} ,g" \
-e "s,^FLAGS *=.*$$,FLAGS = ${CFLAGS}," \
-e "s,/usr/X11R6,${LOCALBASE},g" \
- ${WRKSRC_BUILD}/Makefile
+ ${BUILD_WRKSRC}/Makefile
-do-build:
- @cd ${WRKSRC_BUILD} && ${GMAKE}
+.include <bsd.port.options.mk>
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC_BUILD}/${PORTNAME} ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
. for doc in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
. endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/wmpop3lb/pkg-descr b/mail/wmpop3lb/pkg-descr
index 557a494559a9..5f3cfca7491d 100644
--- a/mail/wmpop3lb/pkg-descr
+++ b/mail/wmpop3lb/pkg-descr
@@ -4,4 +4,4 @@ fields of each mail and display them in a 7 lines window. Messages can be
deleted directly off the servers by selecting the mails to delete and clicking
the "delete" button.
-WWW: http://wmpop3lb.jourdain.org/
+WWW: http://wmpop3lb.jourdain.org/