aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-12-19 22:28:06 +0800
committerbapt <bapt@FreeBSD.org>2012-12-19 22:28:06 +0800
commit9a4e521b888d6fbe5ca8099bcd170f0a090968e9 (patch)
treefb9ca011aaee029d9c3ca57b1a8e43d2e7743378 /mail
parenta5742a2b4fd02edebd376faa8ca8148e20fd8e0b (diff)
downloadfreebsd-ports-gnome-9a4e521b888d6fbe5ca8099bcd170f0a090968e9.tar.gz
freebsd-ports-gnome-9a4e521b888d6fbe5ca8099bcd170f0a090968e9.tar.zst
freebsd-ports-gnome-9a4e521b888d6fbe5ca8099bcd170f0a090968e9.zip
DeforaOS desktop mail client
PR: ports/173000 Submitted by: Olivier Cochard-Labbe <olivier@cochard.me>
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/deforaos-mailer/Makefile37
-rw-r--r--mail/deforaos-mailer/distinfo2
-rw-r--r--mail/deforaos-mailer/files/patch-doc__Makefile30
-rw-r--r--mail/deforaos-mailer/pkg-descr3
-rw-r--r--mail/deforaos-mailer/pkg-plist42
6 files changed, 115 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 034497cb15b2..161033d51274 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -88,6 +88,7 @@
SUBDIR += dbmail
SUBDIR += dbmail22
SUBDIR += dcc-dccd
+ SUBDIR += deforaos-mailer
SUBDIR += delatt
SUBDIR += dk-milter
SUBDIR += dkfilter
diff --git a/mail/deforaos-mailer/Makefile b/mail/deforaos-mailer/Makefile
new file mode 100644
index 000000000000..ffd3dc4a7ca5
--- /dev/null
+++ b/mail/deforaos-mailer/Makefile
@@ -0,0 +1,37 @@
+# Created by: Olivier Cochard-Labbe <olivier@cochard.me>
+# $FreeBSD$
+
+PORTNAME= mailer
+PORTVERSION= 0.1.5
+CATEGORIES= mail
+MASTER_SITES= http://www.defora.org/os/download/download/3704/
+DISTNAME= Mailer-${PORTVERSION}
+PKGNAMEPREFIX= deforaos-
+
+MAINTAINER= olivier@cochard.me
+COMMENT= DeforaOS desktop mail client
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt \
+ ${LOCALBASE}/share/xsl/docbook/manpages/docbook.xsl:${PORTSDIR}/textproc/docbook-xsl
+LIB_DEPENDS= System:${PORTSDIR}/devel/deforaos-libsystem \
+ Desktop:${PORTSDIR}/x11/deforaos-libdesktop
+
+USE_GNOME= gtk20 desktopfileutils
+USE_PKGCONFIG= build
+USE_GETTEXT= yes
+INSTALLS_ICONS= yes
+USE_LDCONFIG= yes
+USE_OPENSSL= yes
+
+MAKE_ENV+= MANDIR=${MANPREFIX}/man
+
+MAN1= compose.1 \
+ mailer.1
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|/lib/|/libdata/|g' \
+ ${WRKSRC}/data/pkgconfig.sh
+
+.include <bsd.port.mk>
diff --git a/mail/deforaos-mailer/distinfo b/mail/deforaos-mailer/distinfo
new file mode 100644
index 000000000000..fe8a17585343
--- /dev/null
+++ b/mail/deforaos-mailer/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Mailer-0.1.5.tar.gz) = dc3d7d0501a08c047dfbd6dce9504dea844d4b5bff7fad90b8e6439342dea64d
+SIZE (Mailer-0.1.5.tar.gz) = 105898
diff --git a/mail/deforaos-mailer/files/patch-doc__Makefile b/mail/deforaos-mailer/files/patch-doc__Makefile
new file mode 100644
index 000000000000..e8b2b1d13e70
--- /dev/null
+++ b/mail/deforaos-mailer/files/patch-doc__Makefile
@@ -0,0 +1,30 @@
+--- ./doc/Makefile.orig 2012-10-14 19:06:02.000000000 +0200
++++ ./doc/Makefile 2012-12-19 15:18:51.668613464 +0100
+@@ -1,5 +1,5 @@
+ SUBDIRS = gtkdoc
+-TARGETS = compose.1 compose.html gtkdoc/Mailer.types gtkdoc/tmpl.stamp gtkdoc/sgml.stamp gtkdoc/html.stamp mailer.1 mailer.html
++TARGETS = compose.1 mailer.1
+ PREFIX = /usr/local
+ DESTDIR =
+ RM ?= rm -f
+@@ -8,7 +8,7 @@
+ INSTALL ?= install
+
+
+-all: subdirs $(TARGETS)
++all: $(TARGETS)
+
+ subdirs:
+ @for i in $(SUBDIRS); do (cd $$i && $(MAKE)) || exit; done
+@@ -48,9 +48,8 @@
+
+ install: $(TARGETS)
+ @for i in $(SUBDIRS); do (cd $$i && $(MAKE) install) || exit; done
+- ./docbook.sh -P "$(DESTDIR)$(PREFIX)" -i -- "compose.html"
+- ./gtkdoc.sh -P "$(DESTDIR)$(PREFIX)" -i -- "gtkdoc/html.stamp"
+- ./docbook.sh -P "$(DESTDIR)$(PREFIX)" -i -- "mailer.html"
++ ./docbook.sh -P "$(DESTDIR)$(PREFIX)" -i -- "compose.1"
++ ./docbook.sh -P "$(DESTDIR)$(PREFIX)" -i -- "mailer.1"
+
+ uninstall:
+ @for i in $(SUBDIRS); do (cd $$i && $(MAKE) uninstall) || exit; done
diff --git a/mail/deforaos-mailer/pkg-descr b/mail/deforaos-mailer/pkg-descr
new file mode 100644
index 000000000000..3eaa222ba6ed
--- /dev/null
+++ b/mail/deforaos-mailer/pkg-descr
@@ -0,0 +1,3 @@
+DeforaOS desktop mail client
+
+WWW: http://www.defora.org/
diff --git a/mail/deforaos-mailer/pkg-plist b/mail/deforaos-mailer/pkg-plist
new file mode 100644
index 000000000000..853bc2fccf00
--- /dev/null
+++ b/mail/deforaos-mailer/pkg-plist
@@ -0,0 +1,42 @@
+bin/compose
+bin/mailer
+include/Desktop/Mailer.h
+include/Desktop/Mailer/account.h
+include/Desktop/Mailer/folder.h
+include/Desktop/Mailer/helper.h
+include/Desktop/Mailer/mailer.h
+include/Desktop/Mailer/message.h
+include/Desktop/Mailer/plugin.h
+include/Desktop/Mailer/transport.h
+lib/Mailer/account/imap4.so
+lib/Mailer/account/mbox.so
+lib/Mailer/account/pop3.so
+lib/Mailer/plugins/mailing-lists.so
+lib/Mailer/plugins/search.so
+lib/libMailer.a
+lib/libMailer.so
+lib/libMailer.so.0
+lib/libMailer.so.0.0
+libdata/pkgconfig/Mailer.pc
+share/applications/mailer.desktop
+share/icons/hicolor/16x16/apps/mailer-accounts.png
+share/icons/hicolor/16x16/apps/mailer-drafts.png
+share/icons/hicolor/16x16/apps/mailer-inbox.png
+share/icons/hicolor/16x16/apps/mailer-outbox.png
+share/icons/hicolor/16x16/apps/mailer-sent.png
+share/icons/hicolor/16x16/apps/mailer.png
+share/icons/hicolor/24x24/apps/mailer-accounts.png
+share/icons/hicolor/24x24/apps/mailer-drafts.png
+share/icons/hicolor/24x24/apps/mailer-inbox.png
+share/icons/hicolor/24x24/apps/mailer-outbox.png
+share/icons/hicolor/24x24/apps/mailer-sent.png
+share/icons/hicolor/24x24/apps/mailer.png
+share/icons/hicolor/48x48/apps/mailer-inbox.png
+share/icons/hicolor/48x48/apps/mailer-outbox.png
+share/icons/hicolor/48x48/apps/mailer-sent.png
+share/icons/hicolor/48x48/apps/mailer.png
+share/locale/fr/LC_MESSAGES/Mailer.mo
+@dirrm include/Desktop/Mailer
+@dirrm lib/Mailer/account
+@dirrm lib/Mailer/plugins
+@dirrm lib/Mailer
38 +0800'>2006-05-143-26/+174 * Remove whitespace from line endings in pkg-plist files.vd2006-05-121-11/+11 * - Update to 0.50.1stefan2006-05-114-33/+29 * Update to 3.0.1 release.ale2006-05-102-4/+4 * Chase gmp library and bump PORTREVISION.ale2006-05-101-2/+2 * Remove USE_REINPLACE from categories starting with a Jedwin2006-05-0922-26/+0 * Mark RESTRICTED and require manual fetching (netcomponents may not belawrance2006-05-071-2/+11 * Update distfile name. Checksum unchanged.lawrance2006-05-072-4/+3 * . Add a pkg-message file describing the known problems. The SIGBUS on MPglewis2006-05-042-0/+24 * - Update to 4.1.1 [1]hq2006-05-033-14/+13 * . Bump PORTREVISION for the previous fix.glewis2006-04-271-1/+1 * . Avoid stomping on environment variables by prefixing variable names withglewis2006-04-271-123/+121 * . Make diablo-jdk15 the default bootstrap JDK for i386.glewis2006-04-262-2/+8 * . Fix key recognition problems when NumLock is on.glewis2006-04-264-0/+120 * . Remove th