aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2004-08-12 20:48:01 +0800
committermat <mat@FreeBSD.org>2004-08-12 20:48:01 +0800
commitb2915fd9d1aba9c155acea1793e42c7659e36be8 (patch)
tree7f1b6a044bd73b3a561e1fee38519f0ba6679d11 /mail
parent1140f51cbed662c0f6dbd4ef84e3b5f2849f7cbd (diff)
downloadfreebsd-ports-gnome-b2915fd9d1aba9c155acea1793e42c7659e36be8.tar.gz
freebsd-ports-gnome-b2915fd9d1aba9c155acea1793e42c7659e36be8.tar.zst
freebsd-ports-gnome-b2915fd9d1aba9c155acea1793e42c7659e36be8.zip
After devel/p5-File-Temp has gained an IGNORE for PERL_LEVEL > 500800, all
these ports were broken because they always depended on it. I've rearranged all the dependencies to fit the new scheme.
Diffstat (limited to 'mail')
-rw-r--r--mail/mailscanner-devel/Makefile4
-rw-r--r--mail/mailscanner/Makefile4
-rw-r--r--mail/p5-Mail-GnuPG/Makefile4
3 files changed, 9 insertions, 3 deletions
diff --git a/mail/mailscanner-devel/Makefile b/mail/mailscanner-devel/Makefile
index d268fcd4799b..348c85835ba5 100644
--- a/mail/mailscanner-devel/Makefile
+++ b/mail/mailscanner-devel/Makefile
@@ -22,7 +22,6 @@ BUILD_DEPENDS= \
${SITE_PERL}/HTML/Tagset.pm:${PORTSDIR}/www/p5-HTML-Tagset \
${SITE_PERL}/${PERL_ARCH}/HTML/HeadParser.pm:${PORTSDIR}/www/p5-HTML-Parser \
${SITE_PERL}/MIME/Parser.pm:${PORTSDIR}/mail/p5-MIME-Tools \
- ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
${SITE_PERL}/Convert/TNEF.pm:${PORTSDIR}/converters/p5-Convert-TNEF \
${SITE_PERL}/Convert/BinHex.pm:${PORTSDIR}/converters/p5-Convert-BinHex \
${SITE_PERL}/Net/CIDR.pm:${PORTSDIR}/net-mgmt/p5-Net-CIDR \
@@ -50,10 +49,13 @@ MLINKS= MailScanner.8 mailscanner.8 \
.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
.if ${PERL_LEVEL} < 500601
BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
RUN_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
.endif
+.endif
DOC_FILES= INSTALL INSTALL.FreeBSD INSTALL.OpenBSD README
ETC_FILES= MailScanner.conf filename.rules.conf \
diff --git a/mail/mailscanner/Makefile b/mail/mailscanner/Makefile
index e9e16c7a52d6..f5e8ff7639db 100644
--- a/mail/mailscanner/Makefile
+++ b/mail/mailscanner/Makefile
@@ -21,7 +21,6 @@ BUILD_DEPENDS= \
${SITE_PERL}/HTML/Tagset.pm:${PORTSDIR}/www/p5-HTML-Tagset \
${SITE_PERL}/${PERL_ARCH}/HTML/HeadParser.pm:${PORTSDIR}/www/p5-HTML-Parser \
${SITE_PERL}/MIME/Parser.pm:${PORTSDIR}/mail/p5-MIME-Tools \
- ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
${SITE_PERL}/Convert/TNEF.pm:${PORTSDIR}/converters/p5-Convert-TNEF \
${SITE_PERL}/Convert/BinHex.pm:${PORTSDIR}/converters/p5-Convert-BinHex \
${SITE_PERL}/Net/CIDR.pm:${PORTSDIR}/net-mgmt/p5-Net-CIDR \
@@ -49,10 +48,13 @@ MLINKS= MailScanner.8 mailscanner.8 \
.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
.if ${PERL_LEVEL} < 500601
BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
RUN_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
.endif
+.endif
DOC_FILES= INSTALL INSTALL.FreeBSD INSTALL.OpenBSD README
ETC_FILES= MailScanner.conf filename.rules.conf \
diff --git a/mail/p5-Mail-GnuPG/Makefile b/mail/p5-Mail-GnuPG/Makefile
index d621f136016a..68441b5d4152 100644
--- a/mail/p5-Mail-GnuPG/Makefile
+++ b/mail/p5-Mail-GnuPG/Makefile
@@ -18,7 +18,6 @@ COMMENT= Perl5 interface to process and/or create PGP email
BUILD_DEPENDS= ${SITE_PERL}/GnuPG/Interface.pm:${PORTSDIR}/security/p5-GnuPG-Interface \
${SITE_PERL}/MIME/Entity.pm:${PORTSDIR}/mail/p5-MIME-Tools \
- ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
${SITE_PERL}/Mail/Address.pm:${PORTSDIR}/mail/p5-Mail-Tools \
${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
RUN_DEPENDS= ${BUILD_DEPENDS}
@@ -29,8 +28,11 @@ MAN3= Mail::GnuPG.3
.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
.if ${PERL_LEVEL} < 500601
IGNORE= This port requires perl 5.6.x or later. Install lang/perl5 then try again
.endif
+.endif
.include <bsd.port.post.mk>