aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2010-10-06 18:38:09 +0800
committermm <mm@FreeBSD.org>2010-10-06 18:38:09 +0800
commitb596f428515ae6293b229241c5c39163e7206545 (patch)
tree0d996e3875d5ae64f18bfe54b6962d7e005e2b8d /mail
parent7fb7197a644910f2e9067d440a8fcb64cce2b3e9 (diff)
downloadfreebsd-ports-gnome-b596f428515ae6293b229241c5c39163e7206545.tar.gz
freebsd-ports-gnome-b596f428515ae6293b229241c5c39163e7206545.tar.zst
freebsd-ports-gnome-b596f428515ae6293b229241c5c39163e7206545.zip
- fix unnecessary dependencies for perl >= 5.10.1
- add upstream patch for perl 5.12 (bugs #6392, #6396) PR: ports/150764, ports/149561 Approved by: maintainer (timeout in ports/150764)
Diffstat (limited to 'mail')
-rw-r--r--mail/p5-Mail-SpamAssassin/Makefile32
-rw-r--r--mail/p5-Mail-SpamAssassin/files/patch-bug6392225
-rw-r--r--mail/p5-Mail-SpamAssassin/files/patch-bug639613
3 files changed, 255 insertions, 15 deletions
diff --git a/mail/p5-Mail-SpamAssassin/Makefile b/mail/p5-Mail-SpamAssassin/Makefile
index 42c49c183932..0bfbafb71f71 100644
--- a/mail/p5-Mail-SpamAssassin/Makefile
+++ b/mail/p5-Mail-SpamAssassin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Mail-SpamAssassin
PORTVERSION= 3.3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail perl5
MASTER_SITES= ${MASTER_SITE_APACHE:S/$/:apache/} ${MASTER_SITE_PERL_CPAN:S/$/:cpan/}
MASTER_SITE_SUBDIR= spamassassin/source/:apache Mail/:cpan
@@ -17,18 +17,14 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:apache,cpan
MAINTAINER= scheidell@secnap.net
COMMENT= A highly efficient mail filter for identifying spam
-BUILD_DEPENDS= p5-NetAddr-IP>=4.00.7:${PORTSDIR}/net-mgmt/p5-NetAddr-IP \
- p5-Archive-Tar>=1.23:${PORTSDIR}/archivers/p5-Archive-Tar \
+RUN_DEPENDS= p5-NetAddr-IP>=4.00.7:${PORTSDIR}/net-mgmt/p5-NetAddr-IP \
p5-Net-DNS>=0.63:${PORTSDIR}/dns/p5-Net-DNS \
- p5-IO-Zlib>=1.04:${PORTSDIR}/archivers/p5-IO-Zlib \
p5-HTML-Parser>=3.43:${PORTSDIR}/www/p5-HTML-Parser \
- p5-Test-Harness>=3.16:${PORTSDIR}/devel/p5-Test-Harness \
${SITE_PERL}/Bundle/LWP.pm:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/${PERL_ARCH}/Encode/Detect.pm:${PORTSDIR}/converters/p5-Encode-Detect \
${SITE_PERL}/Mail/Internet.pm:${PORTSDIR}/mail/p5-Mail-Tools
-RUN_DEPENDS= ${BUILD_DEPENDS} \
- ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+BUILD_DEPENDS= ${RUN_DEPENDS}
CONFLICTS= ja-p5-Mail-SpamAssassin-[0-9]*
@@ -62,7 +58,13 @@ USE_OPENSSL= yes
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500903
-BUILD_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
+.if ${PERL_LEVEL} < 501000
+RUN_DEPENDS+= p5-Archive-Tar>=1.23:${PORTSDIR}/archivers/p5-Archive-Tar \
+ p5-IO-Zlib>=1.04:${PORTSDIR}/archivers/p5-IO-Zlib \
+ p5-Test-Harness>=3.16:${PORTSDIR}/devel/p5-Test-Harness
.endif
.if defined (WITH_SPAMC)
@@ -74,7 +76,7 @@ WITHOUT_SSL=1
.endif
.if defined(WITH_SPF_QUERY)
-BUILD_DEPENDS+= ${SITE_PERL}/Mail/SPF.pm:${PORTSDIR}/mail/p5-Mail-SPF
+RUN_DEPENDS+= ${SITE_PERL}/Mail/SPF.pm:${PORTSDIR}/mail/p5-Mail-SPF
.endif
.if !defined(WITHOUT_IPV6)
RUN_DEPENDS+= ${SITE_PERL}/IO/Socket/INET6.pm:${PORTSDIR}/net/p5-IO-Socket-INET6
@@ -107,20 +109,20 @@ RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-P
.if defined(WITH_RAZOR)
RUN_DEPENDS+= razor-agents>=2.84:${PORTSDIR}/mail/razor-agents
.else
-.if !defined(WITH_DKIM)
.if ${PERL_LEVEL} < 501000
-BUILD_DEPENDS+= p5-Digest-SHA1>=2.11:${PORTSDIR}/security/p5-Digest-SHA1
+.if !defined(WITH_DKIM)
+RUN_DEPENDS+= p5-Digest-SHA1>=2.11:${PORTSDIR}/security/p5-Digest-SHA1
.endif
.endif
.endif
.if defined(WITH_DKIM)
-BUILD_DEPENDS+= ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL
+RUN_DEPENDS+= ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL
. if ${PERL_LEVEL} < 501000
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA.pm:${PORTSDIR}/security/p5-Digest-SHA
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA.pm:${PORTSDIR}/security/p5-Digest-SHA
. endif
-BUILD_DEPENDS+= p5-Mail-DKIM>=0.37:${PORTSDIR}/mail/p5-Mail-DKIM
-BUILD_DEPENDS+= p5-Crypt-OpenSSL-RSA>=0.24:${PORTSDIR}/security/p5-Crypt-OpenSSL-RSA
+RUN_DEPENDS+= p5-Mail-DKIM>=0.37:${PORTSDIR}/mail/p5-Mail-DKIM
+RUN_DEPENDS+= p5-Crypt-OpenSSL-RSA>=0.24:${PORTSDIR}/security/p5-Crypt-OpenSSL-RSA
.endif
.if defined(WITH_SACOMPILE)
diff --git a/mail/p5-Mail-SpamAssassin/files/patch-bug6392 b/mail/p5-Mail-SpamAssassin/files/patch-bug6392
new file mode 100644
index 000000000000..6125c497e8da
--- /dev/null
+++ b/mail/p5-Mail-SpamAssassin/files/patch-bug6392
@@ -0,0 +1,225 @@
+Index: lib/Mail/SpamAssassin/HTML.pm
+===================================================================
+--- lib/Mail/SpamAssassin/HTML.pm (revision 943932)
++++ lib/Mail/SpamAssassin/HTML.pm (revision 943933)
+@@ -191,7 +191,7 @@
+ my $self = shift;
+ my %options = @_;
+
+- return join('', @{ $self->{text} }) unless keys %options;
++ return join('', @{ $self->{text} }) unless %options;
+
+ my $mask;
+ while (my ($k, $v) = each %options) {
+Index: lib/Mail/SpamAssassin/Dns.pm
+===================================================================
+--- lib/Mail/SpamAssassin/Dns.pm (revision 943932)
++++ lib/Mail/SpamAssassin/Dns.pm (revision 943933)
+@@ -754,7 +754,7 @@
+ dbg("dns: entering helper-app run mode");
+ $self->{old_slash} = $/; # Razor pollutes this
+ %{$self->{old_env}} = ();
+- if ( defined %ENV ) {
++ if ( %ENV ) {
+ # undefined values in %ENV can result due to autovivification elsewhere,
+ # this prevents later possible warnings when we restore %ENV
+ while (my ($key, $value) = each %ENV) {
+Index: lib/Mail/SpamAssassin/Plugin/Check.pm
+===================================================================
+--- lib/Mail/SpamAssassin/Plugin/Check.pm (revision 943932)
++++ lib/Mail/SpamAssassin/Plugin/Check.pm (revision 943933)
+@@ -307,64 +307,51 @@
+ my $package_name = __PACKAGE__;
+ my $methodname = $package_name."::_".$ruletype."_tests_".$clean_priority;
+
+- if (defined &{$methodname} && !$doing_user_rules) {
+-run_compiled_method:
+- # dbg("rules: run_generic_tests - calling %s", $methodname);
+- my $t = Mail::SpamAssassin::Timeout->new({ deadline => $master_deadline });
+- my $err = $t->run(sub {
+- no strict "refs";
+- $methodname->($pms, @{$opts{args}});
+- });
+- if ($t->timed_out() && $master_deadline && time > $master_deadline) {
+- info("check: exceeded time limit in $methodname, skipping further tests");
+- $pms->{deadline_exceeded} = 1;
+- }
+- return;
+- }
++ if (!defined &{$methodname} || $doing_user_rules) {
+
+- # use %nopts for named parameter-passing; it's more friendly to future-proof
+- # subclassing, since new parameters can be added without breaking third-party
+- # subclassed implementations of this plugin.
+- my %nopts = (
+- ruletype => $ruletype,
+- doing_user_rules => $doing_user_rules,
+- priority => $priority,
+- clean_priority => $clean_priority
+- );
++ # use %nopts for named parameter-passing; it's more friendly
++ # to future-proof subclassing, since new parameters can be added without
++ # breaking third-party subclassed implementations of this plugin.
++ my %nopts = (
++ ruletype => $ruletype,
++ doing_user_rules => $doing_user_rules,
++ priority => $priority,
++ clean_priority => $clean_priority
++ );
+
+- # build up the eval string...
+- $self->{evalstr_methodname} = $methodname;
+- $self->{evalstr_chunk_current_methodname} = undef;
+- $self->{evalstr_chunk_methodnames} = [];
+- $self->{evalstr_chunk_prefix} = []; # stack (array) of source code sections
+- $self->{evalstr} = ''; $self->{evalstr_l} = 0;
+- $self->{evalstr2} = '';
+- $self->begin_evalstr_chunk($pms);
++ # build up the eval string...
++ $self->{evalstr_methodname} = $methodname;
++ $self->{evalstr_chunk_current_methodname} = undef;
++ $self->{evalstr_chunk_methodnames} = [];
++ $self->{evalstr_chunk_prefix} = []; # stack (array) of source code sections
++ $self->{evalstr} = ''; $self->{evalstr_l} = 0;
++ $self->{evalstr2} = '';
++ $self->begin_evalstr_chunk($pms);
+
+- $self->push_evalstr_prefix($pms, '
+- # start_rules_plugin_code '.$ruletype.' '.$priority.'
+- my $scoresptr = $self->{conf}->{scores};
+- ');
+- if (defined $opts{pre_loop_body}) {
+- $opts{pre_loop_body}->($self, $pms, $conf, %nopts);
+- }
+- $self->add_evalstr($pms,
+- $self->start_rules_plugin_code($ruletype, $priority) );
+- while (my($rulename, $test) = each %{$opts{testhash}->{$priority}}) {
+- $opts{loop_body}->($self, $pms, $conf, $rulename, $test, %nopts);
+- }
+- if (defined $opts{post_loop_body}) {
+- $opts{post_loop_body}->($self, $pms, $conf, %nopts);
+- }
++ $self->push_evalstr_prefix($pms, '
++ # start_rules_plugin_code '.$ruletype.' '.$priority.'
++ my $scoresptr = $self->{conf}->{scores};
++ ');
++ if (defined $opts{pre_loop_body}) {
++ $opts{pre_loop_body}->($self, $pms, $conf, %nopts);
++ }
++ $self->add_evalstr($pms,
++ $self->start_rules_plugin_code($ruletype, $priority) );
++ while (my($rulename, $test) = each %{$opts{testhash}->{$priority}}) {
++ $opts{loop_body}->($self, $pms, $conf, $rulename, $test, %nopts);
++ }
++ if (defined $opts{post_loop_body}) {
++ $opts{post_loop_body}->($self, $pms, $conf, %nopts);
++ }
+
+- $self->flush_evalstr($pms, 'run_generic_tests');
+- $self->free_ruleset_source($pms, $ruletype, $priority);
++ $self->flush_evalstr($pms, 'run_generic_tests');
++ $self->free_ruleset_source($pms, $ruletype, $priority);
+
+- # clear out a previous version of this method
+- undef &{$methodname};
++ # clear out a previous version of this method
++ undef &{$methodname};
+
+- # generate the loop that goes through each line...
+- my $evalstr = <<"EOT";
++ # generate the loop that goes through each line...
++ my $evalstr = <<"EOT";
+ {
+ package $package_name;
+
+@@ -373,41 +360,52 @@
+ sub $methodname {
+ EOT
+
+- for my $chunk_methodname (@{$self->{evalstr_chunk_methodnames}}) {
+- $evalstr .= " $chunk_methodname(\@_);\n";
+- }
++ for my $chunk_methodname (@{$self->{evalstr_chunk_methodnames}}) {
++ $evalstr .= " $chunk_methodname(\@_);\n";
++ }
+
+- $evalstr .= <<"EOT";
++ $evalstr .= <<"EOT";
+ }
+
+ 1;
+ }
+ EOT
+
+- delete $self->{evalstr}; # free up some RAM before we eval()
+- delete $self->{evalstr2};
+- delete $self->{evalstr_methodname};
+- delete $self->{evalstr_chunk_current_methodname};
+- delete $self->{evalstr_chunk_methodnames};
+- delete $self->{evalstr_chunk_prefix};
++ delete $self->{evalstr}; # free up some RAM before we eval()
++ delete $self->{evalstr2};
++ delete $self->{evalstr_methodname};
++ delete $self->{evalstr_chunk_current_methodname};
++ delete $self->{evalstr_chunk_methodnames};
++ delete $self->{evalstr_chunk_prefix};
+
+- dbg("rules: run_generic_tests - compiling eval code: %s, priority %s",
+- $ruletype, $priority);
+-# dbg("rules: eval code to compile: $evalstr");
+- my $eval_result;
+- { my $timer = $self->{main}->time_method('compile_gen');
+- $eval_result = eval($evalstr);
+- }
+- if (!$eval_result) {
+- my $eval_stat = $@ ne '' ? $@ : "errno=$!"; chomp $eval_stat;
+- warn "rules: failed to compile $ruletype tests, skipping:\n".
+- "\t($eval_stat)\n";
+- $pms->{rule_errors}++;
+- }
+- else {
++ dbg("rules: run_generic_tests - compiling eval code: %s, priority %s",
++ $ruletype, $priority);
++ # dbg("rules: eval code to compile: $evalstr");
++ my $eval_result;
++ { my $timer = $self->{main}->time_method('compile_gen');
++ $eval_result = eval($evalstr);
++ }
++ if (!$eval_result) {
++ my $eval_stat = $@ ne '' ? $@ : "errno=$!"; chomp $eval_stat;
++ warn "rules: failed to compile $ruletype tests, skipping:\n".
++ "\t($eval_stat)\n";
++ $pms->{rule_errors}++;
++ return;
++ }
+ dbg("rules: compiled $ruletype tests");
+- goto run_compiled_method;
+ }
++
++#run_compiled_method:
++# dbg("rules: run_generic_tests - calling %s", $methodname);
++ my $t = Mail::SpamAssassin::Timeout->new({ deadline => $master_deadline });
++ my $err = $t->run(sub {
++ no strict "refs";
++ $methodname->($pms, @{$opts{args}});
++ });
++ if ($t->timed_out() && $master_deadline && time > $master_deadline) {
++ info("check: exceeded time limit in $methodname, skipping further tests");
++ $pms->{deadline_exceeded} = 1;
++ }
+ }
+
+ sub begin_evalstr_chunk {
+Index: lib/Mail/SpamAssassin/Plugin/BodyEval.pm
+===================================================================
+--- lib/Mail/SpamAssassin/Plugin/BodyEval.pm (revision 943932)
++++ lib/Mail/SpamAssassin/Plugin/BodyEval.pm (revision 943933)
+@@ -119,7 +119,7 @@
+ }
+
+ # If there are no words, mark if there's at least 1 image ...
+- if (keys %html == 0 && exists $pms->{html}{inside}{img}) {
++ if (!%html && exists $pms->{html}{inside}{img}) {
+ # Use "\n" as the mark since it can't ever occur normally
+ $html{"\n"}=1;
+ }
diff --git a/mail/p5-Mail-SpamAssassin/files/patch-bug6396 b/mail/p5-Mail-SpamAssassin/files/patch-bug6396
new file mode 100644
index 000000000000..cfd9f3bd1926
--- /dev/null
+++ b/mail/p5-Mail-SpamAssassin/files/patch-bug6396
@@ -0,0 +1,13 @@
+Index: lib/Mail/SpamAssassin/Plugin/MIMEEval.pm
+===================================================================
+--- lib/Mail/SpamAssassin/Plugin/MIMEEval.pm (revision 929342)
++++ lib/Mail/SpamAssassin/Plugin/MIMEEval.pm (revision 929343)
+@@ -498,7 +498,7 @@
+ # perhaps just limit to test, and image?
+ next if ($ctype eq 'application/ics');
+
+- my $cte = lc $p->get_header('content-transfer-encoding') || '';
++ my $cte = lc($p->get_header('content-transfer-encoding') || '');
+ next if ($cte !~ /^base64$/);
+ foreach my $l ( @{$p->raw()} ) {
+ my $len = length $l;