aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-08-23 22:42:02 +0800
committermarino <marino@FreeBSD.org>2016-08-23 22:42:02 +0800
commitb6d63d4ab88db69a9adc7d1cc4d69e85c39f209b (patch)
tree913e87205742166764d491ab29692aea0e81b6c2 /mail
parentc906bf4e70a6562d7f2ed69a4d3339eddc72f5a0 (diff)
downloadfreebsd-ports-gnome-b6d63d4ab88db69a9adc7d1cc4d69e85c39f209b.tar.gz
freebsd-ports-gnome-b6d63d4ab88db69a9adc7d1cc4d69e85c39f209b.tar.zst
freebsd-ports-gnome-b6d63d4ab88db69a9adc7d1cc4d69e85c39f209b.zip
mail/gubby: document ncurses required, add missing c++ header
Approved by: ncurses blanket
Diffstat (limited to 'mail')
-rw-r--r--mail/gubby/Makefile2
-rw-r--r--mail/gubby/files/patch-include_die.h10
2 files changed, 12 insertions, 0 deletions
diff --git a/mail/gubby/Makefile b/mail/gubby/Makefile
index 16869fefd01d..dcce909f22d5 100644
--- a/mail/gubby/Makefile
+++ b/mail/gubby/Makefile
@@ -9,6 +9,8 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= mich@FreeBSD.org
COMMENT= Program showing where new mail has been placed
+USES= ncurses
+
LDFLAGS+= -lncurses
CFLAGS+= -fno-exceptions -fno-rtti
diff --git a/mail/gubby/files/patch-include_die.h b/mail/gubby/files/patch-include_die.h
new file mode 100644
index 000000000000..746d2fe7864b
--- /dev/null
+++ b/mail/gubby/files/patch-include_die.h
@@ -0,0 +1,10 @@
+--- include/die.h.orig 2004-12-18 04:29:19 UTC
++++ include/die.h
+@@ -1,6 +1,7 @@
+ // Gubby
+ // csl@sublevel3.org
+
++#include <cstdlib>
+ #include <string>
+
+ void die(const std::string& s);