aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-06-02 07:18:19 +0800
committerbapt <bapt@FreeBSD.org>2013-06-02 07:18:19 +0800
commitbb2507ee9768f7dbf5718c5e592ffd6fc3c1d831 (patch)
treefc1da988ed9c9cba707cf220721bac89300d0c78 /mail
parentc58a15df775d75a040a08e6253d56a8e8b74044a (diff)
downloadfreebsd-ports-gnome-bb2507ee9768f7dbf5718c5e592ffd6fc3c1d831.tar.gz
freebsd-ports-gnome-bb2507ee9768f7dbf5718c5e592ffd6fc3c1d831.tar.zst
freebsd-ports-gnome-bb2507ee9768f7dbf5718c5e592ffd6fc3c1d831.zip
Convert to new options framework
Diffstat (limited to 'mail')
-rw-r--r--mail/crm114/Makefile22
-rw-r--r--mail/dcc-dccd/Makefile41
-rw-r--r--mail/dracmail/Makefile17
-rw-r--r--mail/extmail/Makefile18
-rw-r--r--mail/faces/Makefile26
-rw-r--r--mail/greylite/Makefile20
6 files changed, 63 insertions, 81 deletions
diff --git a/mail/crm114/Makefile b/mail/crm114/Makefile
index d263764e3bc9..cbf5c652f02b 100644
--- a/mail/crm114/Makefile
+++ b/mail/crm114/Makefile
@@ -1,8 +1,5 @@
-# New ports collection makefile for: crm114
-# Date created: 23 February 2004
-# Whom: Meno Abels <meno.abels@adviser.com>
+# Created by: Meno Abels <meno.abels@adviser.com>
# $FreeBSD$
-#
PORTNAME= crm114
PORTVERSION= 20100106
@@ -46,11 +43,12 @@ CRM_FILES= mailfilter.crm mailfilter.cf mailreaver.crm mailtrainer.crm \
blacklist.mfp.example whitelist.mfp.example crm114-mode.el \
reto_procmailrc.recipe
-OPTIONS= PGO "Enable Profile-Guided Optimization" off
+OPTIONS_DEFINE= PGO
+PGO_DESC= Profile-Guided Optimization
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_PGO)
+.if ${PORT_OPTIONS:MPGO}
MAKE_ARGS+= CFLAGS="${CFLAGS} -fprofile-use" \
LDFLAGS="${LDFLAGS} -fprofile-use"
.else
@@ -63,7 +61,7 @@ post-patch:
's,^((LD|C)FLAGS),#\1,;;s,^(prefix=),#\1,;;s,^(.*-install),#\1,' \
${WRKSRC}/Makefile
-.if defined(WITH_PGO)
+.if ${PORT_OPTIONS:MPGO}
.if target(pre-build)
.error Makefile error since pre-build target has already been defined
.endif
@@ -82,7 +80,7 @@ post-install:
@for i in priolist.mfp whitelist.mfp; do \
${CP} ${WRKSRC}/$${i}.example ${WRKSRC}/$${i}; \
done
-.ifdef(WITH_NORMALIZEMIME)
+.if ${PORT_OPTIONS:MNORMALIZEMIME}
@${REINPLACE_CMD} -Ee 's|^#(.*/normalizemime/)|\1|' \
${WRKSRC}/mailfilter.cf
.else
@@ -100,7 +98,7 @@ post-install:
done
.endif
-.if defined(WITH_PGO)
+.if ${PORT_OPTIONS:MPGO}
pgo: pgo-build pgo-run pgo-clean
pgo-build:
@@ -113,6 +111,6 @@ pgo-run:
pgo-clean:
@(cd ${BUILD_WRKSRC}; ${MAKE} clean)
-.endif # if defined(WITH_PGO)
+.endif # if ${PORT_OPTIONS:MPGO}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/dcc-dccd/Makefile b/mail/dcc-dccd/Makefile
index 71a8cb84b88d..51e2aad3cfdc 100644
--- a/mail/dcc-dccd/Makefile
+++ b/mail/dcc-dccd/Makefile
@@ -46,13 +46,14 @@ MAN8= cdcc.8 dbclean.8 dblist.8 dcc.8 dccd.8 dccifd.8 dccm.8 \
# like SpamAssassin may need to be explicitly told where
# to find dccifd's socket.
#
-OPTIONS= DCCIFD "DCC interface daemon (for SpamAssassin etc)" on \
- DCCM "DCC milter (for Sendmail only)" on \
- DCCD "DCC server" on \
- DCCGREY "DCC greylisting server" on \
- IPV6 "IPv6 support" on \
- ALT_HOME "DCC home in /var/dcc" off \
- PORTS_SENDMAIL "Use base Sendmail if off, ports if on" off
+OPTIONS_DEFINE= DCCIFD DCCM DCCD DCCGREY IPV6 ALT_HOME PORTS_SENDMAIL
+OPTIONS_DEFAULT= DCCIFD DCCM DCCD DCCGREY
+DCCIFD_DESC= DCC interface daemon (for SpamAssassin etc)
+DCCM_DESC= DCC milter (for Sendmail only)
+DCCD_DESC= DCC server
+DCCGREY_DESC= DCC greylisting server
+ALT_HOME_DESC= DCC home in /var/dcc
+PORTS_SENDMAIL_DESC= Use base Sendmail if off, ports if on
## User for DCC files and SUID binaries
#
@@ -76,7 +77,7 @@ SUB_LIST+= WRKSRC=${WRKSRC} DCCHOME=${DCCHOME}
## /var/dcc home support
#
-.if defined(WITH_ALT_HOME)
+.if ${PORT_OPTIONS:MALT_HOME}
CONFIGURE_ARGS+= --libexecdir=${PREFIX}/dcc/libexec --with-cgibin=${PREFIX}/dcc/cgi-bin
DCCHOME= /var/dcc
PLIST_SUB+= WITH_ALT_HOME=""
@@ -89,19 +90,19 @@ CONFIGURE_ARGS+= --homedir=${DCCHOME}
## dccm milter support
#
-.if defined(WITH_DCCM)
+.if ${PORT_OPTIONS:MDCCM}
.if !exists(/usr/lib/libmilter.a) && !exists(${LOCALBASE}/lib/libmilter.a)
IGNORE= neither base system nor Ports version of Sendmail installed, cannot build milter
.endif
-.if defined(WITHOUT_PORTS_SENDMAIL) && !exists(/usr/lib/libmilter.a)
+.if ! ${PORT_OPTIONS:MPORTS_SENDMAIL} && !exists(/usr/lib/libmilter.a)
IGNORE= base system Sendmail not found or too old, rebuild with WITH_PORTS_SENDMAIL=yes or WITHOUT_DCCM=yes
.endif
-.if defined(WITH_PORTS_SENDMAIL) && !exists(${LOCALBASE}/lib/libmilter.a)
+.if ${PORT_OPTIONS:MPORTS_SENDMAIL} && !exists(${LOCALBASE}/lib/libmilter.a)
IGNORE= ports Sendmail not found, rebuild with WITHOUT_PORTS_SENDMAIL=yes or WITHOUT_DCCM=yes
.endif
-.if defined(WITHOUT_PORTS_SENDMAIL)
+.if ! ${PORT_OPTIONS:MPORTS_SENDMAIL}
MILTERBASE= /usr
.else
BUILD_DEPENDS+= ${LOCALBASE}/lib/libmilter.a:${PORTSDIR}/mail/sendmail
@@ -127,7 +128,7 @@ PLIST_SUB+= WITH_DCCM="@comment "
## dccifd client interface daemon support
#
-.if defined(WITHOUT_DCCIFD)
+.if ! ${PORT_OPTIONS:MDCCIFD}
CONFIGURE_ARGS+= --disable-dccifd
PLIST_SUB+= WITH_DCCIFD="@comment "
.else
@@ -137,7 +138,7 @@ USE_RC_SUBR+= dccifd
## dccd server support
#
-.if defined(WITHOUT_DCCD) && defined(WITHOUT_DCCGREY)
+.if ! ${PORT_OPTIONS:MDCCD} && ! ${PORT_OPTIONS:MDCCGREY}
CONFIGURE_ARGS+= --disable-server
PLIST_SUB+= WITH_DCCD="@comment "
.else
@@ -146,31 +147,29 @@ PLIST_SUB+= WITH_DCCD=""
## IPV6 support
#
-.if defined(WITHOUT_IPV6)
+.if ! ${PORT_OPTIONS:MIPV6}
CONFIGURE_ARGS+= --disable-IPv6
.endif
## Packing list and rcNG script fixups
#
-.if defined(WITHOUT_DCCIFD) && defined(WITHOUT_DCCM)
+.if ! ${PORT_OPTIONS:MDCCIFD} && ! ${PORT_OPTIONS:MDCCM}
PLIST_SUB+= WITH_IFD_MILT="@comment "
.else
PLIST_SUB+= WITH_IFD_MILT=""
.endif
-.if defined(WITH_DCCD)
+.if ${PORT_OPTIONS:MDCCD}
USE_RC_SUBR+= dccd
.endif
-.if defined(WITH_DCCGREY)
+.if ${PORT_OPTIONS:MDCCGREY}
USE_RC_SUBR+= dccgrey
PLIST_SUB+= WITH_DCCGREY=""
.else
PLIST_SUB+= WITH_DCCGREY="@comment "
.endif
-.include <bsd.port.pre.mk>
-
pre-everything::
@${ECHO_MSG} ' '
@${ECHO_MSG} "A description of ALT_HOME may be found in the port's Makefile."
@@ -186,4 +185,4 @@ post-install:
#
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/dracmail/Makefile b/mail/dracmail/Makefile
index 0f73f2418c2f..e2a8bfe586a8 100644
--- a/mail/dracmail/Makefile
+++ b/mail/dracmail/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: dracmail
-# Date created: 14 January 2011
-# Whom: jamrich.majo@gmail.com
-#
+# Created by: jamrich.majo@gmail.com
# $FreeBSD$
-#
PORTNAME= dracmail
PORTVERSION= 0.1.2
@@ -26,19 +22,18 @@ PKGMESSAGE= ${WRKDIR}/${PORTNAME}/pkg-message
SUB_FILES= pkg-message
PLIST_DIRSTRY= %%WWWDIR%%
-OPTIONS= POSTGRE "Use PostgreSQL Database" off \
- APACHE "Use Apache webserver" on \
- LIGHTTPD "Use Lighttpd webserver" off
+OPTIONS_DEFINE= PGSQL APACHE LIGHTTPD
+OPTIONS_DEFAULT= APACHE
.include <bsd.port.options.mk>
-.if defined(WITH_POSTGRE)
+.if ${PORT_OPTIONS:MPGSQL}
USE_PHP+= pgsql
.endif
-.if defined(WITH_APACHE)
+.if ${PORT_OPTIONS:MAPACHE}
USE_APACHE_RUN= 22
.endif
-.if defined(WITH_LIGHTTPD)
+.if ${PORT_OPTIONS:MLIGHTTPD}
RUN_DEPENDS+= lighttpd:${PORTSDIR}/www/lighttpd
.endif
diff --git a/mail/extmail/Makefile b/mail/extmail/Makefile
index a5e9b720a802..9973f1743704 100644
--- a/mail/extmail/Makefile
+++ b/mail/extmail/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: extmail
-# Date created: 31 Frebruary 2006
-# Whom: Chifeng QU <chifeng@gmail.com>
-#
+# Created by: Chifeng QU <chifeng@gmail.com>
# $FreeBSD$
-#
PORTNAME= extmail
PORTVERSION= 1.2
@@ -20,15 +16,15 @@ RUN_DEPENDS= p5-Unix-Syslog>=0:${PORTSDIR}/sysutils/p5-Unix-Syslog
USE_PERL5= yes
NO_BUILD= yes
-OPTIONS= MYSQL "Use MySQL support" On \
- LDAP "Use LDAP support" Off
+OPTIONS_DEFINE= MYSQL LDAP
+OPTIONS_DEFAULT= MYSQL
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
RUN_DEPENDS+= p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql
.endif
-.if defined(WITH_LDAP)
+.if ${PORT_OPTIONS:MLDAP}
RUN_DEPENDS+= p5-DBD-LDAP>=0:${PORTSDIR}/databases/p5-DBD-LDAP
.endif
@@ -63,4 +59,4 @@ post-install:
${CHMOD} +w ${WWWDIR}/webmail.cf ; \
fi
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/faces/Makefile b/mail/faces/Makefile
index ee46e4e6e623..8104cb6c84f0 100644
--- a/mail/faces/Makefile
+++ b/mail/faces/Makefile
@@ -1,10 +1,5 @@
-# New ports collection makefile for: faces-1.6.1
-# Date created: 09 December 96
-# Whom: Lars Koeller <Lars_Koeller@odie.physik2.uni-rostock.de>
-# Andreas Klemm <andreas@FreeBSD.org>
-#
+# Created by: Lars Koeller <Lars_Koeller@odie.physik2.uni-rostock.de>
# $FreeBSD$
-#
PORTNAME= faces
PORTVERSION= 1.7.7
@@ -15,10 +10,11 @@ MASTER_SITES= SF
MAINTAINER= ashish@FreeBSD.org
COMMENT= Visual mail, user, and print face server
-OPTIONS= X11 "X11/GTK support" on \
- NAS "NAS audio support" off \
- RPLAY "rplay audio support" off \
- SOX "Sox audio support" off
+OPTIONS_DEFINE= X11 NAS RPLAY SOX DOCS NLS
+OPTIONS_DEFAULT= X11
+X11_DESC= X11/GTK support
+RPLAY_DESC= rplay audio support
+SOX_DESC= Sox audio support
WANT_GNOME= yes
USE_LDCONFIG= yes
@@ -31,7 +27,7 @@ PORTDOCS= README
.include <bsd.port.pre.mk>
-.if defined(WITHOUT_X11)
+.if ! ${PORT_OPTIONS:MX11}
PLIST_SUB+= X11="@comment "
WITH_AUDIO= # none
.else # with X11
@@ -46,7 +42,7 @@ CONFIGURE_ARGS= --enable-imap --enable-pop \
MAN1+= faces.1
.endif
-.if defined(WITHOUT_NLS)
+.if ! ${PORT_OPTIONS:MNLS}
CONFIGURE_ARGS+=--disable-nls
.endif
@@ -81,7 +77,7 @@ post-patch:
do-build:
cd ${WRKSRC}/compface && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} \
${FILESDIR}/Makefile.compface ${MAKE_ARGS} ${ALL_TARGET}
-.if !defined(WITHOUT_X11)
+.if ${PORT_OPTIONS:MX11}
cd ${WRKSRC}/faces && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} \
${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}
.endif
@@ -99,12 +95,12 @@ do-install:
${INSTALL_SCRIPT} ${FILESDIR}/xbm2ikon ${PREFIX}/bin
${INSTALL_SCRIPT} ${FILESDIR}/xbmcut48 ${PREFIX}/bin
${INSTALL_SCRIPT} ${FILESDIR}/xbmsize48 ${PREFIX}/bin
-.if !defined(WITHOUT_X11)
+.if ${PORT_OPTIONS:MX11}
${INSTALL_PROGRAM} ${WRKSRC}/faces/faces ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/faces/faces.1 ${MANPREFIX}/man/man1
${INSTALL_DATA} ${WRKSRC}/faces/Faces.ad ${LOCALBASE}/lib/X11/app-defaults/Faces
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
diff --git a/mail/greylite/Makefile b/mail/greylite/Makefile
index c2281a453623..85eb8906bb3f 100644
--- a/mail/greylite/Makefile
+++ b/mail/greylite/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: greylite
-# Date created: 2007-12-11
-# Whom: Mij <mij@bitchx.it>
-#
+# Created by: Mij <mij@bitchx.it>
# $FreeBSD$
-#
PORTNAME= greylite
PORTVERSION= 2.3
@@ -25,18 +21,20 @@ PLIST_FILES= bin/greylite \
MAN8= greylite.8
MANCOMPRESSED= yes
-OPTIONS= GEOIP "Support for GeoIP in suspicion rules" On \
- DNSBLENV "Module for interfacing with DNS blacklists" On \
- UCSPI2SOCKET "Module for using greylite as SMTP proxy" On
+OPTIONS_DEFINE= GEOIP DNSBLENV UCSPI2SOCKET
+OPTIONS_DEFAULT= GEOIP DNSBLENV UCSPI2SOCKET
+GEOIP_DESC= Support for GeoIP in suspicion rules
+DNSBLENV_DESC= Module for interfacing with DNS blacklists
+UCSPI2SOCKET_DESC= Module for using greylite as SMTP proxy
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_GEOIP)
+.if ${PORT_OPTIONS:MGEOIP}
LIB_DEPENDS+= GeoIP:${PORTSDIR}/net/GeoIP
MAKE_ARGS+= WITH_GEOIP=yep
.endif
-.if !defined(WITHOUT_DNSBLENV)
+.if ${PORT_OPTIONS:MDNSBLENV}
LIB_DEPENDS+= cares:${PORTSDIR}/dns/c-ares
MAKE_ARGS+= WITH_DNSBLENV=yep
PLIST_SUB+= DNSBLENV=""
@@ -44,7 +42,7 @@ PLIST_SUB+= DNSBLENV=""
PLIST_SUB+= DNSBLENV="@comment "
.endif
-.if !defined(WITHOUT_UCSPI2SOCKET)
+.if ${PORT_OPTIONS:MUCSPI2SOCKET}
MAKE_ARGS+= WITH_UCSPI2SOCKET=yep
PLIST_SUB+= UCSPI2SOCKET=""
.else