aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-02-18 07:21:17 +0800
committerpav <pav@FreeBSD.org>2005-02-18 07:21:17 +0800
commitc02323cf0e6680e24efa32905ae1d6b163300d31 (patch)
tree179afcab1d2d96d0e1ebd1bd669c57f8c820a020 /mail
parent865fceea60668f123462c54b5d22c0ba58a4c73f (diff)
downloadfreebsd-ports-gnome-c02323cf0e6680e24efa32905ae1d6b163300d31.tar.gz
freebsd-ports-gnome-c02323cf0e6680e24efa32905ae1d6b163300d31.tar.zst
freebsd-ports-gnome-c02323cf0e6680e24efa32905ae1d6b163300d31.zip
- Update to 1.12
- Unbreak PR: ports/77632 Submitted by: Johan van Selst <johans@stack.nl>
Diffstat (limited to 'mail')
-rw-r--r--mail/prayer/Makefile10
-rw-r--r--mail/prayer/distinfo4
-rw-r--r--mail/prayer/files/patch-Config38
-rw-r--r--mail/prayer/files/patch-prayer-mydb.c16
-rw-r--r--mail/prayer/pkg-plist1
5 files changed, 46 insertions, 23 deletions
diff --git a/mail/prayer/Makefile b/mail/prayer/Makefile
index 88f8741b7878..b72b90da9164 100644
--- a/mail/prayer/Makefile
+++ b/mail/prayer/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= prayer
-PORTVERSION= 1.0.10
+PORTVERSION= 1.0.12
CATEGORIES= mail www
MASTER_SITES= ftp://ftp.csx.cam.ac.uk/pub/software/email/prayer/
# ftp://ftp.csx.cam.ac.uk/pub/software/email/prayer/prayer-1.0.8.tar.gz
@@ -16,18 +16,16 @@ COMMENT= Prayer Webmail System
BUILD_DEPENDS= ${LOCALBASE}/lib/libc-client4.a:${PORTSDIR}/mail/cclient
.if !defined(PRAYER_WITHOUT_SESSION_CACHE)
-LIB_DEPENDS+= ${BERKLEYDB_LIB}:${PORTSDIR}/${BERKLEYDB_PORT}
+LIB_DEPENDS+= ${BERKELEYDB_LIB}:${PORTSDIR}/${BERKELEYDB_PORT}
.endif
-BROKEN= Does not fetch
-
USE_GMAKE= yes
USE_OPENSSL= yes
USE_REINPLACE= yes
USE_PERL5_BUILD= yes
MAKE_ENV+= PORTCFLAGS="${CFLAGS}"
-BERKLEYDB_PORT?= databases/db3
-BERKLEYDB_LIB?= db3.3
+BERKELEYDB_PORT?= databases/db42
+BERKELEYDB_LIB?= db-4.2
DOCS= ACCOUNTD CMD_LINE DESIGN DONE DONE-OLD FEATURES ICONLIST \
INSTALL LOGS NOTICE README ROADMAP SECURITY TODO URL_OPTIONS
diff --git a/mail/prayer/distinfo b/mail/prayer/distinfo
index 8d7f053fc639..51ed5f06c53a 100644
--- a/mail/prayer/distinfo
+++ b/mail/prayer/distinfo
@@ -1,2 +1,2 @@
-MD5 (prayer-1.0.10.tar.gz) = a78f802a8ac365a993645fa923f14cb3
-SIZE (prayer-1.0.10.tar.gz) = 525342
+MD5 (prayer-1.0.12.tar.gz) = e2bb8fb3ccc54ab1719896bb4cc226db
+SIZE (prayer-1.0.12.tar.gz) = 544239
diff --git a/mail/prayer/files/patch-Config b/mail/prayer/files/patch-Config
index 82e1c5812556..9da3491ad873 100644
--- a/mail/prayer/files/patch-Config
+++ b/mail/prayer/files/patch-Config
@@ -1,15 +1,6 @@
---- Config.orig Thu May 29 11:49:38 2003
-+++ Config Tue Jan 6 10:20:40 2004
-@@ -8,7 +8,7 @@
- # Conventional Configure file.
-
- SSL_ENABLE = true # SSL requires OpenSSL
--SESSION_CACHE_ENABLE = true # SSL session cache Requires Berkeley DB 3 or 4
-+SESSION_CACHE_ENABLE = false # SSL session cache Requires Berkeley DB 3 or 4
- GZIP_ENABLE = true # Enable on the fly compression of pages
- FENCE_ENABLE = false # Use Electric Fence to catch malloc problems
- DIRECT_ENABLE = false # Experimental. Leave this switched off...
-@@ -26,7 +26,7 @@
+--- Config.orig Thu Feb 17 12:18:46 2005
++++ Config Thu Feb 17 12:23:25 2005
+@@ -27,7 +27,7 @@
############################################################################
# Location of compiler
@@ -18,7 +9,7 @@
# Location of make program (GNU make required)
MAKE = gmake
# Location of install program (GNU install or compatible required)
-@@ -35,7 +35,8 @@
+@@ -36,7 +36,8 @@
# Base Compiler options for GCC.
#BASECFLAGS = -Wall -g
#BASELDFLAGS = -g
@@ -28,7 +19,7 @@
BASELDFLAGS = -g -O2
BASE_LIBS = -lcrypt
-@@ -56,9 +57,9 @@
+@@ -57,9 +58,9 @@
# which points to ../../imap/c-client. This just reduces the amount of
# noise output on each line when building the package.
#
@@ -41,7 +32,7 @@
CCLIENT_SSL_ENABLE = true
#
-@@ -78,12 +79,14 @@
+@@ -79,12 +80,14 @@
# Following works with the mail/cclient port from FreeBSD
#
#CCLIENT_INCLUDE = -I/usr/local/include/c-client
@@ -57,3 +48,20 @@
#CCLIENT_KERB_ENABLE = true
############################################################################
+@@ -123,12 +126,12 @@
+ # DB definitions (required if SESSION_CACHE_ENABLE set)
+ #
+ # Following suitable for Redhat Linux which has DB 3 preinstalled
+-DB_INCLUDE=
+-DB_LIBS=-ldb
++#DB_INCLUDE=
++#DB_LIBS=-ldb
+
+ # Following suitable for FreeBSD with DB 4 package installed
+-#DB_INCLUDE=-I/usr/local/include/db4
+-#DB_LIBS=-L/usr/local/lib -ldb4
++DB_INCLUDE=-I/usr/local/include/db42
++DB_LIBS=-L/usr/local/lib -ldb-4.2
+
+ ############################################################################
+
diff --git a/mail/prayer/files/patch-prayer-mydb.c b/mail/prayer/files/patch-prayer-mydb.c
new file mode 100644
index 000000000000..e962244c01a3
--- /dev/null
+++ b/mail/prayer/files/patch-prayer-mydb.c
@@ -0,0 +1,16 @@
+--- prayer/mydb.c.orig Thu Feb 17 23:09:40 2005
++++ prayer/mydb.c Thu Feb 17 23:06:11 2005
+@@ -49,12 +49,12 @@
+ #include <string.h>
+ #include <stdio.h>
+ #include <netdb.h>
++#include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+ #include <errno.h>
+ #include <syslog.h>
+-#include <sys/types.h>
+ #include <sys/stat.h>
+ #include <unistd.h>
+ #include <fcntl.h>
diff --git a/mail/prayer/pkg-plist b/mail/prayer/pkg-plist
index ee43091727d5..978fc33f2e81 100644
--- a/mail/prayer/pkg-plist
+++ b/mail/prayer/pkg-plist
@@ -98,6 +98,7 @@ prayer/etc/welcome.html
prayer/sbin/prayer
prayer/sbin/prayer-session
prayer/sbin/prayer-ssl-prune
+prayer/sbin/prayer-sem-prune
prayer/sbin/prayer-cyclog
@dirrm prayer/help/CVS
@dirrm prayer/help/compose/CVS