aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-06-08 21:23:14 +0800
committervanilla <vanilla@FreeBSD.org>2014-06-08 21:23:14 +0800
commitc4c2f05d9b4ff739a46dee62a9e50efa97ba655c (patch)
treea131ee344ec52ade52d9eebdbfb807369055fc11 /mail
parent0d07bf993680336c658c64737bc5298b87745259 (diff)
downloadfreebsd-ports-gnome-c4c2f05d9b4ff739a46dee62a9e50efa97ba655c.tar.gz
freebsd-ports-gnome-c4c2f05d9b4ff739a46dee62a9e50efa97ba655c.tar.zst
freebsd-ports-gnome-c4c2f05d9b4ff739a46dee62a9e50efa97ba655c.zip
Stagify.
Diffstat (limited to 'mail')
-rw-r--r--mail/james/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/mail/james/Makefile b/mail/james/Makefile
index 20fc6faa362e..a4ac255bb951 100644
--- a/mail/james/Makefile
+++ b/mail/james/Makefile
@@ -28,7 +28,6 @@ SUB_LIST= JAVA_HOME=${JAVA_HOME} \
JAMES_HOME=${APP_HOME} \
JAMES_VERSION=${PORTVERSION:S/.//g}
-NO_STAGE= yes
.include <bsd.port.pre.mk>
pre-patch:
@@ -44,17 +43,17 @@ post-patch:
do-install:
@${ECHO_MSG} -n ">> Creating destination directory..."
- @${MKDIR} ${APP_HOME}
+ @${MKDIR} ${STAGEDIR}${APP_HOME}
@${ECHO_MSG} " [ DONE ]"
@${ECHO_MSG} ">> Copying files to destination directory..."
- @${CP} -R ${WRKSRC}/* ${APP_HOME}
- @${MKDIR} ${APP_HOME}/logs
- @${MKDIR} ${APP_HOME}/apps
+ @${CP} -R ${WRKSRC}/* ${STAGEDIR}${APP_HOME}
+ @${MKDIR} ${STAGEDIR}${APP_HOME}/logs
+ @${MKDIR} ${STAGEDIR}${APP_HOME}/apps
@${ECHO_MSG} " [ DONE ]"
@${ECHO_MSG} -n ">> Creating symlink to tools.jar..."
- @${LN} -sf ${JAVA_HOME}/lib/tools.jar ${APP_HOME}/lib/tools.jar
+ @${LN} -sf ${JAVA_HOME}/lib/tools.jar ${STAGEDIR}${APP_HOME}/lib/tools.jar
@${ECHO_MSG} " [ DONE ]"
post-install: