aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-03-24 04:54:27 +0800
committergarga <garga@FreeBSD.org>2006-03-24 04:54:27 +0800
commitc93bbfaac04d53eafcc5284c9105f51c75330c0a (patch)
tree0db254a6068eed1fd1559bba123f7f63e94fb2fe /mail
parentb1fb394fd506fb268e9c2e03bbe2b49e892fa715 (diff)
downloadfreebsd-ports-gnome-c93bbfaac04d53eafcc5284c9105f51c75330c0a.tar.gz
freebsd-ports-gnome-c93bbfaac04d53eafcc5284c9105f51c75330c0a.tar.zst
freebsd-ports-gnome-c93bbfaac04d53eafcc5284c9105f51c75330c0a.zip
This is a complete standalone C implementation of the SRS (Sender
Rewriting Scheme) and includes a command line utility and daemon, test utility and static and dynamic libraries. SRS is a stop-gap for users of SPF (Sender Policy Framework). WWW: http://srs.mirtol.com PR: ports/94831 Submitted by: Simon Dick <simond@irrelevant.org>
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/libsrs_alt/Makefile35
-rw-r--r--mail/libsrs_alt/distinfo3
-rw-r--r--mail/libsrs_alt/pkg-descr6
-rw-r--r--mail/libsrs_alt/pkg-plist6
5 files changed, 51 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index b292c0a4260c..5753c4b65213 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -167,6 +167,7 @@
SUBDIR += libspf2-10
SUBDIR += libsrs
SUBDIR += libsrs2
+ SUBDIR += libsrs_alt
SUBDIR += libvmime
SUBDIR += listmanager
SUBDIR += lmtp2nntp
diff --git a/mail/libsrs_alt/Makefile b/mail/libsrs_alt/Makefile
new file mode 100644
index 000000000000..4fdf361f40d4
--- /dev/null
+++ b/mail/libsrs_alt/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: libsrs_alt
+# Date created: 22 March 2006
+# Whom: Simon Dick <simond@irrelevant.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libsrs_alt
+DISTVERSION= 1.0rc1a
+CATEGORIES= mail
+MASTER_SITES= http://srs.mirtol.com/
+
+MAINTAINER= simond@irrelevant.org
+COMMENT= Sender Rewriting Scheme C Implementation
+
+USE_BZIP2= yes
+INSTALLS_SHLIB= yes
+SHLIB_MAJOR= 1
+GNU_CONFIGURE= yes
+
+PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
+
+OPTIONS= COMPAT_BASE64 "Enable MTA Friendly base64 compatibility mode" Off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_COMPAT_BASE64)
+CONFIGURE_ARGS+= --with-base64compat
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -E 's,^(test_LDFLAGS.*$$),\1 -lcompat,' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.post.mk>
diff --git a/mail/libsrs_alt/distinfo b/mail/libsrs_alt/distinfo
new file mode 100644
index 000000000000..0dced3fe0263
--- /dev/null
+++ b/mail/libsrs_alt/distinfo
@@ -0,0 +1,3 @@
+MD5 (libsrs_alt-1.0rc1a.tar.bz2) = 1eda222957d339cba28178add3fb5f61
+SHA256 (libsrs_alt-1.0rc1a.tar.bz2) = 69cb6059b0271b42c48f487be9b416fd04974c09d7c7672ebb1137b4cd315f06
+SIZE (libsrs_alt-1.0rc1a.tar.bz2) = 232642
diff --git a/mail/libsrs_alt/pkg-descr b/mail/libsrs_alt/pkg-descr
new file mode 100644
index 000000000000..fb58bc0db342
--- /dev/null
+++ b/mail/libsrs_alt/pkg-descr
@@ -0,0 +1,6 @@
+This is a complete standalone C implementation of the SRS (Sender
+Rewriting Scheme) and includes a command line utility and daemon,
+test utility and static and dynamic libraries. SRS is a stop-gap
+for users of SPF (Sender Policy Framework).
+
+WWW: http://srs.mirtol.com
diff --git a/mail/libsrs_alt/pkg-plist b/mail/libsrs_alt/pkg-plist
new file mode 100644
index 000000000000..afb15bf30f2a
--- /dev/null
+++ b/mail/libsrs_alt/pkg-plist
@@ -0,0 +1,6 @@
+bin/srs
+include/srs_alt.h
+lib/libsrs_alt.a
+lib/libsrs_alt.la
+lib/libsrs_alt.so
+lib/libsrs_alt.so.%%SHLIB_MAJOR%%