aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorsahil <sahil@FreeBSD.org>2013-01-28 10:45:13 +0800
committersahil <sahil@FreeBSD.org>2013-01-28 10:45:13 +0800
commitd690736dec6eb8519947b2537d39436d8377136f (patch)
tree96603cd0460b02651227ed14897377e9ee48acd7 /mail
parent38823f8f01bb978dccb8cc474f6e756f0d0cf6e1 (diff)
downloadfreebsd-ports-gnome-d690736dec6eb8519947b2537d39436d8377136f.tar.gz
freebsd-ports-gnome-d690736dec6eb8519947b2537d39436d8377136f.tar.zst
freebsd-ports-gnome-d690736dec6eb8519947b2537d39436d8377136f.zip
Update to 2.7.12 and revise the PKGINSTALL script to
distinguish between upgrades and fresh installs. Also, backport an upstream patch that allows Postfix packages to build in a jail that has IPv6 enabled, but no addresses assigned on any interface.
Diffstat (limited to 'mail')
-rw-r--r--mail/postfix27/Makefile3
-rw-r--r--mail/postfix27/distinfo4
-rw-r--r--mail/postfix27/files/patch-src-util-inet_proto.c20
-rw-r--r--mail/postfix27/files/patch-src::util::sys_defs.h6
-rw-r--r--mail/postfix27/files/pkg-install.in14
5 files changed, 35 insertions, 12 deletions
diff --git a/mail/postfix27/Makefile b/mail/postfix27/Makefile
index 77dfff3205ef..1bc6109a75d7 100644
--- a/mail/postfix27/Makefile
+++ b/mail/postfix27/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= postfix
-PORTVERSION= 2.7.11
-PORTREVISION= 2
+PORTVERSION= 2.7.12
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/official/ \
diff --git a/mail/postfix27/distinfo b/mail/postfix27/distinfo
index d819f84e471a..12ce2ded3ed4 100644
--- a/mail/postfix27/distinfo
+++ b/mail/postfix27/distinfo
@@ -1,5 +1,5 @@
-SHA256 (postfix/postfix-2.7.11.tar.gz) = 4acdf4c1313fed9d1c64826607df4c1e9518281e33ded4a740ca5f3ccdc0e44a
-SIZE (postfix/postfix-2.7.11.tar.gz) = 3418624
+SHA256 (postfix/postfix-2.7.12.tar.gz) = 529eb64c51bafae93ceea0e8d8cb210f74d5b13d89e877c9e79a496db35f41aa
+SIZE (postfix/postfix-2.7.12.tar.gz) = 3419280
SHA256 (postfix/postfix-2.7.1-libspf2-1.2.x-4.patch.gz) = b67efb1ffbcae91f13bf3ed90a5181d4b5bc86ebe15753eaf9db8b2278f5bb16
SIZE (postfix/postfix-2.7.1-libspf2-1.2.x-4.patch.gz) = 8186
SHA256 (postfix/postfix-vda-v10-2.7.8.patch) = 10738a30f2cb00cd05c593caf5b4b9d4ca44927432c1995a9db5c3557d0528db
diff --git a/mail/postfix27/files/patch-src-util-inet_proto.c b/mail/postfix27/files/patch-src-util-inet_proto.c
new file mode 100644
index 000000000000..00606ec3e8e7
--- /dev/null
+++ b/mail/postfix27/files/patch-src-util-inet_proto.c
@@ -0,0 +1,20 @@
+--- src/util/inet_proto.c.orig 2013-01-27 20:31:06.000000000 +0000
++++ src/util/inet_proto.c 2013-01-27 20:31:41.000000000 +0000
+@@ -205,7 +205,7 @@
+ pf->dns_atype_list = make_unsigned_vector(2, T_AAAA, 0);
+ pf->sa_family_list = make_uchar_vector(2, AF_INET6, 0);
+ break;
+- } else if (errno == EAFNOSUPPORT) {
++ } else if (errno == EAFNOSUPPORT || errno == EPROTONOSUPPORT) {
+ msg_fatal("%s: IPv6 support is disabled: %m", context);
+ } else {
+ msg_fatal("socket: %m");
+@@ -219,7 +219,7 @@
+ pf->dns_atype_list = make_unsigned_vector(3, T_A, T_AAAA, 0);
+ pf->sa_family_list = make_uchar_vector(3, AF_INET, AF_INET6, 0);
+ break;
+- } else if (errno == EAFNOSUPPORT) {
++ } else if (errno == EAFNOSUPPORT || errno == EPROTONOSUPPORT) {
+ msg_warn("%s: IPv6 support is disabled: %m", context);
+ msg_warn("%s: configuring for IPv4 support only", context);
+ /* FALLTHROUGH */
diff --git a/mail/postfix27/files/patch-src::util::sys_defs.h b/mail/postfix27/files/patch-src::util::sys_defs.h
index a13c320759ff..ed169e45af25 100644
--- a/mail/postfix27/files/patch-src::util::sys_defs.h
+++ b/mail/postfix27/files/patch-src::util::sys_defs.h
@@ -1,10 +1,10 @@
---- src/util/sys_defs.h.orig 2011-03-01 19:35:19.000000000 -0500
-+++ src/util/sys_defs.h 2011-03-01 19:36:54.000000000 -0500
+--- src/util/sys_defs.h.orig 2013-01-27 20:30:58.000000000 +0000
++++ src/util/sys_defs.h 2013-01-27 20:32:04.000000000 +0000
@@ -25,7 +25,7 @@
*/
#if defined(FREEBSD2) || defined(FREEBSD3) || defined(FREEBSD4) \
|| defined(FREEBSD5) || defined(FREEBSD6) || defined(FREEBSD7) \
-- || defined(FREEBSD8) \
+- || defined(FREEBSD8) || defined(FREEBSD9) \
+ || defined(FREEBSD8) || defined(FREEBSD9) || defined(FREEBSD10) \
|| defined(BSDI2) || defined(BSDI3) || defined(BSDI4) \
|| defined(OPENBSD2) || defined(OPENBSD3) || defined(OPENBSD4) \
diff --git a/mail/postfix27/files/pkg-install.in b/mail/postfix27/files/pkg-install.in
index d32c125cf297..e5140bea63e3 100644
--- a/mail/postfix27/files/pkg-install.in
+++ b/mail/postfix27/files/pkg-install.in
@@ -65,11 +65,15 @@ if [ "$2" = "POST-INSTALL" ]; then
fi
done
- /bin/sh ${DAEMONDIR}/post-install tempdir=/tmp \
- daemon_directory=${DAEMONDIR} \
- html_directory=${READMEDIR} \
- readme_directory=${READMEDIR} \
- upgrade-package
+ cmp ${DAEMONDIR}/main.cf ${ETCDIR}/main.cf >/dev/null 2>&1 \
+ && POSTARG="set-permissions" \
+ || POSTARG="upgrade-package"
+
+ /bin/sh ${DAEMONDIR}/post-install tempdir=/tmp \
+ daemon_directory=${DAEMONDIR} \
+ html_directory=${READMEDIR} \
+ readme_directory=${READMEDIR} \
+ ${POSTARG}
fi
if [ "$2" = "POST-INSTALL" -a -z "${PACKAGE_BUILDING}" -a -f "${MC}" ]; then