aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-08-18 04:55:32 +0800
committermiwi <miwi@FreeBSD.org>2009-08-18 04:55:32 +0800
commitd85d081d2eb4467be59056d74f1626d84e1337c8 (patch)
treecac23015873cba984e8dfd1e2df6e523af1357d4 /mail
parent3645fa06834d106e49ecd095e5ec67c34835ac33 (diff)
downloadfreebsd-ports-gnome-d85d081d2eb4467be59056d74f1626d84e1337c8.tar.gz
freebsd-ports-gnome-d85d081d2eb4467be59056d74f1626d84e1337c8.tar.zst
freebsd-ports-gnome-d85d081d2eb4467be59056d74f1626d84e1337c8.zip
- Unbreak and Update to 1.2
PR: 137885 Submitted by: Denis Shaposhnikov <dsh@wizard.volgograd.ru> (maintainer)
Diffstat (limited to 'mail')
-rw-r--r--mail/dovecot-antispam/Makefile5
-rw-r--r--mail/dovecot-antispam/distinfo9
-rw-r--r--mail/dovecot-antispam/files/patch-antispam-plugin.h41
3 files changed, 45 insertions, 10 deletions
diff --git a/mail/dovecot-antispam/Makefile b/mail/dovecot-antispam/Makefile
index 6304c20bf85a..d63edd6c60d9 100644
--- a/mail/dovecot-antispam/Makefile
+++ b/mail/dovecot-antispam/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= dovecot-antispam
-PORTVERSION= 1.1
-PORTREVISION= 1
+PORTVERSION= 1.2
PORTEPOCH= 1
CATEGORIES= mail
MASTER_SITES= http://johannes.sipsolutions.net/download/dovecot-antispam/ \
@@ -30,8 +29,6 @@ OPTIONS+= MAILTRAIN "send mail to special addresses for training" off
OPTIONS+= DEBUG "Turn on debug information (syslog)" off
OPTIONS+= DEBUG_VERBOSE "Turn on verbose debug" off
-BROKEN= Needs updating to reflect new mail/dovecot version.
-
do-install:
${INSTALL_DATA} ${WRKSRC}/lib90_antispam_plugin.so \
${PREFIX}/lib/dovecot/imap/
diff --git a/mail/dovecot-antispam/distinfo b/mail/dovecot-antispam/distinfo
index 323597908482..2449e946ac59 100644
--- a/mail/dovecot-antispam/distinfo
+++ b/mail/dovecot-antispam/distinfo
@@ -1,6 +1,3 @@
-MD5 (dovecot-antispam-1.0.tar.bz2) = aeb77a04b0a5f7d37d892118f3791344
-SHA256 (dovecot-antispam-1.0.tar.bz2) = 001cb927b52b06141b5e738d0684f15f0314cbdd7fb0f52ad198c5ff6bdced21
-SIZE (dovecot-antispam-1.0.tar.bz2) = 22279
-MD5 (dovecot-antispam-1.1.tar.bz2) = 551e2c55c1716a1860648fec75f49b18
-SHA256 (dovecot-antispam-1.1.tar.bz2) = 3f6e0098040fb13f3dcc682ed8755b4024a7461ea16873775c600a303b38d5d7
-SIZE (dovecot-antispam-1.1.tar.bz2) = 22298
+MD5 (dovecot-antispam-1.2.tar.bz2) = 4def8bf968a94b3c2cb81bd751b4737c
+SHA256 (dovecot-antispam-1.2.tar.bz2) = 28b3a7819d58a66e86d5432c135c4c9486c4f08226e726d5df0d25ea578b9c15
+SIZE (dovecot-antispam-1.2.tar.bz2) = 26595
diff --git a/mail/dovecot-antispam/files/patch-antispam-plugin.h b/mail/dovecot-antispam/files/patch-antispam-plugin.h
new file mode 100644
index 000000000000..4e97593565f8
--- /dev/null
+++ b/mail/dovecot-antispam/files/patch-antispam-plugin.h
@@ -0,0 +1,41 @@
+From af0f8f8de27901e2efb9560a1fc66c7af3cd810b Mon Sep 17 00:00:00 2001
+From: Johannes Berg <johannes@sipsolutions.net>
+Date: Thu, 2 Jul 2009 14:17:54 +0200
+Subject: [PATCH 1/1] make it compile with dovecot 1.2
+
+---
+ antispam-plugin.h | 13 +++++++++++++
+ 1 files changed, 13 insertions(+), 0 deletions(-)
+
+diff --git a/antispam-plugin.h b/antispam-plugin.h
+index df59e88..493fd1e 100644
+--- antispam-plugin.h
++++ antispam-plugin.h
+@@ -113,11 +113,24 @@ o_stream_create_from_fd(int fd, pool_t pool ATTR_UNUSED)
+ return o_stream_create_fd(fd, 0, TRUE);
+ }
+
++#if DOVECOT_VERSION_CODE(1, 2) == DOVECOT_VERSION
++static inline struct dict *
++string_dict_init(const char *uri, const char *username)
++{
++ const char *base_dir;
++
++ base_dir = getenv("BASE_DIR");
++ if (base_dir == NULL)
++ base_dir = "/var/run/dovecot";
++ return dict_init(uri, DICT_DATA_TYPE_STRING, username, base_dir);
++}
++#else /* 1.1 */
+ static inline struct dict *
+ string_dict_init(const char *uri, const char *username)
+ {
+ return dict_init(uri, DICT_DATA_TYPE_STRING, username);
+ }
++#endif
+ #elif DOVECOT_VERSION_CODE(1, 0) == DOVECOT_VERSION
+ #define ME(err)
+ #define PLUGIN_ID
+--
+1.6.3.3
+