aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authordwcjr <dwcjr@FreeBSD.org>2002-07-10 00:48:49 +0800
committerdwcjr <dwcjr@FreeBSD.org>2002-07-10 00:48:49 +0800
commitea1484d13dfa4fb42fb3ad04ee05a32104a0fc0f (patch)
treea1294df1cebcfee152c6385aef9850cdd3d0bc8a /mail
parent404c567f854f50403c3d981580416ecee09bc42a (diff)
downloadfreebsd-ports-gnome-ea1484d13dfa4fb42fb3ad04ee05a32104a0fc0f.tar.gz
freebsd-ports-gnome-ea1484d13dfa4fb42fb3ad04ee05a32104a0fc0f.tar.zst
freebsd-ports-gnome-ea1484d13dfa4fb42fb3ad04ee05a32104a0fc0f.zip
REINPLACE
PR: 40352 Submitted by: maintainer
Diffstat (limited to 'mail')
-rw-r--r--mail/mutt-devel/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index 8972f5cc7a74..347025626404 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -75,10 +75,11 @@ CONFIGURE_ARGS= --enable-flock --disable-fcntl \
CONFIGURE_ARGS+= ${MUTT_CONFIGURE_ARGS}
.endif
-.include <bsd.port.pre.mk>
-
+USE_REINPLACE= yes
USE_AUTOMAKE= yes
+.include <bsd.port.pre.mk>
+
.if defined(WITH_MUTT_COMPRESSED_FOLDERS) || defined(WITH_MUTT_NNTP) || \
defined(WITH_MUTT_QUOTE_PATCH)
PATCH_SITES+= http://www.mutt.org.ua/download/mutt-${PATCH_VERSION}/ \
@@ -91,8 +92,10 @@ PATCH_SITES+= http://www.mutt.org.ua/download/mutt-${PATCH_VERSION}/ \
# this should be done automagically by aclocal but ....
# for now, this will have to do
pre-build:
- @${PERL} -pi -e "s/^(ACLOCAL = ).+/\1${ACLOCAL}/; s/^(AUTOCONF = ).+/\1${AUTOCONF}/; \
- s/^(AUTOMAKE = ).+/\1${AUTOMAKE}/; s/^(AUTOHEADER = ).+/\1${AUTOHEADER}/" \
+ @${REINPLACE_CMD} -E -e "s/^(ACLOCAL = ).+/\1${ACLOCAL}/" \
+ -e "s/^(AUTOCONF = ).+/\1${AUTOCONF}/" \
+ -e "s/^(AUTOMAKE = ).+/\1${AUTOMAKE}/" \
+ -e "s/^(AUTOHEADER = ).+/\1${AUTOHEADER}/" \
${BUILD_WRKSRC}/Makefile
.if !defined(PATCH_VERSION)
@@ -190,7 +193,7 @@ MAN1= flea.1 mutt.1 mutt_dotlock.1 muttbug.1
MAN5= muttrc.5 mbox.5
post-patch::
- @${PERL} -pi.fbsd -e 's,/usr/bin/gpg,${LOCALBASE}/bin/gpg,g' \
+ @${REINPLACE_CMD} -e 's,/usr/bin/gpg,${LOCALBASE}/bin/gpg,g' \
${WRKSRC}/contrib/gpg.rc
@${CP} ${PATCHDIR}/smime.h ${WRKSRC}