aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-12-19 20:42:50 +0800
committermiwi <miwi@FreeBSD.org>2007-12-19 20:42:50 +0800
commitec844fa5bd638ec6bc090c3eba44e82273da9627 (patch)
treeb92bb89373b260fd3c04755a7e2f6695da342fe4 /mail
parent3f73d29a2a7d914a9d6d50b83ddb6d29ed3c8a9f (diff)
downloadfreebsd-ports-gnome-ec844fa5bd638ec6bc090c3eba44e82273da9627.tar.gz
freebsd-ports-gnome-ec844fa5bd638ec6bc090c3eba44e82273da9627.tar.zst
freebsd-ports-gnome-ec844fa5bd638ec6bc090c3eba44e82273da9627.zip
Greylite is an implementation of a modified greylisting technology for fighting
SPAM on mailservers running qmail. Greylite does not require patching qmail, it is self-contained because it uses sqlite, it uses a technology that minimizes delivery delays and enables suspect senders to be multiply rejected and never whitelisted. Greylite is easy to setup and maintain, and it is small and fast. WWW: http://mij.oltrelinux.com/net/greylite/ PR: ports/118233 Submitted by: Mij <mij at bitchx.it>
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/greylite/Makefile41
-rw-r--r--mail/greylite/distinfo3
-rw-r--r--mail/greylite/pkg-descr10
-rw-r--r--mail/greylite/pkg-message8
5 files changed, 63 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 02b0357128a6..6a79949d0626 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -155,6 +155,7 @@
SUBDIR += gnumail
SUBDIR += gotmail
SUBDIR += grepmail
+ SUBDIR += greylite
SUBDIR += gtray
SUBDIR += gubby
SUBDIR += hashcash
diff --git a/mail/greylite/Makefile b/mail/greylite/Makefile
new file mode 100644
index 000000000000..6a9ab963170e
--- /dev/null
+++ b/mail/greylite/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: greylite
+# Date created: 2007-12-11
+# Whom: Mij <mij@bitchx.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= greylite
+DISTVERSION= 1.3
+CATEGORIES= mail
+MASTER_SITES= http://mij.oltrelinux.com/net/greylite/
+
+MAINTAINER= mij@bitchx.it
+COMMENT= An efficient greylisting module for qmail
+
+USE_BZIP2= yes
+USE_SQLITE= 3
+PLIST_FILES= bin/greylite
+
+MAN8= greylite.8
+MANCOMPRESSED= yes
+
+OPTIONS= GEOIP "Enable support for GeoIP in suspicion rules" On
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_GEOIP)
+LIB_DEPENDS+= GeoIP:$(PORTSDIR)/net/GeoIP
+MAKE_ARGS+= WITH_GEOIP=yep
+.endif
+
+post-patch:
+ ${CP} ${WRKSRC}/Makefile.bsdmake ${WRKSRC}/Makefile
+
+do-build:
+ $(MAKE) -C $(WRKSRC) $(MAKE_ARGS)
+
+post-install:
+ @$(CAT) pkg-message
+
+.include <bsd.port.post.mk>
diff --git a/mail/greylite/distinfo b/mail/greylite/distinfo
new file mode 100644
index 000000000000..1e08b8867e1b
--- /dev/null
+++ b/mail/greylite/distinfo
@@ -0,0 +1,3 @@
+MD5 (greylite-1.3.tar.bz2) = a034d736a75555a3b710a288f33ade96
+SHA256 (greylite-1.3.tar.bz2) = 8393fd976daa4e0f514567f9a39905d4115cbe1f5809315bf4b16e082e8f7eba
+SIZE (greylite-1.3.tar.bz2) = 13629
diff --git a/mail/greylite/pkg-descr b/mail/greylite/pkg-descr
new file mode 100644
index 000000000000..9ead2a04996d
--- /dev/null
+++ b/mail/greylite/pkg-descr
@@ -0,0 +1,10 @@
+Greylite is an implementation of a modified greylisting technology for fighting
+SPAM on mailservers running qmail.
+
+Greylite does not require patching qmail, it is self-contained because it uses
+sqlite, it uses a technology that minimizes delivery delays and enables suspect
+senders to be multiply rejected and never whitelisted.
+
+Greylite is easy to setup and maintain, and it is small and fast.
+
+WWW: http://mij.oltrelinux.com/net/greylite/
diff --git a/mail/greylite/pkg-message b/mail/greylite/pkg-message
new file mode 100644
index 000000000000..7c915c9d3183
--- /dev/null
+++ b/mail/greylite/pkg-message
@@ -0,0 +1,8 @@
+################################################################
+Greylite has been installed. Some steps are required for setting
+it up with qmail. greylite(8) has a synthesis and the website at
+http://mij.oltrelinux.com/net/greylite/ has more information.
+You might be also interested in further refinements to improve
+the effectiveness and performance of greylite:
+http://mij.oltrelinux.com/net/greylite/practmatters.html
+################################################################