aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormatthew <matthew@FreeBSD.org>2016-02-07 07:13:16 +0800
committermatthew <matthew@FreeBSD.org>2016-02-07 07:13:16 +0800
commit0c14f53803c1b676bb304463f38b71540bc5e2c2 (patch)
treecd8804f9cfb674e104585fb8b3896273c94a7aa2 /mail
parent60194775e712af5ce40c49caee1bf6635fa92cd5 (diff)
downloadfreebsd-ports-gnome-0c14f53803c1b676bb304463f38b71540bc5e2c2.tar.gz
freebsd-ports-gnome-0c14f53803c1b676bb304463f38b71540bc5e2c2.tar.zst
freebsd-ports-gnome-0c14f53803c1b676bb304463f38b71540bc5e2c2.zip
(1) Add USES perl5 and add RUN_DEPENDS for perl modules needed by the
various perl scripts installed by this port (2) Use ${PORTSDIR}/mail/sendmail/bsd.milter.mk to link against libmilter installed by the mail/sendmail port when WITH_SENDMAIL_PORT=yes is set in /etc/make.conf or the base libmilter if WITH_SENDMAIL_BASE=yes PR: 202374 (1) Submitted by: freebsd-ports@dan.me.uk (1) matthew (2) Reviewed by: pi (1) Approved by: maintainer timeout (>14days)
Diffstat (limited to 'mail')
-rw-r--r--mail/opendmarc/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/mail/opendmarc/Makefile b/mail/opendmarc/Makefile
index b7bb718d46fb..590f0ecd3984 100644
--- a/mail/opendmarc/Makefile
+++ b/mail/opendmarc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= opendmarc
PORTVERSION= 1.3.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail security
MASTER_SITES= SF/${PORTNAME} \
SF/${PORTNAME}/Previous%20Releases
@@ -14,12 +14,16 @@ COMMENT= DMARC library and milter implementation
LICENSE= BSD3CLAUSE SENDMAIL
LICENSE_COMB= multi
+RUN_DEPENDS= p5-Switch>=0:${PORTSDIR}/lang/p5-Switch \
+ p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
+ p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql
+
LICENSE_FILE_SENDMAIL= ${WRKSRC}/LICENSE.Sendmail
LICENSE_GROUPS_SENDMAIL= FSF OSI
LICENSE_NAME_SENDMAIL= Sendmail Open Source License
LICENSE_PERMS_SENDMAIL= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-USES= libtool shebangfix
+USES= libtool perl5 shebangfix
USE_LDCONFIG= yes
USE_RC_SUBR= opendmarc
@@ -42,10 +46,10 @@ SHEBANG_FILES= reports/opendmarc-expire.in \
PORTDOCS= *
-.if !exists( /usr/include/libmilter/mfapi.h )
-BUILD_DEPENDS+= ${LOCALBASE}/include/libmilter/mfapi.h:${PORTSDIR}/mail/sendmail
-CFLAGS+= -I${LOCALBASE}/include
-.endif
+.include <bsd.port.pre.mk>
+
+.include "${PORTSDIR}/mail/sendmail/bsd.milter.mk"
+CONFIGURE_ARGS+= --with-milter=${MILTERBASE}
post-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/etc/mail
@@ -53,4 +57,4 @@ post-install:
${WRKSRC}/opendmarc/opendmarc.conf.sample ${STAGEDIR}${PREFIX}/etc/mail
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libopendmarc.so.2
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>