aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2007-10-01 13:23:51 +0800
committerlinimon <linimon@FreeBSD.org>2007-10-01 13:23:51 +0800
commit150ee35dfa977f6271ca0dfd7bcb7dc491435459 (patch)
tree11f575e206817adcc43e97b301444f1763904b60 /mail
parent116cc1223979c4f67ee94d6f479caf87acadf3a8 (diff)
downloadfreebsd-ports-gnome-150ee35dfa977f6271ca0dfd7bcb7dc491435459.tar.gz
freebsd-ports-gnome-150ee35dfa977f6271ca0dfd7bcb7dc491435459.tar.zst
freebsd-ports-gnome-150ee35dfa977f6271ca0dfd7bcb7dc491435459.zip
Add USE_PERL5. This will be needed to conditionalize bsd.perl.mk inclusion.
Approved by: maintainer
Diffstat (limited to 'mail')
-rw-r--r--mail/dkfilter/Makefile1
-rw-r--r--mail/dkimproxy/Makefile1
-rw-r--r--mail/pronto/Makefile2
3 files changed, 4 insertions, 0 deletions
diff --git a/mail/dkfilter/Makefile b/mail/dkfilter/Makefile
index 6ed38749a7d1..6f4285257eef 100644
--- a/mail/dkfilter/Makefile
+++ b/mail/dkfilter/Makefile
@@ -22,6 +22,7 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Crypt/OpenSSL/RSA.pm:${PORTSDIR}/securi
RUN_DEPENDS= ${BUILD_DEPENDS}
GNU_CONFIGURE= yes
+USE_PERL5= yes
USE_RC_SUBR= dkfilter_in dkfilter_out
DKFILTER_USERNAME?= dkfilter
diff --git a/mail/dkimproxy/Makefile b/mail/dkimproxy/Makefile
index 4fe086c7e97b..f636e0bf64d5 100644
--- a/mail/dkimproxy/Makefile
+++ b/mail/dkimproxy/Makefile
@@ -18,6 +18,7 @@ BUILD_DEPENDS= ${SITE_PERL}/Mail/DKIM.pm:${PORTSDIR}/mail/p5-Mail-DKIM \
RUN_DEPENDS= ${BUILD_DEPENDS}
GNU_CONFIGURE= yes
+USE_PERL5= yes
USE_RC_SUBR= dkimproxy_in dkimproxy_out
DKIMPY_USERNAME?= dkimproxy
diff --git a/mail/pronto/Makefile b/mail/pronto/Makefile
index 12c205fadfaa..f99eafd2ca60 100644
--- a/mail/pronto/Makefile
+++ b/mail/pronto/Makefile
@@ -35,4 +35,6 @@ BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Mysql.pm:${PORTSDIR}/databases/p5-Mysq
RUN_DEPENDS= ${BUILD_DEPENDS}
+USE_PERL5= yes
+
.include <bsd.port.mk>