aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2016-02-29 20:06:32 +0800
committergahr <gahr@FreeBSD.org>2016-02-29 20:06:32 +0800
commit1b53b42a409c97ddb4212d9904817347f0bf53f7 (patch)
treef1788ce96bc6a8a059b1766cdd8ad9797b9a0137 /mail
parent5a128d9d0902b65b68e3e61b3ee36da5561cd051 (diff)
downloadfreebsd-ports-gnome-1b53b42a409c97ddb4212d9904817347f0bf53f7.tar.gz
freebsd-ports-gnome-1b53b42a409c97ddb4212d9904817347f0bf53f7.tar.zst
freebsd-ports-gnome-1b53b42a409c97ddb4212d9904817347f0bf53f7.zip
mail/opensmtpd-extras: new port - addons for mail/opensmtpd
Currently, only the "tables" components are included. Please feel free to contribute with "filters", "queues", and "schedulers". WWW: https://github.com/OpenSMTPD/OpenSMTPD-extras
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/opensmtpd-extras/Makefile69
-rw-r--r--mail/opensmtpd-extras/distinfo2
-rw-r--r--mail/opensmtpd-extras/pkg-descr3
4 files changed, 75 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 6a9554a4fef1..a37aa01a0f81 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -291,6 +291,7 @@
SUBDIR += openemm2015
SUBDIR += opensmtpd
SUBDIR += opensmtpd-devel
+ SUBDIR += opensmtpd-extras
SUBDIR += openwebmail
SUBDIR += osbf-lua
SUBDIR += ovs
diff --git a/mail/opensmtpd-extras/Makefile b/mail/opensmtpd-extras/Makefile
new file mode 100644
index 000000000000..0f78a79e6884
--- /dev/null
+++ b/mail/opensmtpd-extras/Makefile
@@ -0,0 +1,69 @@
+# Created by: gahr
+# $FreeBSD$
+
+PORTNAME= opensmtpd-extras
+PORTVERSION= 201602042118
+CATEGORIES= mail
+MASTER_SITES= http://www.opensmtpd.org/archives/
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= Addons for OpenSMTPD
+
+LICENSE= ISCL
+
+OPTIONS_GROUP= TABLE
+OPTIONS_GROUP_TABLE= LDAP MYSQL PASSWD PGSQL PYTHON REDIS SMAP SQLITE
+OPTIONS_DEFAULT= LDAP MYSQL PASSWD PGSQL PYTHON REDIS SMAP SQLITE
+
+PASSWD_DESC= passwd(5) table support
+SMAP_DESC= Socketmap protocol support
+
+OPTIONS_SUB= yes
+
+LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2
+RUN_DEPENDS= ${LOCALBASE}/sbin/smtpctl:${PORTSDIR}/mail/opensmtpd
+
+USES= autoreconf libtool pkgconfig
+USE_OPENSSL= yes
+WITH_OPENSSL_PORT= yes
+GNU_CONFIGURE= yes
+PLIST_FILES= man/man3/filter_api.3.gz
+INSTALL_DIR= libexec/opensmtpd
+
+#
+# Tables
+#
+MYSQL_CONFIGURE_WITH= table-mysql
+MYSQL_VARS= USE_MYSQL=client \
+ LDFLAGS+=-L${LOCALBASE}/lib/mysql \
+ PLIST_FILES+=${INSTALL_DIR}/table-mysql
+
+PASSWD_CONFIGURE_WITH= table-passwd
+PASSWD_VARS= PLIST_FILES+=${INSTALL_DIR}/table-passwd \
+ PLIST_FILES+=man/man5/table-passwd.5.gz
+
+PGSQL_CONFIGURE_WITH= table-postgres
+PGSQL_USES= pgsql
+PGSQL_VARS= PLIST_FILES+=${INSTALL_DIR}/table-postgres
+
+PYTHON_CONFIGURE_WITH= table-python python-type=${PYTHON_VERSION}
+PYTHON_USES= python
+PYTHON_VARS= PLIST_FILES+=${INSTALL_DIR}/table-python
+
+REDIS_CONFIGURE_WITH= table-redis
+REDIS_CONFIGURE_ENV= REDIS_CONFIG=${LOCALBASE}/bin/pkgconf
+REDIS_LIB_DEPENDS= libhiredis.so:${PORTSDIR}/databases/hiredis
+REDIS_VARS= CFLAGS+=-I${LOCALBASE}/include/hiredis \
+ PLIST_FILES+=${INSTALL_DIR}/table-redis \
+ PLIST_FILES+=man/man5/table-redis.5.gz
+
+SMAP_CONFIGURE_WITH= table-socketmap
+SMAP_VARS= PLIST_FILES+=${INSTALL_DIR}/table-socketmap \
+ PLIST_FILES+=man/man5/table-socketmap.5.gz
+
+SQLITE_CONFIGURE_WITH= table-sqlite
+SQLITE_USES= sqlite
+SQLITE_VARS= PLIST_FILES+=${INSTALL_DIR}/table-sqlite \
+ PLIST_FILES+=man/man5/table-sqlite.5.gz
+
+.include <bsd.port.mk>
diff --git a/mail/opensmtpd-extras/distinfo b/mail/opensmtpd-extras/distinfo
new file mode 100644
index 000000000000..8d0e2596fe11
--- /dev/null
+++ b/mail/opensmtpd-extras/distinfo
@@ -0,0 +1,2 @@
+SHA256 (opensmtpd-extras-201602042118.tar.gz) = 59480e4bc0c75ca554a0a833b51764e4b7de6acf9f1ebcd2e7f176c144da3b32
+SIZE (opensmtpd-extras-201602042118.tar.gz) = 142226
diff --git a/mail/opensmtpd-extras/pkg-descr b/mail/opensmtpd-extras/pkg-descr
new file mode 100644
index 000000000000..7adec9f08f81
--- /dev/null
+++ b/mail/opensmtpd-extras/pkg-descr
@@ -0,0 +1,3 @@
+OpenSMTPD addons.
+
+WWW: https://github.com/OpenSMTPD/OpenSMTPD-extras