aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2018-12-09 19:48:24 +0800
committerkrion <krion@FreeBSD.org>2018-12-09 19:48:24 +0800
commit1fe1c5f39d6645c1402da647fed2f16b6aa527d5 (patch)
tree50162e90edadbfc9af3952bc13914b8b9c77b86c /mail
parentcf96e704cb02cdd83afeff0507a601305432f9ec (diff)
downloadfreebsd-ports-gnome-1fe1c5f39d6645c1402da647fed2f16b6aa527d5.tar.gz
freebsd-ports-gnome-1fe1c5f39d6645c1402da647fed2f16b6aa527d5.tar.zst
freebsd-ports-gnome-1fe1c5f39d6645c1402da647fed2f16b6aa527d5.zip
Add patches to avoid accessing unallocated memory.
buffer_consume_to_mark() was trying to use Boyer-Moore search to find specified mark string but implementation was walking through unallocated memory. PR: 227543 Submitted by: Jeremy Chadwick <jdc@koitsu.org>
Diffstat (limited to 'mail')
-rw-r--r--mail/tpop3d/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/mail/tpop3d/Makefile b/mail/tpop3d/Makefile
index b4b10cc5cddb..cd010b12349d 100644
--- a/mail/tpop3d/Makefile
+++ b/mail/tpop3d/Makefile
@@ -3,14 +3,17 @@
PORTNAME= tpop3d
PORTVERSION= 1.5.5
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= mail
MASTER_SITES= SAVANNAH
MAINTAINER= ports@FreeBSD.org
COMMENT= Virtual-domain capable POP3 server supporting MySQL, PgSQL etc auth
+LICENSE= GPLv2
+
USES= ssl
+
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib -lcrypto
CONFIGURE_ARGS= --enable-auth-other \