aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorume <ume@FreeBSD.org>2006-04-02 12:45:28 +0800
committerume <ume@FreeBSD.org>2006-04-02 12:45:28 +0800
commit26f8ab07f82de69ef655c6ad869d75412f38520d (patch)
tree9d73a6d8c659a6b95ab15b3784ea7f4c8e6bf742 /mail
parent46edc6e7aacd6fe244948ed87cb794b88a43b0f0 (diff)
downloadfreebsd-ports-gnome-26f8ab07f82de69ef655c6ad869d75412f38520d.tar.gz
freebsd-ports-gnome-26f8ab07f82de69ef655c6ad869d75412f38520d.tar.zst
freebsd-ports-gnome-26f8ab07f82de69ef655c6ad869d75412f38520d.zip
deliver segfaulted when using without -l.
Submitted by: André Böhm <andre__at__abtime.de> Obtained from: https://bugzilla.andrew.cmu.edu/show_bug.cgi?id=2786
Diffstat (limited to 'mail')
-rw-r--r--mail/cyrus-imapd22/Makefile2
-rw-r--r--mail/cyrus-imapd22/files/patch-imap::backend.c13
2 files changed, 14 insertions, 1 deletions
diff --git a/mail/cyrus-imapd22/Makefile b/mail/cyrus-imapd22/Makefile
index b100f303f84b..a42c267c7b00 100644
--- a/mail/cyrus-imapd22/Makefile
+++ b/mail/cyrus-imapd22/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cyrus-imapd
PORTVERSION= 2.2.13
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/ \
ftp://ftp.hanse.de/sites/transit/mirror/ftp.andrew.cmu.edu/pub/cyrus-mail/ \
diff --git a/mail/cyrus-imapd22/files/patch-imap::backend.c b/mail/cyrus-imapd22/files/patch-imap::backend.c
new file mode 100644
index 000000000000..a955d0a2d6fd
--- /dev/null
+++ b/mail/cyrus-imapd22/files/patch-imap::backend.c
@@ -0,0 +1,13 @@
+Index: imap/backend.c
+diff -u -p imap/backend.c.orig imap/backend.c
+--- imap/backend.c.orig Wed Feb 8 05:57:27 2006
++++ imap/backend.c Sun Apr 2 13:39:57 2006
+@@ -271,7 +271,7 @@ struct backend *backend_connect(struct b
+ /* need to (re)establish connection to server or create one */
+ int sock = -1;
+ int r;
+- int err = 0;
++ int err = -1;
+ struct addrinfo hints, *res0 = NULL, *res1 = NULL, *res;
+ struct sockaddr_un sunsock;
+ char buf[2048], *mechlist = NULL;