aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-04-27 05:25:28 +0800
committermarcus <marcus@FreeBSD.org>2002-04-27 05:25:28 +0800
commit35632893b9a3a822b128e601d1e63e8298305e0f (patch)
treec8932647194f14c8e08f55c80d4899e7a28c1e81 /mail
parentecadba4046dd0ec584582cbd73223735fd85c476 (diff)
downloadfreebsd-ports-gnome-35632893b9a3a822b128e601d1e63e8298305e0f.tar.gz
freebsd-ports-gnome-35632893b9a3a822b128e601d1e63e8298305e0f.tar.zst
freebsd-ports-gnome-35632893b9a3a822b128e601d1e63e8298305e0f.zip
Fix a problem were date stamps were offset by one hour when DST was in effect.
Bump PORTREVISION. PR: 37471 Submitted by: Larry Rosenman <ler@lerctr.org> Approved by: sobomax
Diffstat (limited to 'mail')
-rw-r--r--mail/evolution-devel/Makefile1
-rw-r--r--mail/evolution-devel/files/patch-camel_camel-mime-message.c13
-rw-r--r--mail/evolution/Makefile1
-rw-r--r--mail/evolution/files/patch-camel_camel-mime-message.c13
4 files changed, 28 insertions, 0 deletions
diff --git a/mail/evolution-devel/Makefile b/mail/evolution-devel/Makefile
index 5b28c34a7008..491ad0facd5b 100644
--- a/mail/evolution-devel/Makefile
+++ b/mail/evolution-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= evolution
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= mail gnome
MASTER_SITES= ${MASTER_SITE_GNOME} \
http://people.FreeBSD.org/~sobomax/:local
diff --git a/mail/evolution-devel/files/patch-camel_camel-mime-message.c b/mail/evolution-devel/files/patch-camel_camel-mime-message.c
new file mode 100644
index 000000000000..df92a52a222b
--- /dev/null
+++ b/mail/evolution-devel/files/patch-camel_camel-mime-message.c
@@ -0,0 +1,13 @@
+--- camel/camel-mime-message.c.orig Mon Dec 10 14:54:11 2001
++++ camel/camel-mime-message.c Fri Apr 26 17:19:59 2002
+@@ -209,8 +209,10 @@
+ tz = -local->tm_gmtoff;
+ #endif
+ offset = -(((tz/60/60) * 100) + (tz/60 % 60));
++#if defined(HAVE_TIMEZONE)
+ if (local->tm_isdst>0)
+ offset += 100;
++#endif
+ }
+ message->date = date;
+ message->date_offset = offset;
diff --git a/mail/evolution/Makefile b/mail/evolution/Makefile
index 5b28c34a7008..491ad0facd5b 100644
--- a/mail/evolution/Makefile
+++ b/mail/evolution/Makefile
@@ -7,6 +7,7 @@
PORTNAME= evolution
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= mail gnome
MASTER_SITES= ${MASTER_SITE_GNOME} \
http://people.FreeBSD.org/~sobomax/:local
diff --git a/mail/evolution/files/patch-camel_camel-mime-message.c b/mail/evolution/files/patch-camel_camel-mime-message.c
new file mode 100644
index 000000000000..df92a52a222b
--- /dev/null
+++ b/mail/evolution/files/patch-camel_camel-mime-message.c
@@ -0,0 +1,13 @@
+--- camel/camel-mime-message.c.orig Mon Dec 10 14:54:11 2001
++++ camel/camel-mime-message.c Fri Apr 26 17:19:59 2002
+@@ -209,8 +209,10 @@
+ tz = -local->tm_gmtoff;
+ #endif
+ offset = -(((tz/60/60) * 100) + (tz/60 % 60));
++#if defined(HAVE_TIMEZONE)
+ if (local->tm_isdst>0)
+ offset += 100;
++#endif
+ }
+ message->date = date;
+ message->date_offset = offset;