aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-06-05 19:10:08 +0800
committerpawel <pawel@FreeBSD.org>2014-06-05 19:10:08 +0800
commit4076b918337cf5b52e5fde74870634245b963e5f (patch)
tree04b683513968c194212cf7cb12b71a9130481c52 /mail
parentd4b228b9aeaeda93ffdde3404156afba99a3647a (diff)
downloadfreebsd-ports-gnome-4076b918337cf5b52e5fde74870634245b963e5f.tar.gz
freebsd-ports-gnome-4076b918337cf5b52e5fde74870634245b963e5f.tar.zst
freebsd-ports-gnome-4076b918337cf5b52e5fde74870634245b963e5f.zip
Add staging support
Diffstat (limited to 'mail')
-rw-r--r--mail/pop3gwd/Makefile1
-rw-r--r--mail/pop3gwd/files/patch-makefile20
2 files changed, 12 insertions, 9 deletions
diff --git a/mail/pop3gwd/Makefile b/mail/pop3gwd/Makefile
index 3ea884bf6837..4e2786e48be0 100644
--- a/mail/pop3gwd/Makefile
+++ b/mail/pop3gwd/Makefile
@@ -11,5 +11,4 @@ COMMENT= App-level proxy for Mail retrieval behind Firewalls
WRKSRC= ${WRKDIR}/${PORTNAME}
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/mail/pop3gwd/files/patch-makefile b/mail/pop3gwd/files/patch-makefile
index 58b205925ac0..8e6e7512b06f 100644
--- a/mail/pop3gwd/files/patch-makefile
+++ b/mail/pop3gwd/files/patch-makefile
@@ -1,12 +1,12 @@
-# $OpenBSD: patch-makefile,v 1.1.1.1 2000/01/03 02:22:43 kevlo Exp $
---- Makefile.orig Thu Jun 19 19:06:28 1997
-+++ Makefile Wed Dec 29 12:25:33 1999
-@@ -3,22 +3,23 @@
+--- Makefile.orig 1997-06-19 11:06:28.000000000 +0200
++++ Makefile 2014-06-05 12:12:33.861436472 +0200
+@@ -2,25 +2,26 @@
+ # -------------------
-CC=gcc
-+#CC=gcc
-CFLAGS= -O2
++#CC=gcc
+CFLAGS+= -Wall
MODULES=main.o parse_cmd_line.o get_remote_data.o connect_login.o io.o relay_data.o
DOCS=README COPYING HISTORY
@@ -27,7 +27,11 @@
install:
- make
- cp -f in.pop3gwd $(INSTALL_DIR)/
-+ cp -f in.pop3gwd $(INSTALL_DIR)/pop3gwd
- [ -d $(DOC_DIR) ] || mkdir $(DOC_DIR)
- cp -f $(DOCS) $(DOC_DIR)
+- [ -d $(DOC_DIR) ] || mkdir $(DOC_DIR)
+- cp -f $(DOCS) $(DOC_DIR)
++ $(BSD_INSTALL_PROGRAM) in.pop3gwd $(DESTDIR)$(INSTALL_DIR)/pop3gwd
++ [ -d $(DOC_DIR) ] || mkdir $(DESTDIR)$(DOC_DIR)
++ $(BSD_INSTALL_DATA) $(DOCS) $(DESTDIR)$(DOC_DIR)
+ main.o: pop3-gw.h main.c
+ $(CC) $(CFLAGS) -c -o main.o main.c