aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2005-08-31 01:30:41 +0800
committergarga <garga@FreeBSD.org>2005-08-31 01:30:41 +0800
commit4163da3416788f31a1c8d28c181087facd6d9302 (patch)
tree580bf53e094f1189eba8ecd52c8c92135ea18cda /mail
parent2e793b7b6eba5f84f1dc8841baff5efd31ce5b39 (diff)
downloadfreebsd-ports-gnome-4163da3416788f31a1c8d28c181087facd6d9302.tar.gz
freebsd-ports-gnome-4163da3416788f31a1c8d28c181087facd6d9302.tar.zst
freebsd-ports-gnome-4163da3416788f31a1c8d28c181087facd6d9302.zip
- Update to 2.3-20050829
- Add CDB maps (ports/84382) - Use builtin echo - Use REINPLACE instead then scripts/configure and scripts/fix-files-list PR: ports/85489 Submitted by: maintainer
Diffstat (limited to 'mail')
-rw-r--r--mail/postfix-current/Makefile17
-rw-r--r--mail/postfix-current/distinfo4
-rw-r--r--mail/postfix-current/pkg-install54
-rw-r--r--mail/postfix-current/scripts/configure8
-rw-r--r--mail/postfix-current/scripts/configure.postfix141
-rw-r--r--mail/postfix-current/scripts/fix-files-list12
6 files changed, 113 insertions, 123 deletions
diff --git a/mail/postfix-current/Makefile b/mail/postfix-current/Makefile
index e5eb0ec7a2e0..195907208e4c 100644
--- a/mail/postfix-current/Makefile
+++ b/mail/postfix-current/Makefile
@@ -15,7 +15,7 @@
# NOTE: PCRE is enabled by default unless you specifically disable it.
PORTNAME= postfix
-DISTVERSION= 2.3-20050726
+DISTVERSION= 2.3-20050829
PORTEPOCH= 2
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/experimental/ \
@@ -86,11 +86,6 @@ POSTFIX_CCARGS+= -DHAS_PCRE -I${LOCALBASE}/include
POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lpcre
.endif
-post-patch:
- (cd ${WRKSRC} && ${MAKE} -f Makefile.init makefiles ${MAKEFILEFLAGS} \
- CCARGS="${POSTFIX_CCARGS}" AUXLIBS="${POSTFIX_AUXLIBS}" && \
- ${ECHO} "all: default" >> Makefile)
-
pre-patch:
@${ECHO} "<body>See <A HREF="header_checks.5.html">header_checks.5.html</A></BODY>" > ${WRKSRC}/html/body_checks.5.html
@for f in `${FIND} -P ${WRKSRC}/man -type f`; do \
@@ -103,6 +98,13 @@ pre-patch:
${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" $${f}; \
done
+post-patch:
+ @${REINPLACE_CMD} -e "s,!!PREFIX!!,${PREFIX},g" \
+ ${WRKSRC}/conf/main.cf ${WRKSRC}/src/global/mail_params.h
+ (cd ${WRKSRC} && ${MAKE} -f Makefile.init makefiles ${MAKEFILEFLAGS} \
+ CCARGS="${POSTFIX_CCARGS}" AUXLIBS="${POSTFIX_AUXLIBS}" && \
+ ${ECHO} "all: default" >> Makefile)
+
pre-install:
@${SETENV} ${SCRIPTS_ENV} PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
@@ -153,7 +155,8 @@ post-install:
# man pages, since the ports software compresses them after this step, and
# if we run etc/postfix/post-install again during package installation,
# it will complain about missing files.
- @${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/fix-files-list
+ @${REINPLACE_CMD} -E -e "s|(man[158]/.*.[158]):|\1.gz:|g" ${PREFIX}/etc/postfix/postfix-files
+ @${RM} -f ${PREFIX}/etc/postfix/postfix-files.bak
@${CAT} ${PKGMESSAGE}
post-clean:
diff --git a/mail/postfix-current/distinfo b/mail/postfix-current/distinfo
index 96c6b04145cd..0634a3e30eff 100644
--- a/mail/postfix-current/distinfo
+++ b/mail/postfix-current/distinfo
@@ -1,2 +1,2 @@
-MD5 (postfix/postfix-2.3-20050726.tar.gz) = 77bdd5bcbb8f8eac5ad819b619da5f68
-SIZE (postfix/postfix-2.3-20050726.tar.gz) = 2504873
+MD5 (postfix/postfix-2.3-20050829.tar.gz) = b1b3818064af1f0134fac35a8a883ae9
+SIZE (postfix/postfix-2.3-20050829.tar.gz) = 2506666
diff --git a/mail/postfix-current/pkg-install b/mail/postfix-current/pkg-install
index 73fca798b090..71e11cbeeeaf 100644
--- a/mail/postfix-current/pkg-install
+++ b/mail/postfix-current/pkg-install
@@ -34,7 +34,7 @@ ask() {
if [ x${answer} = x ]; then
answer=${default}
fi
- /bin/echo ${answer}
+ echo ${answer}
}
yesno() {
@@ -48,7 +48,7 @@ yesno() {
[Yy]*) return 0;;
[Nn]*) return 1;;
esac
- /bin/echo "Please answer yes or no."
+ echo "Please answer yes or no."
done
}
@@ -61,50 +61,50 @@ if [ x"$2" = xPRE-INSTALL ]; then
GID2=126
if /usr/sbin/pw groupshow "${GROUP}" 2>/dev/null; then
- /bin/echo "You already have a group \"${GROUP}\", so I will use it."
+ echo "You already have a group \"${GROUP}\", so I will use it."
else
if /usr/sbin/pw groupadd ${GROUP} -g ${GID}; then
- /bin/echo "Added group \"${GROUP}\"."
+ echo "Added group \"${GROUP}\"."
else
- /bin/echo "Adding group \"${GROUP}\" failed..."
- /bin/echo "Please create it, and try again."
+ echo "Adding group \"${GROUP}\" failed..."
+ echo "Please create it, and try again."
exit 1
fi
fi
if /usr/sbin/pw groupshow "${GROUP2}" 2>/dev/null; then
- /bin/echo "You already have a group \"${GROUP2}\", so I will use it."
+ echo "You already have a group \"${GROUP2}\", so I will use it."
else
if /usr/sbin/pw groupadd ${GROUP2} -g ${GID2}; then
- /bin/echo "Added group \"${GROUP2}\"."
+ echo "Added group \"${GROUP2}\"."
else
- /bin/echo "Adding group \"${GROUP2}\" failed..."
- /bin/echo "Please create it, and try again."
+ echo "Adding group \"${GROUP2}\" failed..."
+ echo "Please create it, and try again."
exit 1
fi
fi
if /usr/sbin/pw user show "${USER}" 2>/dev/null; then
- /bin/echo "You already have a user \"${USER}\", so I will use it."
+ echo "You already have a user \"${USER}\", so I will use it."
else
if /usr/sbin/pw useradd ${USER} -u ${UID} -g ${GROUP} -h - -d /var/spool/postfix -s ${NOLOGIN} -c "Postfix Mail System"; then
- /bin/echo "Added user \"${USER}\"."
+ echo "Added user \"${USER}\"."
else
- /bin/echo "Adding user \"${USER}\" failed..."
- /bin/echo "Please create it, and try again."
+ echo "Adding user \"${USER}\" failed..."
+ echo "Please create it, and try again."
exit 1
fi
fi
if /usr/sbin/pw show group mail | grep -q "${USER}" 2>/dev/null; then
- /bin/echo "You already have user \"${USER}\" in group \"mail\", so I will use it."
+ echo "You already have user \"${USER}\" in group \"mail\", so I will use it."
else
- /bin/echo "You need user \"${USER}\" added to group \"mail\"."
+ echo "You need user \"${USER}\" added to group \"mail\"."
if yesno "Would you like me to add it" y; then
/usr/sbin/pw groupmod mail -m ${USER} || exit
- /bin/echo "Done."
+ echo "Done."
else
- /bin/echo "Please create it, and try again."
+ echo "Please create it, and try again."
exit 1
fi
fi
@@ -160,21 +160,21 @@ if [ x"$2" = xPOST-INSTALL -a -z "${PACKAGE_BUILDING}" ]; then
if [ ${OSVERSION} -ge 400014 ]; then
if yesno "Would you like to activate Postfix in /etc/mail/mailer.conf" ${DEFAULT_REPLACE_MAILERCONF}; then
/bin/mv -f /etc/mail/mailer.conf /etc/mail/mailer.conf.old
- /bin/echo "#" > /etc/mail/mailer.conf
- /bin/echo -n "# Execute the Postfix sendmail program" >> /etc/mail/mailer.conf
- /bin/echo ", named ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- /bin/echo "#" >> /etc/mail/mailer.conf
- /bin/echo "sendmail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- /bin/echo "send-mail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- /bin/echo "mailq ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- /bin/echo "newaliases ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "#" > /etc/mail/mailer.conf
+ echo -n "# Execute the Postfix sendmail program" >> /etc/mail/mailer.conf
+ echo ", named ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "#" >> /etc/mail/mailer.conf
+ echo "sendmail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "send-mail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "mailq ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "newaliases ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
fi
else
if yesno "Would you like to replace {sendmail,mailq,newaliases} with Postfix versions" n; then
replace /usr/sbin/sendmail ${PKG_PREFIX}/sbin/sendmail
replace /usr/bin/mailq ${PKG_PREFIX}/sbin/sendmail
replace /usr/bin/newaliases ${PKG_PREFIX}/sbin/sendmail
- /bin/echo "Done."
+ echo "Done."
fi
fi
fi
diff --git a/mail/postfix-current/scripts/configure b/mail/postfix-current/scripts/configure
deleted file mode 100644
index 93c5b95ec561..000000000000
--- a/mail/postfix-current/scripts/configure
+++ /dev/null
@@ -1,8 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-
-for f in `find ${WRKSRC} -type f | xargs grep -l '\!\!PREFIX\!\!' ` ; do \
- mv $f $f.orig && sed s+!!PREFIX!!+$PREFIX+g < $f.orig > $f && \
- rm $f.orig
-done
diff --git a/mail/postfix-current/scripts/configure.postfix b/mail/postfix-current/scripts/configure.postfix
index cb9d3642ae48..dd666620cf44 100644
--- a/mail/postfix-current/scripts/configure.postfix
+++ b/mail/postfix-current/scripts/configure.postfix
@@ -33,6 +33,7 @@ DB43 "Berkeley DB4.3 (required if SASL also built with DB4.3)" "$status_DB43" \
MySQL "MySQL map lookups (choose version with WITH_MYSQL_VER)" "$status_MySQL" \
PgSQL "PostgreSQL map lookups (choose with DEFAULT_PGSQL_VER)" "$status_PgSQL" \
OpenLDAP "OpenLDAP map lookups (choose ver. with WITH_OPENLDAP_VER)" "$status_OpenLDAP" \
+CDB "CDB map lookups" "$status_CDB" \
NIS "NIS map lookups" "$status_NIS" \
Test "SMTP/LMTP test server and generator" "$status_Test" \
2> $tempfile
@@ -46,10 +47,10 @@ Test "SMTP/LMTP test server and generator" "$status_Test" \
case $retval in
0) if [ -z "$*" ]; then
- /bin/echo "Nothing selected"
+ echo "Nothing selected"
fi
;;
- 1) /bin/echo "Cancel pressed."
+ 1) echo "Cancel pressed."
exit 1
;;
esac
@@ -58,22 +59,22 @@ fi
${MKDIR} ${WRKDIRPREFIX}${CURDIR}
exec > ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
-/bin/echo "PREFIX= ${PREFIX}"
+echo "PREFIX= ${PREFIX}"
SUB_TEST="@comment "
while [ "$1" ]; do
case $1 in
NOPCRE)
- /bin/echo "WITHOUT_PCRE= yes"
- /bin/echo "NOPCRE_SUFFIX= +nopcre"
+ echo "WITHOUT_PCRE= yes"
+ echo "NOPCRE_SUFFIX= +nopcre"
SUB_NOPCRE=""
;;
SASL)
- /bin/echo "LIB_DEPENDS+= sasl.8:\${PORTSDIR}/security/cyrus-sasl"
- /bin/echo "POSTFIX_CCARGS+= -DUSE_SASL_AUTH -I\${LOCALBASE}/include -I\${LOCALBASE}/include/sasl1"
- /bin/echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib -lsasl -lpam -lcrypt"
- /bin/echo "SASL_SUFFIX= +sasl"
+ echo "LIB_DEPENDS+= sasl.8:\${PORTSDIR}/security/cyrus-sasl"
+ echo "POSTFIX_CCARGS+= -DUSE_SASL_AUTH -I\${LOCALBASE}/include -I\${LOCALBASE}/include/sasl1"
+ echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib -lsasl -lpam -lcrypt"
+ echo "SASL_SUFFIX= +sasl"
if [ -f ${LOCALBASE}/lib/libsasl.a ]; then
if /usr/bin/nm ${LOCALBASE}/lib/libsasl.a | grep -wq "mysql_init"; then
SASL_USE_MYSQL="YES"
@@ -81,10 +82,10 @@ while [ "$1" ]; do
fi
;;
SASL2)
- /bin/echo "LIB_DEPENDS+= sasl2.2:\${PORTSDIR}/security/cyrus-sasl2"
- /bin/echo "POSTFIX_CCARGS+= -DUSE_SASL_AUTH -I\${LOCALBASE}/include -I\${LOCALBASE}/include/sasl"
- /bin/echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib -lsasl2 -lpam -lcrypt"
- /bin/echo "SASL_SUFFIX= +sasl2"
+ echo "LIB_DEPENDS+= sasl2.2:\${PORTSDIR}/security/cyrus-sasl2"
+ echo "POSTFIX_CCARGS+= -DUSE_SASL_AUTH -I\${LOCALBASE}/include -I\${LOCALBASE}/include/sasl"
+ echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib -lsasl2 -lpam -lcrypt"
+ echo "SASL_SUFFIX= +sasl2"
if [ -f ${LOCALBASE}/lib/libsasl2.a ]; then
if /usr/bin/nm ${LOCALBASE}/lib/libsasl2.a | grep -wq "mysql_init"; then
SASL_USE_MYSQL="YES"
@@ -92,16 +93,16 @@ while [ "$1" ]; do
fi
;;
SASLKRB)
- /bin/echo "POSTFIX_AUXLIBS+= -lkrb -lcrypto -lcom_err"
+ echo "POSTFIX_AUXLIBS+= -lkrb -lcrypto -lcom_err"
;;
SASLKRB5)
- /bin/echo "POSTFIX_AUXLIBS+= -lkrb5 -lcrypto -lcrypt -lcom_err -lasn1 -lroken"
+ echo "POSTFIX_AUXLIBS+= -lkrb5 -lcrypto -lcrypt -lcom_err -lasn1 -lroken"
;;
TLS)
- /bin/echo "USE_OPENSSL= yes"
- /bin/echo "POSTFIX_CCARGS+= -DUSE_TLS -I\${OPENSSLINC}"
- /bin/echo "POSTFIX_AUXLIBS+= -L\${OPENSSLLIB} -lssl -lcrypto"
- /bin/echo "TLS_SUFFIX= +tls"
+ echo "USE_OPENSSL= yes"
+ echo "POSTFIX_CCARGS+= -DUSE_TLS -I\${OPENSSLINC}"
+ echo "POSTFIX_AUXLIBS+= -L\${OPENSSLLIB} -lssl -lcrypto"
+ echo "TLS_SUFFIX= +tls"
;;
DB3)
if [ "X$BDB_SELECTED" != "X" ]; then
@@ -109,10 +110,10 @@ while [ "$1" ]; do
rm -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
exit 1
fi
- /bin/echo "LIB_DEPENDS+= db3.3:\${PORTSDIR}/databases/db3"
- /bin/echo "POSTFIX_CCARGS+= -I\${LOCALBASE}/include/db3"
- /bin/echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib -ldb3"
- /bin/echo "DB_SUFFIX= +db3"
+ echo "LIB_DEPENDS+= db3.3:\${PORTSDIR}/databases/db3"
+ echo "POSTFIX_CCARGS+= -I\${LOCALBASE}/include/db3"
+ echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib -ldb3"
+ echo "DB_SUFFIX= +db3"
BDB_SELECTED="3"
;;
DB40)
@@ -121,10 +122,10 @@ while [ "$1" ]; do
rm -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
exit 1
fi
- /bin/echo "LIB_DEPENDS+= db4.0:\${PORTSDIR}/databases/db4"
- /bin/echo "POSTFIX_CCARGS+= -I\${LOCALBASE}/include/db4"
- /bin/echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib -ldb4"
- /bin/echo "DB_SUFFIX= +db40"
+ echo "LIB_DEPENDS+= db4.0:\${PORTSDIR}/databases/db4"
+ echo "POSTFIX_CCARGS+= -I\${LOCALBASE}/include/db4"
+ echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib -ldb4"
+ echo "DB_SUFFIX= +db40"
BDB_SELECTED="40"
;;
DB41)
@@ -133,10 +134,10 @@ while [ "$1" ]; do
rm -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
exit 1
fi
- /bin/echo "LIB_DEPENDS+= db41.1:\${PORTSDIR}/databases/db41"
- /bin/echo "POSTFIX_CCARGS+= -I\${LOCALBASE}/include/db41"
- /bin/echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib -ldb41"
- /bin/echo "DB_SUFFIX= +db41"
+ echo "LIB_DEPENDS+= db41.1:\${PORTSDIR}/databases/db41"
+ echo "POSTFIX_CCARGS+= -I\${LOCALBASE}/include/db41"
+ echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib -ldb41"
+ echo "DB_SUFFIX= +db41"
BDB_SELECTED="41"
;;
DB42)
@@ -145,10 +146,10 @@ while [ "$1" ]; do
rm -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
exit 1
fi
- /bin/echo "LIB_DEPENDS+= db-4.2.2:\${PORTSDIR}/databases/db42"
- /bin/echo "POSTFIX_CCARGS+= -I\${LOCALBASE}/include/db42"
- /bin/echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib/db42/ -ldb"
- /bin/echo "DB_SUFFIX= +db42"
+ echo "LIB_DEPENDS+= db-4.2.2:\${PORTSDIR}/databases/db42"
+ echo "POSTFIX_CCARGS+= -I\${LOCALBASE}/include/db42"
+ echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib/db42/ -ldb"
+ echo "DB_SUFFIX= +db42"
BDB_SELECTED="42"
;;
DB43)
@@ -157,49 +158,55 @@ while [ "$1" ]; do
rm -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
exit 1
fi
- /bin/echo "LIB_DEPENDS+= db-4.3.0:\${PORTSDIR}/databases/db43"
- /bin/echo "POSTFIX_CCARGS+= -I\${LOCALBASE}/include/db43"
- /bin/echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib/db43/ -ldb"
- /bin/echo "DB_SUFFIX= +db43"
+ echo "LIB_DEPENDS+= db-4.3.0:\${PORTSDIR}/databases/db43"
+ echo "POSTFIX_CCARGS+= -I\${LOCALBASE}/include/db43"
+ echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib/db43/ -ldb"
+ echo "DB_SUFFIX= +db43"
BDB_SELECTED="43"
;;
MySQL)
- /bin/echo "USE_MYSQL=YES"
- /bin/echo "POSTFIX_CCARGS+= -DHAS_MYSQL -I\${LOCALBASE}/include/mysql"
- /bin/echo "POSTFIX_AUXLIBS+= \${LOCALBASE}/lib/mysql/libmysqlclient.a -lm -lz -lcrypt"
+ echo "USE_MYSQL=YES"
+ echo "POSTFIX_CCARGS+= -DHAS_MYSQL -I\${LOCALBASE}/include/mysql"
+ echo "POSTFIX_AUXLIBS+= \${LOCALBASE}/lib/mysql/libmysqlclient.a -lm -lz -lcrypt"
if [ -f ${LOCALBASE}/lib/mysql/libmysqlclient.a ]; then
if /usr/bin/nm ${LOCALBASE}/lib/mysql/libmysqlclient.a | grep -wq "SSL_new"; then
- /bin/echo "USE_OPENSSL= yes"
- /bin/echo "POSTFIX_CCARGS+= -I\${OPENSSLLIB}"
- /bin/echo "POSTFIX_AUXLIBS+= -L\${OPENSSLLIB} -lssl -lcrypto"
+ echo "USE_OPENSSL= yes"
+ echo "POSTFIX_CCARGS+= -I\${OPENSSLLIB}"
+ echo "POSTFIX_AUXLIBS+= -L\${OPENSSLLIB} -lssl -lcrypto"
fi
fi
- /bin/echo "MYSQL_SUFFIX= +mysql"
+ echo "MYSQL_SUFFIX= +mysql"
MYSQL_SELECTED="YES"
;;
PgSQL)
- /bin/echo "USE_PGSQL=YES"
- /bin/echo "POSTFIX_CCARGS+= -DHAS_PGSQL -I\${LOCALBASE}/include -I\${LOCALBASE}/pgsql/include"
- /bin/echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib -L\${LOCALBASE}/pgsql/lib -lpq -lcrypt"
- /bin/echo "PGSQL_SUFFIX= +pgsql"
+ echo "USE_PGSQL=YES"
+ echo "POSTFIX_CCARGS+= -DHAS_PGSQL -I\${LOCALBASE}/include -I\${LOCALBASE}/pgsql/include"
+ echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib -L\${LOCALBASE}/pgsql/lib -lpq -lcrypt"
+ echo "PGSQL_SUFFIX= +pgsql"
;;
OpenLDAP)
- /bin/echo "USE_OPENLDAP=YES"
- /bin/echo "POSTFIX_CCARGS+= -DHAS_LDAP -I\${LOCALBASE}/include"
- /bin/echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib -lldap -llber"
- /bin/echo "OPENLDAP_SUFFIX= +openldap"
+ echo "USE_OPENLDAP=YES"
+ echo "POSTFIX_CCARGS+= -DHAS_LDAP -I\${LOCALBASE}/include"
+ echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib -lldap -llber"
+ echo "OPENLDAP_SUFFIX= +openldap"
+ ;;
+ CDB)
+ echo "BUILD_DEPENDS+= \${LOCALBASE}/lib/libcdb.a:\${PORTSDIR}/databases/tinycdb"
+ echo "POSTFIX_CCARGS+= -DHAS_CDB -I\${LOCALBASE}/include"
+ echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib -lcdb"
+ echo "CDB_SUFFIX= +cdb"
;;
NIS)
- /bin/echo "POSTFIX_CCARGS+= -DHAS_NIS"
- /bin/echo "NIS_SUFFIX= +nis"
+ echo "POSTFIX_CCARGS+= -DHAS_NIS"
+ echo "NIS_SUFFIX= +nis"
;;
Test)
- /bin/echo "BIN1= smtp-sink smtp-source qmqp-source"
-# /bin/echo "MAN1+= smtp-sink.1 smtp-source.1 qmqp-sink.1 qmqp-source.1"
+ echo "BIN1= smtp-sink smtp-source qmqp-source"
+# echo "MAN1+= smtp-sink.1 smtp-source.1 qmqp-sink.1 qmqp-source.1"
SUB_TEST=""
;;
*)
- /bin/echo "Unknown option(s): $*" > /dev/stderr
+ echo "Unknown option(s): $*" > /dev/stderr
rm -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
exit 1
;;
@@ -211,24 +218,24 @@ if [ -z "${BATCH}" ]; then
if [ "X$SASL_USE_MYSQL" != "X" ] && [ "$MYSQL_SELECTED" != "YES" ]; then
/usr/bin/dialog --yesno "Your lib SASL it is compiled with MySQL. It desires to use the MySQL?" 5 80 > /dev/stderr
if [ $? = 0 ]; then
- /bin/echo "USE_MYSQL=YES"
- /bin/echo "POSTFIX_CCARGS+= -DHAS_MYSQL -I\${LOCALBASE}/include/mysql"
- /bin/echo "POSTFIX_AUXLIBS+= \${LOCALBASE}/lib/mysql/libmysqlclient.a -lm -lz -lcrypt"
+ echo "USE_MYSQL=YES"
+ echo "POSTFIX_CCARGS+= -DHAS_MYSQL -I\${LOCALBASE}/include/mysql"
+ echo "POSTFIX_AUXLIBS+= \${LOCALBASE}/lib/mysql/libmysqlclient.a -lm -lz -lcrypt"
if [ -f ${LOCALBASE}/lib/mysql/libmysqlclient.a ]; then
if /usr/bin/nm ${LOCALBASE}/lib/mysql/libmysqlclient.a | grep -wq "SSL_new"; then
- /bin/echo "USE_OPENSSL= yes"
- /bin/echo "POSTFIX_CCARGS+= -I\${OPENSSLLIB}"
- /bin/echo "POSTFIX_AUXLIBS+= -L\${OPENSSLLIB} -lssl -lcrypto"
+ echo "USE_OPENSSL= yes"
+ echo "POSTFIX_CCARGS+= -I\${OPENSSLLIB}"
+ echo "POSTFIX_AUXLIBS+= -L\${OPENSSLLIB} -lssl -lcrypto"
fi
fi
fi
fi
fi
-/bin/echo "PLIST_SUB+= SUB_TEST=\"${SUB_TEST}\""
+echo "PLIST_SUB+= SUB_TEST=\"${SUB_TEST}\""
# for some reason, if we alter the pkg name this way, the first build (where
# we ask the configure questions) doesn't pick up the extensions, but
# any subsequent build will. so "make; make install" will build twice.
# don't do this for now.
-#/bin/echo "PKGNAMESUFFIX= \${NOPCRE_SUFFIX}\${SASL_SUFFIX}\${DB_SUFFIX}\${MYSQL_SUFFIX}\${PGSQL_SUFFIX}\${OPENLDAP_SUFFIX}\${TLS_SUFFIX}\${NIS_SUFFIX}"
+#echo "PKGNAMESUFFIX=\${NOPCRE_SUFFIX}\${SASL_SUFFIX}\${DB_SUFFIX}\${MYSQL_SUFFIX}\${PGSQL_SUFFIX}\${OPENLDAP_SUFFIX}\${TLS_SUFFIX}\${TLS_SUFFIX}\${NIS_SUFFIX}"
diff --git a/mail/postfix-current/scripts/fix-files-list b/mail/postfix-current/scripts/fix-files-list
deleted file mode 100644
index cc4a1083a814..000000000000
--- a/mail/postfix-current/scripts/fix-files-list
+++ /dev/null
@@ -1,12 +0,0 @@
-#!/bin/sh
-
-# need to fixup ${PREFIX}/etc/postfix/postfix-files to indicate compressed
-# man pages, since the ports software compresses them later, and if we
-# run post-install it will complain about missing files
-# (script from Simon J. Mudd)
-
-ed ${PREFIX}/etc/postfix/postfix-files <<EOF || exit 1
-%s/\(\/man[158]\/.*\.[158]\):/\1.gz:/
-w
-q
-EOF