aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-07-20 22:17:26 +0800
committertobik <tobik@FreeBSD.org>2018-07-20 22:17:26 +0800
commit4433b04b58641940872deb56aec7485177265a33 (patch)
treeda7444b4181b08691ce58bdece31516cb5266fa8 /mail
parentb383d343c1e85cd0ed547f27f132b02e8b76f9c9 (diff)
downloadfreebsd-ports-gnome-4433b04b58641940872deb56aec7485177265a33.tar.gz
freebsd-ports-gnome-4433b04b58641940872deb56aec7485177265a33.tar.zst
freebsd-ports-gnome-4433b04b58641940872deb56aec7485177265a33.zip
mail/qmail-dk: Fix build with lld
/usr/bin/ld: error: duplicate symbol: scan_ulong >>> defined at scan_ulong.c >>> scan_ulong.o:(scan_ulong) in archive fs.a >>> defined at scan_ulong.c >>> scan_ulong.o:(.text+0x0) http://beefy12.nyi.freebsd.org/data/head-amd64-default/p474767_s336359/logs/qmail-dk-0.54_1.log scan_ulong.o is added to fs.a and appears twice in the link command line (via fs.a and listed explicitly) which results in a duplicate symbol error with lld. Removing scan_ulong.o from the link command line would result in an undefined reference error when linking auto-int with ld.bfd, so remove it from fs.a instead. Attempt to build on aarch64 again as the error message is the same. PR: 221812 Reported by: emaste, pkg-fallout
Diffstat (limited to 'mail')
-rw-r--r--mail/qmail-dk/Makefile2
-rw-r--r--mail/qmail-dk/files/patch-Makefile31
2 files changed, 31 insertions, 2 deletions
diff --git a/mail/qmail-dk/Makefile b/mail/qmail-dk/Makefile
index 31ed3cc0b5db..ca69bd9d7d92 100644
--- a/mail/qmail-dk/Makefile
+++ b/mail/qmail-dk/Makefile
@@ -12,8 +12,6 @@ DIST_SUBDIR= qmail
MAINTAINER= ports@FreeBSD.org
COMMENT= DomainKeys implementation for qmail
-BROKEN_aarch64= fails to link: scan_ulong.c:(.text+0x0): duplicate symbol 'scan_ulong'
-
LIB_DEPENDS+= libdomainkeys.so:mail/libdomainkeys
PATCH_SITES= QMAIL
diff --git a/mail/qmail-dk/files/patch-Makefile b/mail/qmail-dk/files/patch-Makefile
new file mode 100644
index 000000000000..bf6cea8614de
--- /dev/null
+++ b/mail/qmail-dk/files/patch-Makefile
@@ -0,0 +1,31 @@
+/usr/bin/ld: error: duplicate symbol: scan_ulong
+ >>> defined at scan_ulong.c
+ >>> scan_ulong.o:(scan_ulong) in archive fs.a
+ >>> defined at scan_ulong.c
+ >>> scan_ulong.o:(.text+0x0)
+
+--- Makefile.orig 2018-07-20 14:10:56 UTC
++++ Makefile
+@@ -37,8 +37,8 @@ scan.h fmt.h
+ ./compile auto-gid.c
+
+ auto-int: \
+-load auto-int.o substdio.a error.a str.a fs.a
+- ./load auto-int substdio.a error.a str.a fs.a
++load auto-int.o substdio.a error.a str.a fs.a scan_ulong.o
++ ./load auto-int substdio.a error.a str.a fs.a scan_ulong.o
+
+ auto-int.o: \
+ compile auto-int.c substdio.h readwrite.h exit.h scan.h fmt.h
+@@ -609,9 +609,9 @@ strerr.h substdio.h fmt.h
+
+ fs.a: \
+ makelib fmt_str.o fmt_strn.o fmt_uint.o fmt_uint0.o fmt_ulong.o \
+-scan_ulong.o scan_8long.o
++scan_8long.o
+ ./makelib fs.a fmt_str.o fmt_strn.o fmt_uint.o fmt_uint0.o \
+- fmt_ulong.o scan_ulong.o scan_8long.o
++ fmt_ulong.o scan_8long.o
+
+ getln.a: \
+ makelib getln.o getln2.o