aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorjfitz <jfitz@FreeBSD.org>1997-06-25 02:43:34 +0800
committerjfitz <jfitz@FreeBSD.org>1997-06-25 02:43:34 +0800
commit5cafe13f0d4bb398c9d0d7257a5690698385d9eb (patch)
treedaf5bfe3bf7b554d2376a303a250d14f858a016a /mail
parent3351443cc3e46b27c564a255306d3930d2368653 (diff)
downloadfreebsd-ports-gnome-5cafe13f0d4bb398c9d0d7257a5690698385d9eb.tar.gz
freebsd-ports-gnome-5cafe13f0d4bb398c9d0d7257a5690698385d9eb.tar.zst
freebsd-ports-gnome-5cafe13f0d4bb398c9d0d7257a5690698385d9eb.zip
Make all p5- ports use USE_PERL instead of explicitly stating the version number in each Makefile
In-Conjunction-With: Satoshi's patch to bsd.port.mk (note: unlike the last change in perl5 versions, I have only upgraded p5-* ports, not other ports that rely upon perl5.)
Diffstat (limited to 'mail')
-rw-r--r--mail/p5-Mail-Folder/Makefile5
-rw-r--r--mail/p5-Mail-POP3Client/Makefile5
-rw-r--r--mail/p5-Mail-Tools/Makefile8
3 files changed, 8 insertions, 10 deletions
diff --git a/mail/p5-Mail-Folder/Makefile b/mail/p5-Mail-Folder/Makefile
index a96a8c3cf3d4..f9ce42364e31 100644
--- a/mail/p5-Mail-Folder/Makefile
+++ b/mail/p5-Mail-Folder/Makefile
@@ -3,7 +3,7 @@
# Date created: October 24th 1996
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
-# $Id: Makefile,v 1.6 1997/04/20 21:26:27 jfitz Exp $
+# $Id: Makefile,v 1.7 1997/05/24 13:17:10 jfitz Exp $
#
DISTNAME= MailFolder-0.06
@@ -14,8 +14,7 @@ MASTER_SITE_SUBDIR= Mail
MAINTAINER= jfitz@FreeBSD.ORG
-BUILD_DEPENDS= perl5.004:${PORTSDIR}/lang/perl5
-RUN_DEPENDS= perl5.004:${PORTSDIR}/lang/perl5
+USE_PERL5= YES
MAN3= Mail::Folder.3 Mail::Folder::Emaul.3 Mail::Folder::Mbox.3 Mail::Folder::NNTP.3 Mail::Folder::Maildir.3
MANPREFIX= ${PREFIX}/lib/perl5
diff --git a/mail/p5-Mail-POP3Client/Makefile b/mail/p5-Mail-POP3Client/Makefile
index b320c865c1dd..7ec79a4accd9 100644
--- a/mail/p5-Mail-POP3Client/Makefile
+++ b/mail/p5-Mail-POP3Client/Makefile
@@ -3,7 +3,7 @@
# Date created: October 24th 1996
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
-# $Id: Makefile,v 1.6 1997/04/20 21:26:35 jfitz Exp $
+# $Id: Makefile,v 1.7 1997/05/24 13:17:10 jfitz Exp $
#
DISTNAME= POP3Client-1_15
@@ -14,8 +14,7 @@ MASTER_SITE_SUBDIR= Mail
MAINTAINER= jfitz@FreeBSD.ORG
-BUILD_DEPENDS= perl5.004:${PORTSDIR}/lang/perl5
-RUN_DEPENDS= perl5.004:${PORTSDIR}/lang/perl5
+USE_PERL5= YES
MAN3= Mail::POP3Client.3
MANPREFIX= ${PREFIX}/lib/perl5
diff --git a/mail/p5-Mail-Tools/Makefile b/mail/p5-Mail-Tools/Makefile
index 802408befc43..60509785c82e 100644
--- a/mail/p5-Mail-Tools/Makefile
+++ b/mail/p5-Mail-Tools/Makefile
@@ -3,7 +3,7 @@
# Date created: October 24th 1996
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
-# $Id: Makefile,v 1.6 1997/04/20 13:52:35 wosch Exp $
+# $Id: Makefile,v 1.7 1997/05/24 13:17:11 jfitz Exp $
#
DISTNAME= MailTools-1.09
@@ -14,10 +14,10 @@ MASTER_SITE_SUBDIR= Mail
MAINTAINER= jfitz@FreeBSD.ORG
-BUILD_DEPENDS= perl5.004:${PORTSDIR}/lang/perl5 \
- ${PREFIX}/lib/perl5/site_perl/Net/SMTP.pm:${PORTSDIR}/net/p5-Net \
+BUILD_DEPENDS= ${PREFIX}/lib/perl5/site_perl/Net/SMTP.pm:${PORTSDIR}/net/p5-Net \
${PREFIX}/lib/perl5/site_perl/Net/Domain.pm:${PORTSDIR}/net/p5-Net
-RUN_DEPENDS= perl5.004:${PORTSDIR}/lang/perl5
+
+USE_PERL5= YES
MAN3= Mail::Address.3 Mail::Cap.3 Mail::Field.3 Mail::Header.3 \
Mail::Internet.3 Mail::Alias.3 Mail::Mailer.3 Mail::Send.3 \