aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2005-12-28 06:41:55 +0800
committermnag <mnag@FreeBSD.org>2005-12-28 06:41:55 +0800
commit632f94365edef3a477d775f673f62d4d376aacb5 (patch)
treeccd66cb1f5ad306f4a9c4599a2b806863437410c /mail
parent327f1e8a90cac2520023753ec3c8dc9d893bb912 (diff)
downloadfreebsd-ports-gnome-632f94365edef3a477d775f673f62d4d376aacb5.tar.gz
freebsd-ports-gnome-632f94365edef3a477d775f673f62d4d376aacb5.tar.zst
freebsd-ports-gnome-632f94365edef3a477d775f673f62d4d376aacb5.zip
Add Dovecot SASL authentication method (http://www.postfix.org/SASL_README.html#server_dovecot)
Notified by: Tracy Phillips <tracy.phillips@rackeasy.com>
Diffstat (limited to 'mail')
-rw-r--r--mail/postfix-current/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/mail/postfix-current/Makefile b/mail/postfix-current/Makefile
index 26f3a4d9cb12..005ff5032040 100644
--- a/mail/postfix-current/Makefile
+++ b/mail/postfix-current/Makefile
@@ -31,6 +31,7 @@ USE_PERL5_BUILD=yes
OPTIONS= PCRE "Perl Compatible Regular Expressions" on \
SASL "Cyrus SASLv1 (Simple Auth. and Sec. Layer)" off \
SASL2 "Cyrus SASLv2 (Simple Auth. and Sec. Layer)" off \
+ DOVECOT "Dovecot SASL authentication method" off \
SASLKRB "If your SASL req. Kerberos select this option" off \
SASLKRB5 "If your SASL req. Kerberos5 select this option" off \
SASLKMIT "If your SASL req. MIT Kerberos5 select this option" off \
@@ -91,8 +92,8 @@ POSTFIX_CCARGS+= -DNO_PCRE
.endif
.if defined(WITH_SASL)
-.if defined(WITH_SASL2)
-BROKEN= "Select only one SASL version"
+.if defined(WITH_SASL2) || defined(WITH_DOVECOT)
+BROKEN= "Select only one SASL authentication method"
.endif
LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
POSTFIX_CCARGS+= -DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I${LOCALBASE}/include -I${LOCALBASE}/include/sasl1
@@ -100,14 +101,22 @@ POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lsasl -lpam -lcrypt
.endif
.if defined(WITH_SASL2)
-.if defined(WITH_SASL)
-BROKEN= "Select only one SASL version"
+.if defined(WITH_SASL) || defined(WITH_DOVECOT)
+BROKEN= "Select only one SASL authentication method"
.endif
LIB_DEPENDS+= sasl2.2:${PORTSDIR}/security/cyrus-sasl2
POSTFIX_CCARGS+= -DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I${LOCALBASE}/include -I${LOCALBASE}/include/sasl
POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lsasl2 -lpam -lcrypt
.endif
+.if defined(WITH_DOVECOT)
+.if defined(WITH_SASL) || defined(WITH_SASL2)
+BROKEN= "Select only one SASL authentication method"
+.endif
+RUN_DEPENDS+= dovecot:${PORTSDIR}/mail/dovecot
+POSTFIX_CCARGS+= -DUSE_SASL_AUTH -DDEF_SASL_SERVER=\"dovecot\"
+.endif
+
.if defined(WITH_SASLKRB)
.if defined(WITH_SASLKRB5) || defined(WITH_SASLKMIT)
BROKEN= "Select only one SASL Kerberos option"