aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authortabthorpe <tabthorpe@FreeBSD.org>2010-02-02 11:15:19 +0800
committertabthorpe <tabthorpe@FreeBSD.org>2010-02-02 11:15:19 +0800
commit683688e9eedd5b3efede8ef1562b60d763594dcf (patch)
tree676c007dbfcd6ee02019af55196f7d82c3664815 /mail
parent4a3ea880ca032737617a95b61ec037aec396810c (diff)
downloadfreebsd-ports-gnome-683688e9eedd5b3efede8ef1562b60d763594dcf.tar.gz
freebsd-ports-gnome-683688e9eedd5b3efede8ef1562b60d763594dcf.tar.zst
freebsd-ports-gnome-683688e9eedd5b3efede8ef1562b60d763594dcf.zip
Allows for the importing of addressbooks from a CSV (comma separated
values) file. This will be located at the bottom of the "Addresses" section. WWW: http://www.squirrelmail.org/plugin_view.php?id=29 PR: ports/143303 Submitted by: Scott Lambert <lambert at lambertfam.org>
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/squirrelmail-abook_import_export-plugin/Makefile23
-rw-r--r--mail/squirrelmail-abook_import_export-plugin/distinfo3
-rw-r--r--mail/squirrelmail-abook_import_export-plugin/files/pkg-message.in7
-rw-r--r--mail/squirrelmail-abook_import_export-plugin/pkg-descr5
-rw-r--r--mail/squirrelmail-abook_import_export-plugin/pkg-plist17
6 files changed, 56 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 4a70f84aa20b..55452d907754 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -640,6 +640,7 @@
SUBDIR += spruce
SUBDIR += sqlgrey
SUBDIR += squirrelmail
+ SUBDIR += squirrelmail-abook_import_export-plugin
SUBDIR += squirrelmail-avelsieve-plugin
SUBDIR += squirrelmail-calendar_file_backend-plugin
SUBDIR += squirrelmail-calendar_sql_backend-plugin
diff --git a/mail/squirrelmail-abook_import_export-plugin/Makefile b/mail/squirrelmail-abook_import_export-plugin/Makefile
new file mode 100644
index 000000000000..d72c9e556175
--- /dev/null
+++ b/mail/squirrelmail-abook_import_export-plugin/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: squirrelmail-abook_import-export-plugin
+# Date created: 2010-01-27
+# Whom: Scott Lambert <lambert@lambertfam.org>
+# Modified from: squirrelmail-check_quota-plugin
+#
+# $FreeBSD$
+#
+
+PORTNAME= abook_import_export
+PORTVERSION= 1.1
+DISTNAME= ${PORTNAME:S/-/_/}-${PORTVERSION}-1.4.4
+DIST_SUBDIR= squirrelmail
+
+MAINTAINER= lambert@lambertfam.org
+COMMENT= Allows for the importing of addressbooks from a CSV (comma separated values) file.
+
+SQUIRREL_PLUGIN_NAME= ${PORTNAME:S/-/_/}
+
+.include <bsd.port.pre.mk>
+
+.include "${PORTSDIR}/mail/squirrelmail/bsd.squirrelmail.mk"
+
+.include <bsd.port.post.mk>
diff --git a/mail/squirrelmail-abook_import_export-plugin/distinfo b/mail/squirrelmail-abook_import_export-plugin/distinfo
new file mode 100644
index 000000000000..a463f2aa4004
--- /dev/null
+++ b/mail/squirrelmail-abook_import_export-plugin/distinfo
@@ -0,0 +1,3 @@
+MD5 (squirrelmail/abook_import_export-1.1-1.4.4.tar.gz) = 29708739d856ad4d1a18bd6e840316a4
+SHA256 (squirrelmail/abook_import_export-1.1-1.4.4.tar.gz) = 59f2c795170f2155076d5c5e730415c3148e469f775bb0cde617652b6d1bfe26
+SIZE (squirrelmail/abook_import_export-1.1-1.4.4.tar.gz) = 23988
diff --git a/mail/squirrelmail-abook_import_export-plugin/files/pkg-message.in b/mail/squirrelmail-abook_import_export-plugin/files/pkg-message.in
new file mode 100644
index 000000000000..f973030e458b
--- /dev/null
+++ b/mail/squirrelmail-abook_import_export-plugin/files/pkg-message.in
@@ -0,0 +1,7 @@
+================================================================
+You may want to copy the file
+%%PREFIX%%/%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config_default.php
+to
+%%PREFIX%%/%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.php
+and edit the configuration to meet your needs.
+================================================================
diff --git a/mail/squirrelmail-abook_import_export-plugin/pkg-descr b/mail/squirrelmail-abook_import_export-plugin/pkg-descr
new file mode 100644
index 000000000000..ec1e4f03c287
--- /dev/null
+++ b/mail/squirrelmail-abook_import_export-plugin/pkg-descr
@@ -0,0 +1,5 @@
+Allows for the importing of addressbooks from a CSV (comma separated
+values) file. This will be located at the bottom of the "Addresses"
+section.
+
+WWW: http://www.squirrelmail.org/plugin_view.php?id=29
diff --git a/mail/squirrelmail-abook_import_export-plugin/pkg-plist b/mail/squirrelmail-abook_import_export-plugin/pkg-plist
new file mode 100644
index 000000000000..70058032e033
--- /dev/null
+++ b/mail/squirrelmail-abook_import_export-plugin/pkg-plist
@@ -0,0 +1,17 @@
+@unexec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --remove-plugin %%SQUIRREL_PLUGIN_NAME%%; fi
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/CHANGELOG
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/COPYING
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/INSTALL
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/README
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/ReleaseNotes.txt
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/abook_import_export.pot
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/address_book_export.php
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/address_book_import.php
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config_default.php
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/functions.php
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/index.php
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/setup.php
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/version
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/xgetpot
+@dirrm %%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%
+@exec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --install-plugin %%SQUIRREL_PLUGIN_NAME%%; fi