aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-03-08 18:51:34 +0800
committerkwm <kwm@FreeBSD.org>2013-03-08 18:51:34 +0800
commit77aa43669359356c3cab5041fdfcd537e1cabf09 (patch)
tree961839899dce7f75292a08c079f548973bdbd40d /mail
parent0fdeab2269ff13fcc43d09958d528d0ce5ec786a (diff)
downloadfreebsd-ports-gnome-77aa43669359356c3cab5041fdfcd537e1cabf09.tar.gz
freebsd-ports-gnome-77aa43669359356c3cab5041fdfcd537e1cabf09.tar.zst
freebsd-ports-gnome-77aa43669359356c3cab5041fdfcd537e1cabf09.zip
* Update the glib to 2.34.3 and gtk20 to 2.24.17 and gtk30 to 3.6.4 which
are the latest stable releases. * Update vala to the newest stable release 0.18.1, also update a few ports in the gtk/gnome stack. * The c++ bindings ports for glib, atk, gconf, etc, have now USE_GNOME toggles. * Remove pkg-config run depends from glib20 and freetype2. This doesn't eliminate pkg-config run dependency completely, a second phase is needed and is planned. * Support for .:run. and .:build. for USE_GNOME components was added. Currently only libxml2 and libxslt support this mechanism. * Updates of the telepathy stack and empathy. * Trim makefile headers, convert ports to new options, trim off library versions for some ports. * Fix other ports so they build with the new glib version. Thanks to miwi and crees for helping out with some exp-runs. Approved by: portmgr (miwi & bapt) Obtained from: gnome team repo
Diffstat (limited to 'mail')
-rw-r--r--mail/evolution-exchange/Makefile7
-rw-r--r--mail/evolution/Makefile19
-rw-r--r--mail/gnome-gmail-notifier/Makefile2
-rw-r--r--mail/masqmail/Makefile1
-rw-r--r--mail/notmuch/Makefile1
-rw-r--r--mail/spmfilter/Makefile2
6 files changed, 18 insertions, 14 deletions
diff --git a/mail/evolution-exchange/Makefile b/mail/evolution-exchange/Makefile
index 75273b7b9e05..c801dcf2fea0 100644
--- a/mail/evolution-exchange/Makefile
+++ b/mail/evolution-exchange/Makefile
@@ -3,12 +3,12 @@
# Whom: Adam Weinberger, based off kiesel's ximian-exchange port
#
# $FreeBSD$
-# $MCom: ports/mail/evolution-exchange/Makefile,v 1.166 2010/11/16 09:52:36 kwm Exp $
+# $MCom: ports/mail/evolution-exchange/Makefile,v 1.172 2012/09/20 23:06:27 kwm Exp $
#
PORTNAME= evolution-exchange
PORTVERSION= 2.32.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -20,6 +20,8 @@ EVO_PC_FILE= ${LOCALBASE}/libdata/pkgconfig/evolution-mail.pc
BUILD_DEPENDS= ${EVO_PC_FILE}:${PORTSDIR}/mail/evolution
RUN_DEPENDS= ${EVO_PC_FILE}:${PORTSDIR}/mail/evolution
+CONFLICTS= evolution-exchange-3.[0-9]*
+
USE_BZIP2= yes
USE_GETTEXT= yes
USE_AUTOTOOLS= libtool
@@ -65,6 +67,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|-ldb|-l${BDB_LIB_NAME}|g' \
-e 's|-lkrb5 -lcrypto -lasn1 -lcom_err -lroken -lgssapi|${KRB5_LIB}|g' \
-e 's|-DGTK_DISABLE_DEPRECATED||g' \
+ -e 's|-DG_DISABLE_DEPRECATED||g' \
-e 's|-Wmissing-include-dirs||g' \
${WRKSRC}/configure
diff --git a/mail/evolution/Makefile b/mail/evolution/Makefile
index 24a6feb062ca..873d8437ccae 100644
--- a/mail/evolution/Makefile
+++ b/mail/evolution/Makefile
@@ -1,24 +1,20 @@
-# New ports collection makefile for: evolution
-# Date created: 28th June 2000
-# Whom: Ade Lovett <ade@FreeBSD.org>
-#
+# Created by: Ade Lovett <ade@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/mail/evolution/Makefile,v 1.237 2011/04/30 20:43:20 mezz Exp $
-#
+# $MCom: ports/mail/evolution/Makefile,v 1.241 2012/09/01 23:02:10 mezz Exp $
PORTNAME= evolution
PORTVERSION= 2.32.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= mail gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
-COMMENT= Integrated mail, calendar, and address book distributed suite
+COMMENT= Integrated mail, calendar and address book distributed suite
-LIB_DEPENDS= nss3.1:${PORTSDIR}/security/nss \
- unique-1.0.2:${PORTSDIR}/x11-toolkits/unique \
- gtkimageview.0:${PORTSDIR}/x11-toolkits/gtkimageview
+LIB_DEPENDS= nss3:${PORTSDIR}/security/nss \
+ unique-1.0:${PORTSDIR}/x11-toolkits/unique \
+ gtkimageview:${PORTSDIR}/x11-toolkits/gtkimageview
RUN_DEPENDS= ${LOCALBASE}/lib/gnome-spell/libgnome-spell-component-0.3.so:${PORTSDIR}/textproc/gnome-spell
CONFLICTS= evolution-3.[0-9]*
@@ -109,6 +105,7 @@ post-patch:
-e 's|-lkrb5 -lcrypto -lasn1 -lcom_err -lroken -lgssapi|${KRB5_LIB}|g' \
-e 's|-Wl,--no-undefined||g' \
-e 's|-DGTK_DISABLE_DEPRECATED||g' \
+ -e 's|-DG_DISABLE_DEPRECATED||g' \
-e 's|-Wmissing-include-dirs||g' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/usr|${LOCALBASE}|g' \
diff --git a/mail/gnome-gmail-notifier/Makefile b/mail/gnome-gmail-notifier/Makefile
index 462832c6db02..ea8b0a29763f 100644
--- a/mail/gnome-gmail-notifier/Makefile
+++ b/mail/gnome-gmail-notifier/Makefile
@@ -27,5 +27,7 @@ USE_GSTREAMER= good
post-patch:
@${REINPLACE_CMD} -e 's|@DATADIRNAME@|share|' ${WRKSRC}/po/Makefile.in.in
+ @${REINPLACE_CMD} -e 's|<glib/gthread.h>|<glib.h>|g' ${WRKSRC}/src/main.h
+
.include <bsd.port.mk>
diff --git a/mail/masqmail/Makefile b/mail/masqmail/Makefile
index 2bf7245a3aec..9f87ea1735d5 100644
--- a/mail/masqmail/Makefile
+++ b/mail/masqmail/Makefile
@@ -20,6 +20,7 @@ MAN8= masqmail.8 rmail.8
.endif
USE_GNOME= glib20
+USE_PKGCONFIG= build
USE_RC_SUBR= masqmail
GNU_CONFIGURE= yes
CFLAGS+= -Wno-trigraphs
diff --git a/mail/notmuch/Makefile b/mail/notmuch/Makefile
index 692cbf02716c..d08cebc61b6c 100644
--- a/mail/notmuch/Makefile
+++ b/mail/notmuch/Makefile
@@ -17,6 +17,7 @@ LIB_DEPENDS= gmime-2.4:${PORTSDIR}/mail/gmime24 \
talloc:${PORTSDIR}/devel/talloc
HAS_CONFIGURE= yes
+USE_PKGCONFIG= build
CONFIGURE_ARGS= --prefix=${PREFIX} --mandir=${MANPREFIX}/man
USE_GMAKE= yes
USE_LDCONFIG= yes
diff --git a/mail/spmfilter/Makefile b/mail/spmfilter/Makefile
index 1d125e37413a..a466eee109cc 100644
--- a/mail/spmfilter/Makefile
+++ b/mail/spmfilter/Makefile
@@ -27,7 +27,7 @@ LICENSE= LGPL3
USE_CMAKE= yes
CMAKE_ARGS+= -DCMAKE_INCLUDE_PATH="${LOCALBASE}/include" \
-DCMAKE_LIBRARY_PATH="${LOCALBASE}/lib"
-
+USE_PKGCONFIG= build
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
USE_RC_SUBR= ${PORTNAME}