aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authoravg <avg@FreeBSD.org>2010-06-03 22:06:11 +0800
committeravg <avg@FreeBSD.org>2010-06-03 22:06:11 +0800
commit801f22067856c73dfedbdf1b89e98a2db7c13277 (patch)
tree6639bbabbed1e7253f8e8791b323e227781c40bf /mail
parent75a81cb672c90160dde2538e80c54c726081754f (diff)
downloadfreebsd-ports-gnome-801f22067856c73dfedbdf1b89e98a2db7c13277.tar.gz
freebsd-ports-gnome-801f22067856c73dfedbdf1b89e98a2db7c13277.tar.zst
freebsd-ports-gnome-801f22067856c73dfedbdf1b89e98a2db7c13277.zip
fix installation when WRKDIRPREFIX is used
don't assume that current working directory is in ports tree Approved by: wxs
Diffstat (limited to 'mail')
-rw-r--r--mail/moztraybiff/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/mail/moztraybiff/Makefile b/mail/moztraybiff/Makefile
index 05462315acc5..cb4ca6efc90f 100644
--- a/mail/moztraybiff/Makefile
+++ b/mail/moztraybiff/Makefile
@@ -20,14 +20,17 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/thunderbird/components/libwidget_gtk2.so:${PORTS
zip:${PORTSDIR}/archivers/zip
RUN_DEPENDS= ${LOCALBASE}/lib/thunderbird/components/libwidget_gtk2.so:${PORTSDIR}/mail/thunderbird
-.if !exists(../thunderbird/Makefile)
+USE_GMAKE= yes
+USE_GNOME= libgnome
+
+.include <bsd.port.pre.mk>
+
+.if !exists(${PORTSDIR}/mail/thunderbird/Makefile)
BROKEN= ${PORTNAME} needs the Thunderbird port in order to build
.else
-TBVER!= cd ../thunderbird && ${MAKE} -V PORTVERSION
+TBVER!= (cd ${PORTSDIR}/mail/thunderbird && ${MAKE} -V PORTVERSION)
.endif
-USE_GMAKE= yes
-USE_GNOME= libgnome
MAKE_ARGS+= MOZILLA_PLATFORM=tbird TBVER=${TBVER} MOZ_TRUNK=0
FILENAME= mozTrayBiff-${PORTVERSION}-tb${TBVER}.xpi
@@ -50,4 +53,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>