aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-04-06 00:27:13 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-04-06 00:27:13 +0800
commit8113cca324a76aa7afc87e579b9f5ea48a59af50 (patch)
treead77831c93002b44f36673abc3f5be7bc6c2c8fb /mail
parent8dcada51832ffe9ab4aed9752a2c49af07c5cc45 (diff)
downloadfreebsd-ports-gnome-8113cca324a76aa7afc87e579b9f5ea48a59af50.tar.gz
freebsd-ports-gnome-8113cca324a76aa7afc87e579b9f5ea48a59af50.tar.zst
freebsd-ports-gnome-8113cca324a76aa7afc87e579b9f5ea48a59af50.zip
- Add LICENSE
- Switch to options helpers - Regenerate patches with `make makepatch`
Diffstat (limited to 'mail')
-rw-r--r--mail/annoyance-filter/Makefile17
-rw-r--r--mail/annoyance-filter/files/patch-Makefile.in16
-rw-r--r--mail/annoyance-filter/files/patch-annoyance-filter.cc10
-rw-r--r--mail/annoyance-filter/files/patch-statlib_test.cc6
-rw-r--r--mail/annoyance-filter/pkg-plist8
5 files changed, 29 insertions, 28 deletions
diff --git a/mail/annoyance-filter/Makefile b/mail/annoyance-filter/Makefile
index 9dc116eac9f4..d0e6ff8d5b50 100644
--- a/mail/annoyance-filter/Makefile
+++ b/mail/annoyance-filter/Makefile
@@ -11,12 +11,19 @@ MASTER_SITES= SF/annoyancefilter/annoyancefilter/${PORTVERSION} \
MAINTAINER= ports@FreeBSD.org
COMMENT= Adaptive Bayesian Junk Mail Filter
+LICENSE= PD GPLv2+
+LICENSE_COMB= multi
+LICENSE_FILE_PD= ${WRKSRC}/COPYING
+LICENSE_FILE_GPLv2+ = ${WRKSRC}/COPYING.GNU
+
USE_GCC= yes
GNU_CONFIGURE= yes
-DOCS= COPYING INSTALL README *.pdf
+PORTDOCS= INSTALL README *.pdf
-CFLAGS= ${CPPFLAGS}
+PLIST_FILES= bin/annoyance-filter \
+ bin/annoyance-filter-run \
+ man/man1/annoyance-filter.1.gz
OPTIONS_DEFINE= DOCS
@@ -24,7 +31,9 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}-run ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/mail/annoyance-filter/files/patch-Makefile.in b/mail/annoyance-filter/files/patch-Makefile.in
index d8ac40b3bd98..285462f13e85 100644
--- a/mail/annoyance-filter/files/patch-Makefile.in
+++ b/mail/annoyance-filter/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig Tue Feb 18 15:57:20 2003
-+++ Makefile.in Fri Jan 2 02:56:16 2004
-@@ -83,11 +83,11 @@
+--- Makefile.in.orig 2004-08-04 14:42:56 UTC
++++ Makefile.in
+@@ -83,11 +83,11 @@ ipmpar.o: DCDFlib/src/ipmpar.c
# Annoyance filter program
@@ -15,7 +15,7 @@
$(PRODUCT).cc: $(PRODUCT).w
$(PRODUCT).tex: $(PRODUCT).w log.w $(TOOLS)
$(PRODUCT).view: $(PRODUCT).dvi
-@@ -97,8 +97,8 @@
+@@ -97,8 +97,8 @@ getopt1.o: getopt1.c getopt.h
# Statistical library
@@ -26,11 +26,10 @@
statlib.o: statlib.cc config.h getopt.h
statlib.cc: statlib.w
-@@ -275,14 +275,6 @@
- groff -man $(PRODUCT).1 | lp
+@@ -276,14 +276,6 @@ printman: $(PRODUCT).1
# HTML edition of manual page
--
+
-$(PRODUCT)_man_raw.html: $(PRODUCT).1
- $(MAN2HTML) -H $(MAN2HTMLHOST) $(PRODUCT).1 \
- >$(PRODUCT)_man_raw.html
@@ -38,6 +37,7 @@
-$(PRODUCT)_man.html: $(PRODUCT)_man_raw.html
- $(PERL) docutil/fixman2html.pl $(PRODUCT)_man_raw.html \
- >$(PRODUCT)_man.html
-
+-
manhtml: $(PRODUCT)_man.html
+ # Test it
diff --git a/mail/annoyance-filter/files/patch-annoyance-filter.cc b/mail/annoyance-filter/files/patch-annoyance-filter.cc
index c615d62a7eb1..040bd21c57ff 100644
--- a/mail/annoyance-filter/files/patch-annoyance-filter.cc
+++ b/mail/annoyance-filter/files/patch-annoyance-filter.cc
@@ -1,6 +1,6 @@
---- annoyance-filter.cc.orig 2004-08-04 16:28:36.000000000 -0400
-+++ annoyance-filter.cc 2014-10-08 12:04:20.000000000 -0400
-@@ -114,7 +114,7 @@
+--- annoyance-filter.cc.orig 2004-08-04 20:28:36 UTC
++++ annoyance-filter.cc
+@@ -114,7 +114,7 @@ using namespace std;
#define __GNU_LIBRARY__
#undef __GETOPT_H__
#endif
@@ -9,7 +9,7 @@
#include "statlib.h"
/*237:*/
-@@ -2675,7 +2675,7 @@
+@@ -2675,7 +2675,7 @@ return false;
fileLength= lseek(fileHandle,0,2);
lseek(fileHandle,0,0);
dp= static_cast<char*> (mmap((caddr_t)0,fileLength,
@@ -18,7 +18,7 @@
fileHandle,0));
istrstream is(dp,fileLength);
#else
-@@ -7332,7 +7332,7 @@
+@@ -7332,7 +7332,7 @@ return 1;
long fileLength= lseek(fileHandle,0,2);
lseek(fileHandle,0,0);
char*dp= static_cast<char*> (mmap((caddr_t)0,fileLength,
diff --git a/mail/annoyance-filter/files/patch-statlib_test.cc b/mail/annoyance-filter/files/patch-statlib_test.cc
index 497017ebf93f..75432fd84182 100644
--- a/mail/annoyance-filter/files/patch-statlib_test.cc
+++ b/mail/annoyance-filter/files/patch-statlib_test.cc
@@ -1,6 +1,6 @@
---- statlib_test.cc.orig Thu Sep 25 02:02:10 2003
-+++ statlib_test.cc Fri Jan 2 02:51:57 2004
-@@ -28,7 +28,7 @@
+--- statlib_test.cc.orig 2004-08-04 12:28:53 UTC
++++ statlib_test.cc
+@@ -28,7 +28,7 @@ using namespace std;
#include <unistd.h>
#endif
#else
diff --git a/mail/annoyance-filter/pkg-plist b/mail/annoyance-filter/pkg-plist
deleted file mode 100644
index 12e5ed2060d8..000000000000
--- a/mail/annoyance-filter/pkg-plist
+++ /dev/null
@@ -1,8 +0,0 @@
-bin/annoyance-filter
-bin/annoyance-filter-run
-man/man1/annoyance-filter.1.gz
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/annoyance-filter.pdf
-%%PORTDOCS%%%%DOCSDIR%%/statlib.pdf