aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2016-07-31 15:15:14 +0800
committerriggs <riggs@FreeBSD.org>2016-07-31 15:15:14 +0800
commit8166511d2784e75d846a00927242854fb8aec701 (patch)
treebbf363a27f616429fddb186a393452fe71400a21 /mail
parentcfbe5b47cf1110bfb398d250a95e41a5d1ecf6e7 (diff)
downloadfreebsd-ports-gnome-8166511d2784e75d846a00927242854fb8aec701.tar.gz
freebsd-ports-gnome-8166511d2784e75d846a00927242854fb8aec701.tar.zst
freebsd-ports-gnome-8166511d2784e75d846a00927242854fb8aec701.zip
New port: py-fuglu, a mail scanning daemon for Postfix written in Python
PR: 203120 Submitted by: ports@caomhin.org (maintainer)
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/py-fuglu/Makefile66
-rw-r--r--mail/py-fuglu/distinfo3
-rw-r--r--mail/py-fuglu/files/fuglu.in29
-rw-r--r--mail/py-fuglu/pkg-descr5
5 files changed, 104 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 3ff3c7251510..d6935538ea39 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -539,6 +539,7 @@
SUBDIR += py-authres
SUBDIR += py-cyruslib
SUBDIR += py-dkimpy
+ SUBDIR += py-fuglu
SUBDIR += py-libgmail
SUBDIR += py-milter
SUBDIR += py-notmuch
diff --git a/mail/py-fuglu/Makefile b/mail/py-fuglu/Makefile
new file mode 100644
index 000000000000..d8515ad72a33
--- /dev/null
+++ b/mail/py-fuglu/Makefile
@@ -0,0 +1,66 @@
+# Created by: Kevin Golding <ports@caomhin.org>
+# $FreeBSD$
+
+PORTNAME= fuglu
+PORTVERSION= 0.6.6
+CATEGORIES= mail python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@caomhin.org
+COMMENT= Mail scanning daemon for Postfix written in Python
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= postfix:mail/postfix \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six
+
+USES= python:2.4+
+USE_PYTHON= autoplist distutils
+
+USE_RC_SUBR= fuglu
+
+NO_ARCH= yes
+
+LOGDIR= /var/log/fuglu
+PLIST_DIRS+= ${LOGDIR}
+
+OPTIONS_DEFINE= BEAUTIFULSOUP CLAMAV DKIM MAGIC SPAMASSASSIN SPF SQL
+OPTIONS_DEFAULT= BEAUTIFULSOUP CLAMAV DKIM MAGIC SPAMASSASSIN SPF
+
+BEAUTIFULSOUP_DESC= Use BeautifulSoup for improved html processing
+CLAMAV_DESC= Use ClamAV
+DKIM_DESC= Use DKIM (in FuGlu)
+MAGIC_DESC= Use mime magic bindings for attachment detection
+SPAMASSASSIN_DESC= Use SpamAssassin
+SPF_DESC= Use SPF (in FuGlu)
+SQL_DESC= Use SQL
+
+BEAUTIFULSOUP_RUN_DEPENDS= ${PYTHON_SITELIBDIR}/bs4/__init__.py:www/py-beautifulsoup
+CLAMAV_RUN_DEPENDS= clamd:security/clamav
+DKIM_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dkimpy>0:mail/py-dkimpy
+MAGIC_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}magic>0:devel/py-magic
+SPAMASSASSIN_RUN_DEPENDS= spamassassin>=0:mail/spamassassin
+SPF_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyspf>0:mail/py-pyspf
+SQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy10>=1.0:databases/py-sqlalchemy10
+
+post-extract:
+ @${REINPLACE_CMD} -e "s|'/etc|'etc|g" ${WRKSRC}/setup.py
+ @${REINPLACE_CMD} -e "s|=/etc|=${PREFIX}/etc|g" ${WRKSRC}/conf/fuglu.conf.dist
+ @${REINPLACE_CMD} -e "s|'/etc|'${PREFIX}/etc|g" \
+ ${WRKSRC}/compareconfig.py \
+ ${WRKSRC}/src/fuglu/plugins/actionoverride.py \
+ ${WRKSRC}/src/fuglu/plugins/archive.py \
+ ${WRKSRC}/src/fuglu/plugins/attachment.py \
+ ${WRKSRC}/src/fuglu/plugins/domainauth.py \
+ ${WRKSRC}/src/fuglu/plugins/p_fraction.py \
+ ${WRKSRC}/src/fuglu/plugins/p_skipper.py \
+ ${WRKSRC}/src/fuglu/plugins/script.py \
+ ${WRKSRC}/src/startscript/fuglu \
+ ${WRKSRC}/src/tools/fuglu_conf \
+ ${WRKSRC}/src/tools/fuglu_debug
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${LOGDIR}
+
+.include <bsd.port.mk>
diff --git a/mail/py-fuglu/distinfo b/mail/py-fuglu/distinfo
new file mode 100644
index 000000000000..b10512587ada
--- /dev/null
+++ b/mail/py-fuglu/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1463569283
+SHA256 (fuglu-0.6.6.tar.gz) = c3cbc23a356bf38ac7ebb3999d94c84ef1c718189dde8f21a8ed9809f436e86c
+SIZE (fuglu-0.6.6.tar.gz) = 108982
diff --git a/mail/py-fuglu/files/fuglu.in b/mail/py-fuglu/files/fuglu.in
new file mode 100644
index 000000000000..f10ce2839dbb
--- /dev/null
+++ b/mail/py-fuglu/files/fuglu.in
@@ -0,0 +1,29 @@
+#!/bin/sh
+
+# $FreeBSD$
+#
+# PROVIDE: fuglu
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+#
+# Add these lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# fuglu_enable (bool): Set to NO by default.
+# Set it to YES to enable fuglu.
+
+. /etc/rc.subr
+
+name=fuglu
+rcvar=fuglu_enable
+
+load_rc_config $name
+: ${fuglu_enable:=no}
+: ${fuglu_pidfile="/var/run/${name}.pid"}
+
+command=%%PREFIX%%/bin/${name}
+pidfile=${fuglu_pidfile}
+
+command_interpreter=%%PYTHON_CMD%%
+
+run_rc_command "$1"
diff --git a/mail/py-fuglu/pkg-descr b/mail/py-fuglu/pkg-descr
new file mode 100644
index 000000000000..3e87bcba75f5
--- /dev/null
+++ b/mail/py-fuglu/pkg-descr
@@ -0,0 +1,5 @@
+A mail scanning daemon for Postfix written in Python. It acts as the
+glue application between the MTA and spam checkers and antivirus
+software and focuses on being solid, easy to manage, debug and monitor.
+
+WWW: http://fuglu.org/