aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-04-26 20:42:12 +0800
committermat <mat@FreeBSD.org>2016-04-26 20:42:12 +0800
commit8b38c6baee0b430adac6b69b2df09dc7074de3ce (patch)
tree3f9c2171e021f73b88f38e0b29006146dacecf57 /mail
parent41e5e3523d98feb46e4368a2bb5b57b99ec46236 (diff)
downloadfreebsd-ports-gnome-8b38c6baee0b430adac6b69b2df09dc7074de3ce.tar.gz
freebsd-ports-gnome-8b38c6baee0b430adac6b69b2df09dc7074de3ce.tar.zst
freebsd-ports-gnome-8b38c6baee0b430adac6b69b2df09dc7074de3ce.zip
Update to 1.3.2.
PR: 209044 Submitted by: tkato432 yahoo com Sponsored by: Absolight
Diffstat (limited to 'mail')
-rw-r--r--mail/elmo/Makefile26
-rw-r--r--mail/elmo/distinfo4
-rw-r--r--mail/elmo/files/patch-src_elmoconf.pl4
-rw-r--r--mail/elmo/files/patch-src_gettext.h11
-rw-r--r--mail/elmo/files/patch-src_rstring.c18
-rw-r--r--mail/elmo/files/patch-src_str.c14
-rw-r--r--mail/elmo/pkg-descr2
-rw-r--r--mail/elmo/pkg-plist7
8 files changed, 30 insertions, 56 deletions
diff --git a/mail/elmo/Makefile b/mail/elmo/Makefile
index f5100232a1e6..0e21aa54e254 100644
--- a/mail/elmo/Makefile
+++ b/mail/elmo/Makefile
@@ -2,17 +2,19 @@
# $FreeBSD$
PORTNAME= elmo
-PORTVERSION= 1.3.0
-PORTREVISION= 3
+PORTVERSION= 1.3.2
CATEGORIES= mail
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Receive, filter, read, compose, and send mail at the text console
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
CONFLICTS= elmo-devel-[0-9]*
-OPTIONS_DEFINE= NLS
+OPTIONS_DEFINE= GPGME NLS
GNU_CONFIGURE= yes
USES= iconv ncurses shebangfix perl5
@@ -20,28 +22,18 @@ USE_OPENSSL= yes
USE_PERL5= run
SHEBANG_FILES= src/elmoconf.pl
-LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
-
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+GPGME_DESC= GnuPG support using GPGME
+GPGME_LIB_DEPENDS= libgpgme.so:security/gpgme
+GPGME_CONFIGURE_ENV_OFF=ac_cv_header_gpgme_h=no
NLS_CONFIGURE_ON= --with-libintl-prefix="${LOCALBASE}"
NLS_CONFIGURE_OFF= --disable-nls
NLS_USES= gettext
OPTIONS_SUB= yes
-.if exists(${LOCALBASE}/lib/libgpgme.so) || defined(WITH_GPGME)
-LIB_DEPENDS+= libgpgme.so:security/gpgme
-.else
-pre-everything::
- @${ECHO_CMD}
- @${ECHO_CMD} "Define WITH_GPGME=yes to build with gpgme support."
- @${ECHO_CMD}
-.endif
-
post-patch:
- @${REINPLACE_CMD} -e 's|gpgme4|gpgme|g' -e 's|== "|= "|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|gpgme4|gpgme|g' ${WRKSRC}/src/pgp.c
+ @${REINPLACE_CMD} -e '/if test/s|==|=|g' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/mail/elmo/distinfo b/mail/elmo/distinfo
index 7e9f66086396..d6e78046e999 100644
--- a/mail/elmo/distinfo
+++ b/mail/elmo/distinfo
@@ -1,2 +1,2 @@
-SHA256 (elmo-1.3.0.tar.gz) = 6a4033ac4db0316fc3cbb5b36a1422ecaaae844cd0c668240037f3a6cf68d36b
-SIZE (elmo-1.3.0.tar.gz) = 513705
+SHA256 (elmo-1.3.2.tar.gz) = 96fa20b171e3c24262b3af150e89141a2a59883075b5e6a0f9a40ff60830fcbd
+SIZE (elmo-1.3.2.tar.gz) = 536768
diff --git a/mail/elmo/files/patch-src_elmoconf.pl b/mail/elmo/files/patch-src_elmoconf.pl
index 0414ca2c7fc6..a029c78c8ef5 100644
--- a/mail/elmo/files/patch-src_elmoconf.pl
+++ b/mail/elmo/files/patch-src_elmoconf.pl
@@ -1,5 +1,5 @@
---- src/elmoconf.pl.orig Sat Aug 7 11:30:51 2004
-+++ src/elmoconf.pl Sat Aug 7 11:32:44 2004
+--- src/elmoconf.pl.orig 2004-08-13 11:18:22 UTC
++++ src/elmoconf.pl
@@ -26,7 +26,6 @@
# This script sets up user's config file based on few simple questions.
diff --git a/mail/elmo/files/patch-src_gettext.h b/mail/elmo/files/patch-src_gettext.h
new file mode 100644
index 000000000000..4e3f573f7618
--- /dev/null
+++ b/mail/elmo/files/patch-src_gettext.h
@@ -0,0 +1,11 @@
+--- src/gettext.h.orig 2003-04-26 19:01:59 UTC
++++ src/gettext.h
+@@ -42,7 +42,7 @@
+ for invalid uses of the value returned from these functions.
+ On pre-ANSI systems without 'const', the config.h file is supposed to
+ contain "#define const". */
+-# define gettext(Msgid) ((const char *) (Msgid))
++# define gettext(Msgid) ((char *) (Msgid))
+ # define dgettext(Domainname, Msgid) ((const char *) (Msgid))
+ # define dcgettext(Domainname, Msgid, Category) ((const char *) (Msgid))
+ # define ngettext(Msgid1, Msgid2, N) \
diff --git a/mail/elmo/files/patch-src_rstring.c b/mail/elmo/files/patch-src_rstring.c
deleted file mode 100644
index 9f224c115ae2..000000000000
--- a/mail/elmo/files/patch-src_rstring.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/rstring.c.orig Sat Aug 7 03:01:05 2004
-+++ src/rstring.c Sat Aug 7 03:02:12 2004
-@@ -30,7 +30,6 @@
- #include <string.h>
- #include <stdarg.h>
- #include <sys/types.h>
--#include <regex.h>
- #include <errno.h>
- #include <ctype.h>
-
-@@ -38,6 +37,7 @@
- #include "rarray.h"
- #include "rstring.h"
- #include "error.h"
-+#include <regex.h>
- #include "memchunk.h"
- #include "str.h"
-
diff --git a/mail/elmo/files/patch-src_str.c b/mail/elmo/files/patch-src_str.c
deleted file mode 100644
index b06758e23c50..000000000000
--- a/mail/elmo/files/patch-src_str.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/str.c.orig Sat Aug 7 11:07:36 2004
-+++ src/str.c Sat Aug 7 11:22:37 2004
-@@ -217,7 +217,11 @@
-
- while (1){
- max_size = str->size - str->len - 1;
-+#if (defined(__FreeBSD__) && __FreeBSD__ < 5)
-+ copy = ap;
-+#else
- va_copy (copy, ap);
-+#endif
- n = vsnprintf (str->str + str->len, max_size, fmt, copy);
- if (n > -1 && n < max_size){
- str->len += n;
diff --git a/mail/elmo/pkg-descr b/mail/elmo/pkg-descr
index a03177b4e2ff..43b83946daed 100644
--- a/mail/elmo/pkg-descr
+++ b/mail/elmo/pkg-descr
@@ -6,4 +6,4 @@ maildir or Berkeley-formatted mailboxes.
Before running elmo, users should run elmoconf.pl to generate an
~/.elmorc file.
-WWW: http://elmo.sourceforge.net/
+WWW: http://elmo.sourceforge.net/
diff --git a/mail/elmo/pkg-plist b/mail/elmo/pkg-plist
index 8fa1fd1a8934..8c53061bf7b4 100644
--- a/mail/elmo/pkg-plist
+++ b/mail/elmo/pkg-plist
@@ -1,8 +1,11 @@
bin/elmo
bin/elmoconf.pl
+man/man1/elmo.1.gz
+man/man1/elmoconf.pl.1.gz
%%DATADIR%%/template
+%%DATADIR%%/themes/80x25
+%%DATADIR%%/themes/README
+%%DATADIR%%/themes/outlook
%%DATADIR%%/tutorial
%%NLS%%share/locale/de/LC_MESSAGES/elmo.mo
%%NLS%%share/locale/pl/LC_MESSAGES/elmo.mo
-man/man1/elmo.1.gz
-man/man1/elmoconf.pl.1.gz