aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2004-03-14 14:17:56 +0800
committerade <ade@FreeBSD.org>2004-03-14 14:17:56 +0800
commit9291e9a32f6612ca0d4f25bdcb5c417e0451d313 (patch)
tree545e55afde412d844a25f5c03d6d51b17ceeebb9 /mail
parenta8a89c37fe338cbff0192ceeef27ccf7a13714a5 (diff)
downloadfreebsd-ports-gnome-9291e9a32f6612ca0d4f25bdcb5c417e0451d313.tar.gz
freebsd-ports-gnome-9291e9a32f6612ca0d4f25bdcb5c417e0451d313.tar.zst
freebsd-ports-gnome-9291e9a32f6612ca0d4f25bdcb5c417e0451d313.zip
Whoa there, boy, that's a mighty big commit y'all have there...
Begin autotools sanitization sequence by requiring ports to explicitly specify which version of {libtool,autoconf,automake} they need, erasing the concept of a "system default". For ports-in-waiting: USE_LIBTOOL=YES -> USE_LIBTOOL_VER=13 USE_AUTOCONF=YES -> USE_AUTOCONF_VER=213 USE_AUTOMAKE=YES -> USE_AUTOMAKE_VER=14 Ports attempting to use the old style system after June 1st 2004 will be sorely disappointed.
Diffstat (limited to 'mail')
-rw-r--r--mail/balsa/Makefile2
-rw-r--r--mail/balsa2/Makefile2
-rw-r--r--mail/claws-mail/Makefile2
-rw-r--r--mail/crashecho/Makefile2
-rw-r--r--mail/cyrus/Makefile2
-rw-r--r--mail/dspam-devel/Makefile2
-rw-r--r--mail/dspam/Makefile2
-rw-r--r--mail/gmail/Makefile2
-rw-r--r--mail/gmime/Makefile2
-rw-r--r--mail/gmime2/Makefile3
-rw-r--r--mail/im/Makefile2
-rw-r--r--mail/jamlib/Makefile2
-rw-r--r--mail/libesmtp/Makefile2
-rw-r--r--mail/libetpan/Makefile2
-rw-r--r--mail/libnewmail/Makefile2
-rw-r--r--mail/mutt-devel/Makefile2
-rw-r--r--mail/mutt/Makefile2
-rw-r--r--mail/mutt14/Makefile2
-rw-r--r--mail/perdition/Makefile2
-rw-r--r--mail/pop3lite/Makefile2
-rw-r--r--mail/qpopper/Makefile2
-rw-r--r--mail/stuphead/Makefile2
-rw-r--r--mail/sylpheed-claws/Makefile2
-rw-r--r--mail/sylpheed-gtk2/Makefile2
-rw-r--r--mail/sylpheed/Makefile2
-rw-r--r--mail/sylpheed2-devel/Makefile2
-rw-r--r--mail/sylpheed2/Makefile2
-rw-r--r--mail/sylpheed3/Makefile2
-rw-r--r--mail/xfmail/Makefile2
29 files changed, 29 insertions, 30 deletions
diff --git a/mail/balsa/Makefile b/mail/balsa/Makefile
index 31e163960240..f2361534310d 100644
--- a/mail/balsa/Makefile
+++ b/mail/balsa/Makefile
@@ -24,7 +24,7 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GNOME= gnomeprefix gnomehack gnomeprint gnomevfs gtkhtml gnometarget
USE_OPENLDAP= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
USE_OPENSSL= yes
LIBTOOLFILES= configure libmutt/configure
CONFIGURE_ARGS= --enable-threads \
diff --git a/mail/balsa2/Makefile b/mail/balsa2/Makefile
index 718992cfc1a0..561740a6b35a 100644
--- a/mail/balsa2/Makefile
+++ b/mail/balsa2/Makefile
@@ -26,7 +26,7 @@ USE_PERL5= yes
USE_OPENSSL= yes
USE_GNOME= gnomeprefix gnomehack libgnomeui libgnomeprintui libgtkhtml
GNU_CONFIGURE= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
CONFIGURE_ARGS= --enable-threads \
--enable-gtkhtml \
--disable-more-warnings \
diff --git a/mail/claws-mail/Makefile b/mail/claws-mail/Makefile
index 1b6206c2026c..04d30b0ef0e2 100644
--- a/mail/claws-mail/Makefile
+++ b/mail/claws-mail/Makefile
@@ -28,7 +28,7 @@ USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
USE_GNOME= gnomehack pkgconfig gtk12
USE_REINPLACE= yes
diff --git a/mail/crashecho/Makefile b/mail/crashecho/Makefile
index 1b81b3a56547..eb3993889099 100644
--- a/mail/crashecho/Makefile
+++ b/mail/crashecho/Makefile
@@ -15,7 +15,7 @@ COMMENT= An FTN JAM and *.MSG tosser
LIB_DEPENDS= jam.2:${PORTSDIR}/mail/jamlib
-USE_LIBTOOL=yes
+USE_LIBTOOL_VER= 13
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= crashecho.1 \
diff --git a/mail/cyrus/Makefile b/mail/cyrus/Makefile
index 8a67999e0341..bca2c76dc363 100644
--- a/mail/cyrus/Makefile
+++ b/mail/cyrus/Makefile
@@ -23,7 +23,7 @@ BUILD_DEPENDS= makedepend:${PORTSDIR}/devel/makedepend \
${LOCALBASE}/sbin/pwcheck:${PORTSDIR}/security/cyrus-sasl
USE_REINPLACE= yes
-USE_AUTOCONF= yes
+USE_AUTOCONF_VER= 213
CONFIGURE_ARGS= --with-cyrus-prefix=${PREFIX}/cyrus \
--with-cyrus-group=cyrus \
--with-sasldir=${LOCALBASE} \
diff --git a/mail/dspam-devel/Makefile b/mail/dspam-devel/Makefile
index 0e1bb304095f..6edd19c71cf7 100644
--- a/mail/dspam-devel/Makefile
+++ b/mail/dspam-devel/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= http://www.nuclearelephant.com/projects/dspam/sources/
MAINTAINER= rob@debank.tv
COMMENT= A server-side bayesian spam filter
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
diff --git a/mail/dspam/Makefile b/mail/dspam/Makefile
index 0e1bb304095f..6edd19c71cf7 100644
--- a/mail/dspam/Makefile
+++ b/mail/dspam/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= http://www.nuclearelephant.com/projects/dspam/sources/
MAINTAINER= rob@debank.tv
COMMENT= A server-side bayesian spam filter
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
diff --git a/mail/gmail/Makefile b/mail/gmail/Makefile
index 4d3349334a93..2fed4f46f8a6 100644
--- a/mail/gmail/Makefile
+++ b/mail/gmail/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client \
USE_X_PREFIX= YES
USE_GMAKE= YES
#USE_GNOME= YES
-USE_LIBTOOL= YES
+USE_LIBTOOL_VER=13
BROKEN= project is dead and port unmaintained
DEPRECATED= ${BROKEN}
diff --git a/mail/gmime/Makefile b/mail/gmime/Makefile
index 3a4cd71e2f30..7b7acc24652f 100644
--- a/mail/gmime/Makefile
+++ b/mail/gmime/Makefile
@@ -21,7 +21,7 @@ USE_X_PREFIX= YES
GNU_CONFIGURE= YES
USE_GMAKE= YES
USE_GNOME= glib12
-USE_LIBTOOL= YES
+USE_LIBTOOL_VER=13
CONFIGURE_ARGS+=--with-libiconv-prefix=${LOCALBASE}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/mail/gmime2/Makefile b/mail/gmime2/Makefile
index 75b3933e0eb3..52205975520b 100644
--- a/mail/gmime2/Makefile
+++ b/mail/gmime2/Makefile
@@ -19,8 +19,7 @@ USE_ICONV= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= glib20 lthack
-USE_LIBTOOL= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL_VER=13
CONFIGURE_ARGS+= --with-libiconv=${LOCALBASE}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/mail/im/Makefile b/mail/im/Makefile
index fa8460cd5e0c..431dbc54ecfc 100644
--- a/mail/im/Makefile
+++ b/mail/im/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= kiri@FreeBSD.org
COMMENT= Set of user interfaces of Email and NetNews
USE_PERL5= yes
-USE_AUTOCONF= yes
+USE_AUTOCONF_VER= 213
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --libdir=${PREFIX}/etc
# If you use RPOP instead of APOP, comment out following line.
diff --git a/mail/jamlib/Makefile b/mail/jamlib/Makefile
index aa9d0f1e91c0..9a4fac9be0e2 100644
--- a/mail/jamlib/Makefile
+++ b/mail/jamlib/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= cyrilm@tower.pp.ru
COMMENT= A JAM subroutine library
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER= 13
NO_INSTALL_MANPAGES= yes
INSTALLS_SHLIB= yes
diff --git a/mail/libesmtp/Makefile b/mail/libesmtp/Makefile
index 5d8f2facdc90..2d3ad4f1f6cd 100644
--- a/mail/libesmtp/Makefile
+++ b/mail/libesmtp/Makefile
@@ -19,7 +19,7 @@ COMMENT= A library for posting electronic mail
USE_BZIP2= yes
USE_GMAKE= yes
USE_OPENSSL= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
USE_PERL5_BUILD=yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/mail/libetpan/Makefile b/mail/libetpan/Makefile
index b5e042fffd8b..3a157cace8c7 100644
--- a/mail/libetpan/Makefile
+++ b/mail/libetpan/Makefile
@@ -18,7 +18,7 @@ COMMENT= A mail library
LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
USE_OPENSSL= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INSTALLS_SHLIB= yes
diff --git a/mail/libnewmail/Makefile b/mail/libnewmail/Makefile
index 523c83729c3a..99ee1be8576d 100644
--- a/mail/libnewmail/Makefile
+++ b/mail/libnewmail/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= gnutls.13:${PORTSDIR}/security/gnutls \
USE_SIZE= yes
GNU_CONFIGURE= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index 0b59857542da..7731c6b906bf 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -119,7 +119,7 @@ CONFIGURE_ARGS+= ${MUTT_CONFIGURE_ARGS}
.endif
USE_REINPLACE= yes
-USE_AUTOMAKE= yes
+USE_AUTOMAKE_VER= 14
USE_OPENSSL= yes
PLIST= ${WRKDIR}/PLIST
diff --git a/mail/mutt/Makefile b/mail/mutt/Makefile
index 0eb76c4c92fb..5327698869e3 100644
--- a/mail/mutt/Makefile
+++ b/mail/mutt/Makefile
@@ -64,7 +64,7 @@ DIST_SUBDIR= mutt
WRKSRC= ${WRKDIR}/${DISTNAME:S/i$//}
USE_OPENSSL= yes
GNU_CONFIGURE= yes
-USE_AUTOMAKE= yes # configure.in is patched by <PATCHFILES>
+USE_AUTOMAKE_VER= 14 # configure.in is patched by <PATCHFILES>
USE_REINPLACE= yes
CONFIGURE_TARGET=${ARCH}-portbld-freebsd${OSREL}
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/mail/mutt14/Makefile b/mail/mutt14/Makefile
index 0eb76c4c92fb..5327698869e3 100644
--- a/mail/mutt14/Makefile
+++ b/mail/mutt14/Makefile
@@ -64,7 +64,7 @@ DIST_SUBDIR= mutt
WRKSRC= ${WRKDIR}/${DISTNAME:S/i$//}
USE_OPENSSL= yes
GNU_CONFIGURE= yes
-USE_AUTOMAKE= yes # configure.in is patched by <PATCHFILES>
+USE_AUTOMAKE_VER= 14 # configure.in is patched by <PATCHFILES>
USE_REINPLACE= yes
CONFIGURE_TARGET=${ARCH}-portbld-freebsd${OSREL}
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/mail/perdition/Makefile b/mail/perdition/Makefile
index 51258f35e3f1..9ea1802dc9a3 100644
--- a/mail/perdition/Makefile
+++ b/mail/perdition/Makefile
@@ -25,7 +25,7 @@ MAN8= perdition.8
MANCOMPRESSED= no
USE_GETTEXT= yes
-USE_LIBTOOL= YES
+USE_LIBTOOL_VER=13
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" BDB_LIB=db3
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ENV+= DOCSDIR=${DOCSDIR}
diff --git a/mail/pop3lite/Makefile b/mail/pop3lite/Makefile
index 65fc901e0bfd..50576ead9700 100644
--- a/mail/pop3lite/Makefile
+++ b/mail/pop3lite/Makefile
@@ -17,7 +17,7 @@ COMMENT= A flexible, modular RFC-compliant POP3 daemon
USE_GNOME= glib12
USE_GMAKE= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
MAN5= pop3lite.conf.5
diff --git a/mail/qpopper/Makefile b/mail/qpopper/Makefile
index 4f7e39f35786..042114b8bbf6 100644
--- a/mail/qpopper/Makefile
+++ b/mail/qpopper/Makefile
@@ -28,7 +28,7 @@ PATCHFILES= qpopper4.0.5-ipv6-20030313.diff.gz
PATCH_DIST_STRIP= -p1
.endif
-USE_AUTOCONF= yes
+USE_AUTOCONF_VER= 213
USE_REINPLACE= yes
USE_SIZE= yes
GNU_CONFIGURE= yes
diff --git a/mail/stuphead/Makefile b/mail/stuphead/Makefile
index 040866c72577..81a47236b195 100644
--- a/mail/stuphead/Makefile
+++ b/mail/stuphead/Makefile
@@ -24,7 +24,7 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GTK= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
CONFIGURE_ARGS= --enable-threads \
--prefix=${PREFIX}
diff --git a/mail/sylpheed-claws/Makefile b/mail/sylpheed-claws/Makefile
index 1b6206c2026c..04d30b0ef0e2 100644
--- a/mail/sylpheed-claws/Makefile
+++ b/mail/sylpheed-claws/Makefile
@@ -28,7 +28,7 @@ USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
USE_GNOME= gnomehack pkgconfig gtk12
USE_REINPLACE= yes
diff --git a/mail/sylpheed-gtk2/Makefile b/mail/sylpheed-gtk2/Makefile
index 2a3cb0ec45f8..0af27af307e4 100644
--- a/mail/sylpheed-gtk2/Makefile
+++ b/mail/sylpheed-gtk2/Makefile
@@ -22,7 +22,7 @@ USE_GMAKE= yes
USE_X_PREFIX= yes
USE_GNOME= gtk20
USE_OPENSSL= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER= 13
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/mail/sylpheed/Makefile b/mail/sylpheed/Makefile
index 957c03bf8f2f..70a24e240fc0 100644
--- a/mail/sylpheed/Makefile
+++ b/mail/sylpheed/Makefile
@@ -23,7 +23,7 @@ USE_GETTEXT= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_GNOME= gtk12
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include -I${LOCALBASE}/include -I${X11BASE}/include" \
diff --git a/mail/sylpheed2-devel/Makefile b/mail/sylpheed2-devel/Makefile
index 957c03bf8f2f..70a24e240fc0 100644
--- a/mail/sylpheed2-devel/Makefile
+++ b/mail/sylpheed2-devel/Makefile
@@ -23,7 +23,7 @@ USE_GETTEXT= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_GNOME= gtk12
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include -I${LOCALBASE}/include -I${X11BASE}/include" \
diff --git a/mail/sylpheed2/Makefile b/mail/sylpheed2/Makefile
index 957c03bf8f2f..70a24e240fc0 100644
--- a/mail/sylpheed2/Makefile
+++ b/mail/sylpheed2/Makefile
@@ -23,7 +23,7 @@ USE_GETTEXT= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_GNOME= gtk12
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include -I${LOCALBASE}/include -I${X11BASE}/include" \
diff --git a/mail/sylpheed3/Makefile b/mail/sylpheed3/Makefile
index 957c03bf8f2f..70a24e240fc0 100644
--- a/mail/sylpheed3/Makefile
+++ b/mail/sylpheed3/Makefile
@@ -23,7 +23,7 @@ USE_GETTEXT= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_GNOME= gtk12
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include -I${LOCALBASE}/include -I${X11BASE}/include" \
diff --git a/mail/xfmail/Makefile b/mail/xfmail/Makefile
index c5c5e6eeb7ff..8a827a33a020 100644
--- a/mail/xfmail/Makefile
+++ b/mail/xfmail/Makefile
@@ -25,7 +25,7 @@ CONFLICTS= qt-3.*
USE_BZIP2= yes
USE_GNOME= glib12
USE_GMAKE= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
USE_X_PREFIX= yes
USE_XPM= yes
INSTALLS_SHLIB= yes