aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2018-11-22 17:26:37 +0800
committerale <ale@FreeBSD.org>2018-11-22 17:26:37 +0800
commit9a4a862571a11283dbd684ff8f2ec036a7b7f48b (patch)
tree577504b2f67c2985d5e56b2b2ee07dd99df3882e /mail
parentee823f1e3058f196abe1e6913f34e1f805ce44d9 (diff)
downloadfreebsd-ports-gnome-9a4a862571a11283dbd684ff8f2ec036a7b7f48b.tar.gz
freebsd-ports-gnome-9a4a862571a11283dbd684ff8f2ec036a7b7f48b.tar.zst
freebsd-ports-gnome-9a4a862571a11283dbd684ff8f2ec036a7b7f48b.zip
Disable rsh/ssh functionality in imap by default (php bug #77153).
PR: 233384 Submitted by: joneum
Diffstat (limited to 'mail')
-rw-r--r--mail/php56-imap/Makefile1
-rw-r--r--mail/php56-imap/files/patch-config.m48
-rw-r--r--mail/php56-imap/files/patch-php__imap.c40
-rw-r--r--mail/php56-imap/files/patch-php__imap.h10
4 files changed, 55 insertions, 4 deletions
diff --git a/mail/php56-imap/Makefile b/mail/php56-imap/Makefile
index fb2e5394f3e0..6bc1c55c249e 100644
--- a/mail/php56-imap/Makefile
+++ b/mail/php56-imap/Makefile
@@ -2,6 +2,7 @@
# $FreeBSD$
CATEGORIES= mail
+PORTREVISION= 1
MASTERDIR= ${.CURDIR}/../../lang/php56
diff --git a/mail/php56-imap/files/patch-config.m4 b/mail/php56-imap/files/patch-config.m4
index ab7120b2c8c8..c4ddcf2bb90e 100644
--- a/mail/php56-imap/files/patch-config.m4
+++ b/mail/php56-imap/files/patch-config.m4
@@ -1,6 +1,6 @@
---- config.m4.orig 2010-02-07 14:06:54.000000000 +0100
-+++ config.m4 2010-03-08 11:56:24.000000000 +0100
-@@ -103,6 +103,8 @@
+--- config.m4.orig 2018-09-11 22:12:36 UTC
++++ config.m4
+@@ -103,6 +103,8 @@ PHP_ARG_WITH(kerberos,for IMAP Kerberos
PHP_ARG_WITH(imap-ssl,for IMAP SSL support,
[ --with-imap-ssl[=DIR] IMAP: Include SSL support. DIR is the OpenSSL install prefix], no, no)
@@ -9,7 +9,7 @@
if test "$PHP_IMAP" != "no"; then
PHP_SUBST(IMAP_SHARED_LIBADD)
-@@ -119,6 +121,30 @@
+@@ -119,6 +121,30 @@ if test "$PHP_IMAP" != "no"; then
fi
done
diff --git a/mail/php56-imap/files/patch-php__imap.c b/mail/php56-imap/files/patch-php__imap.c
new file mode 100644
index 000000000000..faa12adafa16
--- /dev/null
+++ b/mail/php56-imap/files/patch-php__imap.c
@@ -0,0 +1,40 @@
+--- php_imap.c.orig 2018-09-11 22:12:36 UTC
++++ php_imap.c
+@@ -562,6 +562,15 @@ static const zend_module_dep imap_deps[]
+ };
+ /* }}} */
+
++
++/* {{{ PHP_INI
++ */
++PHP_INI_BEGIN()
++STD_PHP_INI_BOOLEAN("imap.enable_insecure_rsh", "0", PHP_INI_SYSTEM, OnUpdateBool, enable_rsh, zend_imap_globals, imap_globals)
++PHP_INI_END()
++/* }}} */
++
++
+ /* {{{ imap_module_entry
+ */
+ zend_module_entry imap_module_entry = {
+@@ -835,6 +844,8 @@ PHP_MINIT_FUNCTION(imap)
+ {
+ unsigned long sa_all = SA_MESSAGES | SA_RECENT | SA_UNSEEN | SA_UIDNEXT | SA_UIDVALIDITY;
+
++ REGISTER_INI_ENTRIES();
++
+ #ifndef PHP_WIN32
+ mail_link(&unixdriver); /* link in the unix driver */
+ mail_link(&mhdriver); /* link in the mh driver */
+@@ -1052,6 +1063,12 @@ PHP_MINIT_FUNCTION(imap)
+ GC_TEXTS texts
+ */
+
++ if (!IMAPG(enable_rsh)) {
++ /* disable SSH and RSH, see https://bugs.php.net/bug.php?id=77153 */
++ mail_parameters (NIL, SET_RSHTIMEOUT, 0);
++ mail_parameters (NIL, SET_SSHTIMEOUT, 0);
++ }
++
+ le_imap = zend_register_list_destructors_ex(mail_close_it, NULL, "imap", module_number);
+ return SUCCESS;
+ }
diff --git a/mail/php56-imap/files/patch-php__imap.h b/mail/php56-imap/files/patch-php__imap.h
new file mode 100644
index 000000000000..f27f888f2ee7
--- /dev/null
+++ b/mail/php56-imap/files/patch-php__imap.h
@@ -0,0 +1,10 @@
+--- php_imap.h.orig 2018-09-11 22:12:36 UTC
++++ php_imap.h
+@@ -214,6 +214,7 @@ ZEND_BEGIN_MODULE_GLOBALS(imap)
+ #endif
+ /* php_stream for php_mail_gets() */
+ php_stream *gets_stream;
++ zend_bool enable_rsh;
+ ZEND_END_MODULE_GLOBALS(imap)
+
+ #ifdef ZTS