aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2018-11-02 21:32:34 +0800
committerrene <rene@FreeBSD.org>2018-11-02 21:32:34 +0800
commitabe85598b76e65884f63f5d35b14a7a5837c77ee (patch)
tree2c2c3d0def8d9d1ad349013f7b532f0065f57789 /mail
parenta6ebb885ab3952f319e4a2e650eba1580d82a26e (diff)
downloadfreebsd-ports-gnome-abe85598b76e65884f63f5d35b14a7a5837c77ee.tar.gz
freebsd-ports-gnome-abe85598b76e65884f63f5d35b14a7a5837c77ee.tar.zst
freebsd-ports-gnome-abe85598b76e65884f63f5d35b14a7a5837c77ee.zip
Remove compatibility code for FreeBSD < 11.2 from all ports.
Simplify some ports where DragonFlyBSD no longer needs to be special-cased. Submitted by: rene Reviewed by: bapt, jbeich Differential Revision: https://reviews.freebsd.org/D17724
Diffstat (limited to 'mail')
-rw-r--r--mail/bogofilter/Makefile3
-rw-r--r--mail/dma/Makefile8
-rw-r--r--mail/gotmail/Makefile10
-rw-r--r--mail/postfix-current/Makefile2
-rw-r--r--mail/postfix/Makefile2
-rw-r--r--mail/rss2email2/Makefile10
-rw-r--r--mail/sendmail/Makefile1
7 files changed, 5 insertions, 31 deletions
diff --git a/mail/bogofilter/Makefile b/mail/bogofilter/Makefile
index 131bcb60e967..a244c05ba566 100644
--- a/mail/bogofilter/Makefile
+++ b/mail/bogofilter/Makefile
@@ -12,9 +12,6 @@ COMMENT= Fast, teachable, learning spam detector
LICENSE= GPLv2
-BROKEN_FreeBSD_10_armv6= fails to configure: Cannot open a shared environment in Berkeley DB
-BROKEN_FreeBSD_10_armv7= fails to configure: Cannot open a shared environment in Berkeley DB
-
.if !defined(MASTERDIR) || ${MASTERDIR} == ${.CURDIR}
# building master port
USES+= bdb:5+
diff --git a/mail/dma/Makefile b/mail/dma/Makefile
index b70393bfeb17..1db2da9f1eb1 100644
--- a/mail/dma/Makefile
+++ b/mail/dma/Makefile
@@ -36,14 +36,8 @@ EXTRA_PATCHES= ${FILESDIR}/fix-security-hole.patch:-p1
# Allow subports to extend.
CONFFILES+= dma.conf auth.conf
-.include <bsd.port.pre.mk>
-
# 11.x has dma imported into base and /var/spool/dma added to mtree
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1100009
-PLIST_SUB+= VARDIR=""
-.else
PLIST_SUB+= VARDIR="@comment "
-.endif
post-patch:
@${REINPLACE_CMD} -e 's,/etc/dma,${PREFIX}/etc/dma,g' \
@@ -59,4 +53,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/dma.conf ${STAGEDIR}${ETCDIR}/dma.conf.sample
${INSTALL_DATA} ${WRKSRC}/auth.conf ${STAGEDIR}${ETCDIR}/auth.conf.sample
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/gotmail/Makefile b/mail/gotmail/Makefile
index 08ebe6d0def2..ab9a7add9f5a 100644
--- a/mail/gotmail/Makefile
+++ b/mail/gotmail/Makefile
@@ -25,14 +25,6 @@ PLIST_FILES= bin/gotmail man/man1/gotmail.1.gz
OPTIONS_DEFINE= DOCS
-.include <bsd.port.pre.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1100077
-# chmod -R bug
-post-extract:
- @${CHMOD} 755 ${WRKSRC}
-.endif
-
do-install:
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.man \
${STAGEDIR}${MANPREFIX}/man/man1/${PORTNAME}.1
@@ -44,4 +36,4 @@ do-install-DOCS-on:
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/postfix-current/Makefile b/mail/postfix-current/Makefile
index c7fc8fb79283..24da29f68682 100644
--- a/mail/postfix-current/Makefile
+++ b/mail/postfix-current/Makefile
@@ -198,7 +198,7 @@ POSTFIX_AUXLIBS+= -L${BDB_LIB_DIR} -l${BDB_LIB_NAME}
.endif
.if ${PORT_OPTIONS:MBLACKLISTD}
-. if ${OPSYS} == FreeBSD && (${OSVERSION} >= 1100122)
+. if ${OPSYS} == FreeBSD
POSTFIX_AUXLIBS+= -lblacklist
. else
IGNORE= blacklistd is only supported on FreeBSD >= 11.0
diff --git a/mail/postfix/Makefile b/mail/postfix/Makefile
index 1902a937e8e0..3542ad1a5721 100644
--- a/mail/postfix/Makefile
+++ b/mail/postfix/Makefile
@@ -198,7 +198,7 @@ POSTFIX_AUXLIBS+= -L${BDB_LIB_DIR} -l${BDB_LIB_NAME}
.endif
.if ${PORT_OPTIONS:MBLACKLISTD}
-. if ${OPSYS} == FreeBSD && (${OSVERSION} >= 1100122)
+. if ${OPSYS} == FreeBSD
POSTFIX_AUXLIBS+= -lblacklist
. else
IGNORE= blacklistd is only supported on FreeBSD >= 11.0
diff --git a/mail/rss2email2/Makefile b/mail/rss2email2/Makefile
index 3e0ad821cf32..6297a503ace3 100644
--- a/mail/rss2email2/Makefile
+++ b/mail/rss2email2/Makefile
@@ -45,12 +45,4 @@ do-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/config.py.example ${STAGEDIR}${EXAMPLESDIR}
-.include <bsd.port.pre.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1100077
-# chmod -R bug.
-post-extract:
- @${CHMOD} 0755 ${WRKSRC}
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/sendmail/Makefile b/mail/sendmail/Makefile
index e51a62507634..6230c962877b 100644
--- a/mail/sendmail/Makefile
+++ b/mail/sendmail/Makefile
@@ -49,7 +49,6 @@ OPTIONS_DEFINE?= SHMEM SEM LA NIS IPV6 TLS SASL SASLAUTHD LDAP BDB \
PICKY_HELO_CHECK MILTER DOCS
OPTIONS_DEFAULT?= SHMEM SEM LA NIS TLS SASL SASLAUTHD BDB1 \
BLACKLISTD PICKY_HELO_CHECK MILTER
-OPTIONS_EXCLUDE_FreeBSD_10= BLACKLISTD
NO_OPTIONS_SORT=yes
SHMEM_DESC= System V shared memory support
LA_DESC= load averages support