aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2002-11-03 23:12:05 +0800
committerarved <arved@FreeBSD.org>2002-11-03 23:12:05 +0800
commitb022d5b9a8a5e4cb29cd001882e050447f421eaf (patch)
tree1188774e267fe1e748e3474bf784c370d115a188 /mail
parentfbc342174f63cd93e9b0777a9c108a03dd62bbf4 (diff)
downloadfreebsd-ports-gnome-b022d5b9a8a5e4cb29cd001882e050447f421eaf.tar.gz
freebsd-ports-gnome-b022d5b9a8a5e4cb29cd001882e050447f421eaf.tar.zst
freebsd-ports-gnome-b022d5b9a8a5e4cb29cd001882e050447f421eaf.zip
Use bsd.port.(pre|post).mk
PR: 38616 Submitted by: KAWATA masahiko <kawata@mta.biglobe.ne.jp> Approved by: Oliver Lehmann <lehmann@ans-netz.de> (maintainer)
Diffstat (limited to 'mail')
-rw-r--r--mail/sylpheed/Makefile4
-rw-r--r--mail/sylpheed2-devel/Makefile4
-rw-r--r--mail/sylpheed2/Makefile4
-rw-r--r--mail/sylpheed3/Makefile4
4 files changed, 12 insertions, 4 deletions
diff --git a/mail/sylpheed/Makefile b/mail/sylpheed/Makefile
index d118adaf7a6f..76439fc14a8b 100644
--- a/mail/sylpheed/Makefile
+++ b/mail/sylpheed/Makefile
@@ -24,6 +24,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
CONFIGURE_ARGS= --enable-ipv6 --prefix=${PREFIX} --with-included-gettext
+.include <bsd.port.pre.mk>
+
.if defined(WITH_PIXBUF)
LIB_DEPENDS+= gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
CONFIGURE_ARGS+=--disable-imlib
@@ -101,4 +103,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/sylpheed2-devel/Makefile b/mail/sylpheed2-devel/Makefile
index d118adaf7a6f..76439fc14a8b 100644
--- a/mail/sylpheed2-devel/Makefile
+++ b/mail/sylpheed2-devel/Makefile
@@ -24,6 +24,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
CONFIGURE_ARGS= --enable-ipv6 --prefix=${PREFIX} --with-included-gettext
+.include <bsd.port.pre.mk>
+
.if defined(WITH_PIXBUF)
LIB_DEPENDS+= gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
CONFIGURE_ARGS+=--disable-imlib
@@ -101,4 +103,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/sylpheed2/Makefile b/mail/sylpheed2/Makefile
index d118adaf7a6f..76439fc14a8b 100644
--- a/mail/sylpheed2/Makefile
+++ b/mail/sylpheed2/Makefile
@@ -24,6 +24,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
CONFIGURE_ARGS= --enable-ipv6 --prefix=${PREFIX} --with-included-gettext
+.include <bsd.port.pre.mk>
+
.if defined(WITH_PIXBUF)
LIB_DEPENDS+= gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
CONFIGURE_ARGS+=--disable-imlib
@@ -101,4 +103,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/sylpheed3/Makefile b/mail/sylpheed3/Makefile
index d118adaf7a6f..76439fc14a8b 100644
--- a/mail/sylpheed3/Makefile
+++ b/mail/sylpheed3/Makefile
@@ -24,6 +24,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
CONFIGURE_ARGS= --enable-ipv6 --prefix=${PREFIX} --with-included-gettext
+.include <bsd.port.pre.mk>
+
.if defined(WITH_PIXBUF)
LIB_DEPENDS+= gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
CONFIGURE_ARGS+=--disable-imlib
@@ -101,4 +103,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>