aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2010-07-06 17:03:44 +0800
committermandree <mandree@FreeBSD.org>2010-07-06 17:03:44 +0800
commitb1c2e567bd235039b0949c35c60a5c236e4a2479 (patch)
tree2edd388b91a9b63e836bc97f6f3e5a1561c2bdb6 /mail
parent9b169f72e00b4351c26b30925432ac3aac0e1390 (diff)
downloadfreebsd-ports-gnome-b1c2e567bd235039b0949c35c60a5c236e4a2479.tar.gz
freebsd-ports-gnome-b1c2e567bd235039b0949c35c60a5c236e4a2479.tar.zst
freebsd-ports-gnome-b1c2e567bd235039b0949c35c60a5c236e4a2479.zip
Fix crash in base64 decoder. Pending CVE assignment from oss-security@.
Also pending vulndb entry. Approved by: garga (mentor, implicit) Feature safe: yes
Diffstat (limited to 'mail')
-rw-r--r--mail/bogofilter-sqlite/Makefile2
-rw-r--r--mail/bogofilter-tc/Makefile2
-rw-r--r--mail/bogofilter/Makefile2
-rw-r--r--mail/bogofilter/files/patch-base6418
4 files changed, 21 insertions, 3 deletions
diff --git a/mail/bogofilter-sqlite/Makefile b/mail/bogofilter-sqlite/Makefile
index 0d2fe30a47d4..5d38b987144b 100644
--- a/mail/bogofilter-sqlite/Makefile
+++ b/mail/bogofilter-sqlite/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bogofilter
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= mail
PKGNAMESUFFIX= -sqlite
diff --git a/mail/bogofilter-tc/Makefile b/mail/bogofilter-tc/Makefile
index 930535f24ec6..d2d8b1b227fc 100644
--- a/mail/bogofilter-tc/Makefile
+++ b/mail/bogofilter-tc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bogofilter
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= mail
PKGNAMESUFFIX= -tc
diff --git a/mail/bogofilter/Makefile b/mail/bogofilter/Makefile
index 340568a1ff35..d3449551b9e9 100644
--- a/mail/bogofilter/Makefile
+++ b/mail/bogofilter/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bogofilter
PORTVERSION= 1.2.1
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES?= mail
MASTER_SITES= SF/bogofilter/bogofilter-stable/bogofilter-${PORTVERSION}
diff --git a/mail/bogofilter/files/patch-base64 b/mail/bogofilter/files/patch-base64
new file mode 100644
index 000000000000..a44616136661
--- /dev/null
+++ b/mail/bogofilter/files/patch-base64
@@ -0,0 +1,18 @@
+Index: base64.c
+===================================================================
+--- src/base64.c (Revision 6766)
++++ src/base64.c (Revision 6921)
+@@ -61,9 +61,11 @@
+ d[i] = c;
+ v = v >> 8;
+ }
+- d += 3 - shorten;
+- count += 3 - shorten;
++ if(shorten != 4) {
++ d += 3 - shorten;
++ count += 3 - shorten;
+ }
++ }
+ /* XXX do we need this NUL byte? */
+ if (word->leng)
+ *d = (byte) '\0'; /* safe, base64 is always longer than original */