aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2010-01-14 08:11:13 +0800
committerleeym <leeym@FreeBSD.org>2010-01-14 08:11:13 +0800
commitd7ad540d4846b07e69a4260c289bc0856db50aa0 (patch)
treefd07cac4025ab83ef34fb504e9d669cb76837389 /mail
parent2105a93c895d488d036a56392325557903c64ef3 (diff)
downloadfreebsd-ports-gnome-d7ad540d4846b07e69a4260c289bc0856db50aa0.tar.gz
freebsd-ports-gnome-d7ad540d4846b07e69a4260c289bc0856db50aa0.tar.zst
freebsd-ports-gnome-d7ad540d4846b07e69a4260c289bc0856db50aa0.zip
use SUB_FILES to adjust pkg-message
use LOCALBASE instead of PREFIX in CFLAGS & LDFLAGS use PLIST_FILES instead of a seperate file PR: 142798 Submitted by: Sevan Janiyan <venture37 at geeklan.co.uk>
Diffstat (limited to 'mail')
-rw-r--r--mail/pop3vscan/Makefile9
-rw-r--r--mail/pop3vscan/files/patch-Makefile4
-rw-r--r--mail/pop3vscan/files/pkg-message.in (renamed from mail/pop3vscan/pkg-message)6
-rw-r--r--mail/pop3vscan/pkg-plist4
4 files changed, 13 insertions, 10 deletions
diff --git a/mail/pop3vscan/Makefile b/mail/pop3vscan/Makefile
index 5cdaf89e618b..375fd6d1d64f 100644
--- a/mail/pop3vscan/Makefile
+++ b/mail/pop3vscan/Makefile
@@ -20,6 +20,13 @@ USE_GMAKE= yes
MAKE_ENV= _LDFLAGS="${LDFLAGS}"
SCRIPTS_ENV= PKG_PREFIX=${PREFIX} NONEXISTENT=${NONEXISTENT} PASSWD=/etc/passwd
+PLIST_FILES= etc/pop3vscan.conf.sample \
+ etc/pop3vscan.mail.sample \
+ etc/rc.d/pop3vscan.sh \
+ sbin/pop3vscan
+
+SUB_FILES= pkg-message
+
post-extract:
@${RM} ${WRKSRC}/ripmime/ripmime.a
@@ -38,6 +45,6 @@ do-install:
post-install:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
- @${SED} -e 's,PREFIX,${PREFIX},g' ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/mail/pop3vscan/files/patch-Makefile b/mail/pop3vscan/files/patch-Makefile
index 06a8d53feb2f..dcd479f75603 100644
--- a/mail/pop3vscan/files/patch-Makefile
+++ b/mail/pop3vscan/files/patch-Makefile
@@ -9,8 +9,8 @@
#CFLAGS=-Wall -ggdb
-CFLAGS=-Wall -O2
-LDFLAGS=-L. -lmime -lpcre #-static
-+CFLAGS=-Wall -O2 -I$(PREFIX)/include -DPREFIX=\"${PREFIX}\"
-+LDFLAGS=-L. -lmime -lpcre -L$(PREFIX)/lib $(_LDFLAGS) #-static
++CFLAGS=-Wall -O2 -I$(LOCALBASE)/include -DPREFIX=\"${PREFIX}\"
++LDFLAGS=-L. -lmime -lpcre -L$(LOCALBASE)/lib $(_LDFLAGS) #-static
OBJECTS=getline.o parsefile.o pop3vscan.o \
scanner_basic.o scanner_avpd.o scanner_trophie.o
diff --git a/mail/pop3vscan/pkg-message b/mail/pop3vscan/files/pkg-message.in
index 614462eafeaf..9e2bd3ab2199 100644
--- a/mail/pop3vscan/pkg-message
+++ b/mail/pop3vscan/files/pkg-message.in
@@ -1,11 +1,11 @@
**********************************************************************
By default, POP3VScan is configured to work with McAfee UVSCAN.
-Please copy PREFIX/etc/pop3vscan.conf.sample to pop3vscan.conf and modify
-PREFIX/etc/pop3vscan.conf and/or PREFIX/etc/rc.d/pop3vscan.sh to
+Please copy %%PREFIX%%/etc/pop3vscan.conf.sample to pop3vscan.conf and modify
+%%PREFIX%%/etc/pop3vscan.conf and/or %%PREFIX%%/etc/rc.d/pop3vscan.sh to
fit your environment.
-Don't forget to copy PREFIX/etc/pop3vscan.mail.sample to pop3vscan.mail
+Don't forget to copy %%PREFIX%%/etc/pop3vscan.mail.sample to pop3vscan.mail
and edit your own template for virus notifications.
By the way, you need to enable the IPFIREWALL opion in kernel. Please note,
diff --git a/mail/pop3vscan/pkg-plist b/mail/pop3vscan/pkg-plist
deleted file mode 100644
index 1dad50f09c06..000000000000
--- a/mail/pop3vscan/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-etc/pop3vscan.conf.sample
-etc/pop3vscan.mail.sample
-etc/rc.d/pop3vscan.sh
-sbin/pop3vscan