aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorume <ume@FreeBSD.org>2006-05-27 14:51:09 +0800
committerume <ume@FreeBSD.org>2006-05-27 14:51:09 +0800
commitd93097e45e6ec90fe34e633bf8935281230fcf83 (patch)
tree050a2f127cd3714b495e14017181c48da957b2b2 /mail
parent12b602985eb4630587e81d457c22d25c43e60c10 (diff)
downloadfreebsd-ports-gnome-d93097e45e6ec90fe34e633bf8935281230fcf83.tar.gz
freebsd-ports-gnome-d93097e45e6ec90fe34e633bf8935281230fcf83.tar.zst
freebsd-ports-gnome-d93097e45e6ec90fe34e633bf8935281230fcf83.zip
Fixed imtest to be compatible with SASL 2.1.22.
Obtained from: https://bugzilla.andrew.cmu.edu/cgi-bin/cvsweb.cgi/src/cyrus/imtest/imtest.c.diff?r1=1.107&r2=1.108&f=u
Diffstat (limited to 'mail')
-rw-r--r--mail/cyrus-imapd22/Makefile2
-rw-r--r--mail/cyrus-imapd22/files/patch-imtest::imtest.c13
2 files changed, 14 insertions, 1 deletions
diff --git a/mail/cyrus-imapd22/Makefile b/mail/cyrus-imapd22/Makefile
index 1985467d81e0..4cbb7e14d88f 100644
--- a/mail/cyrus-imapd22/Makefile
+++ b/mail/cyrus-imapd22/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cyrus-imapd
PORTVERSION= 2.2.13
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/ \
ftp://ftp.hanse.de/sites/transit/mirror/ftp.andrew.cmu.edu/pub/cyrus-mail/ \
diff --git a/mail/cyrus-imapd22/files/patch-imtest::imtest.c b/mail/cyrus-imapd22/files/patch-imtest::imtest.c
index e1fd1efa8c06..957e35677d78 100644
--- a/mail/cyrus-imapd22/files/patch-imtest::imtest.c
+++ b/mail/cyrus-imapd22/files/patch-imtest::imtest.c
@@ -21,3 +21,16 @@ diff -u imtest/imtest.c.orig imtest/imtest.c
/*
* This is the setup routine for the SSL client.
*
+@@ -886,6 +886,12 @@
+ }
+
+ if (*str != '\r') {
++ /* trim CRLF */
++ char *p = str + strlen(str) - 1;
++ if (p >= str && *p == '\n') *p-- = '\0';
++ if (p >= str && *p == '\r') *p-- = '\0';
++
++ /* alloc space for decoded response */
+ len = strlen(str) + 1;
+ *line = malloc(len);
+ if ((*line) == NULL) {