aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorfluffy <fluffy@FreeBSD.org>2016-06-19 23:51:49 +0800
committerfluffy <fluffy@FreeBSD.org>2016-06-19 23:51:49 +0800
commitdc847a565a11a3c4e28b22a4308b6cab8c563b4f (patch)
tree49701685d9b371c2b33b1a9e4b7f11a196331c99 /mail
parent555cb8dfa3d3d4fceccfed3ad936230bea7b54e5 (diff)
downloadfreebsd-ports-gnome-dc847a565a11a3c4e28b22a4308b6cab8c563b4f.tar.gz
freebsd-ports-gnome-dc847a565a11a3c4e28b22a4308b6cab8c563b4f.tar.zst
freebsd-ports-gnome-dc847a565a11a3c4e28b22a4308b6cab8c563b4f.zip
- While Python2 is default, force it as explicit dependency.
Current OpenSMTPD-extras support only Python v2 API, no v3 yet Approved by: miwi (mentor, implicit)
Diffstat (limited to 'mail')
-rw-r--r--mail/opensmtpd-extras-filter-python/Makefile2
-rw-r--r--mail/opensmtpd-extras-queue-python/Makefile2
-rw-r--r--mail/opensmtpd-extras-scheduler-python/Makefile2
-rw-r--r--mail/opensmtpd-extras-table-python/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/mail/opensmtpd-extras-filter-python/Makefile b/mail/opensmtpd-extras-filter-python/Makefile
index b60fd5566469..ae9d64d4bd69 100644
--- a/mail/opensmtpd-extras-filter-python/Makefile
+++ b/mail/opensmtpd-extras-filter-python/Makefile
@@ -11,7 +11,7 @@ PLIST_FILES= libexec/opensmtpd/filter-python
CONFIGURE_ARGS+= --with-filter-python --with-python-type=${PYTHON_VERSION}
-USES= python pkgconfig
+USES= python:2 pkgconfig
MASTERDIR= ${.CURDIR}/../opensmtpd-extras
SLAVE_PORT= yes
diff --git a/mail/opensmtpd-extras-queue-python/Makefile b/mail/opensmtpd-extras-queue-python/Makefile
index 92d2dddaf53f..47980c92544c 100644
--- a/mail/opensmtpd-extras-queue-python/Makefile
+++ b/mail/opensmtpd-extras-queue-python/Makefile
@@ -11,7 +11,7 @@ PLIST_FILES= libexec/opensmtpd/queue-python
CONFIGURE_ARGS+= --with-queue-python --with-python-type=${PYTHON_VERSION}
-USES= python pkgconfig
+USES= python:2 pkgconfig
MASTERDIR= ${.CURDIR}/../opensmtpd-extras
SLAVE_PORT= yes
diff --git a/mail/opensmtpd-extras-scheduler-python/Makefile b/mail/opensmtpd-extras-scheduler-python/Makefile
index 68041b551e70..1d8425061b4f 100644
--- a/mail/opensmtpd-extras-scheduler-python/Makefile
+++ b/mail/opensmtpd-extras-scheduler-python/Makefile
@@ -11,7 +11,7 @@ PLIST_FILES= libexec/opensmtpd/scheduler-python
CONFIGURE_ARGS+= --with-scheduler-python --with-python-type=${PYTHON_VERSION}
-USES= python pkgconfig
+USES= python:2 pkgconfig
MASTERDIR= ${.CURDIR}/../opensmtpd-extras
SLAVE_PORT= yes
diff --git a/mail/opensmtpd-extras-table-python/Makefile b/mail/opensmtpd-extras-table-python/Makefile
index 365726802174..1b8f06f4fb28 100644
--- a/mail/opensmtpd-extras-table-python/Makefile
+++ b/mail/opensmtpd-extras-table-python/Makefile
@@ -10,7 +10,7 @@ PLIST_FILES= libexec/opensmtpd/table-python
CONFIGURE_ARGS+= --with-table-python --with-python-type=${PYTHON_VERSION}
-USES= python pkgconfig
+USES= python:2 pkgconfig
MASTERDIR= ${.CURDIR}/../opensmtpd-extras
SLAVE_PORT= yes