aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorstefan <stefan@FreeBSD.org>2009-10-06 22:52:01 +0800
committerstefan <stefan@FreeBSD.org>2009-10-06 22:52:01 +0800
commitf1d89bd7c8a47f79336aa2859410aba5c45ffee6 (patch)
treed6b147099f2e1ef09f8bfcb57274b27faedadfa4 /mail
parentd7a3a28581aa14531e5dff1cf0e8b00221dccef8 (diff)
downloadfreebsd-ports-gnome-f1d89bd7c8a47f79336aa2859410aba5c45ffee6.tar.gz
freebsd-ports-gnome-f1d89bd7c8a47f79336aa2859410aba5c45ffee6.tar.zst
freebsd-ports-gnome-f1d89bd7c8a47f79336aa2859410aba5c45ffee6.zip
- Update databases/libpbl to 1.04, fix compile-time warnings, declare as safe
for parallel building and run bundled self-tests after building. - Patch mail/spamprobe to make it work with libpbl on amd64. PR: 130236 Submitted by: Kenji Rikitake <kenji.rikitake@acm.org> Patch by: mi Approved by: Zach Thompson <hideo@lastamericanempire.com> (maintainer)
Diffstat (limited to 'mail')
-rw-r--r--mail/spamprobe/Makefile2
-rw-r--r--mail/spamprobe/files/patch-src_database_FrequencyCBImpl_pbl.cc21
2 files changed, 22 insertions, 1 deletions
diff --git a/mail/spamprobe/Makefile b/mail/spamprobe/Makefile
index 5009d2ee55a3..2c612d0b194e 100644
--- a/mail/spamprobe/Makefile
+++ b/mail/spamprobe/Makefile
@@ -14,7 +14,7 @@
PORTNAME= spamprobe
PORTVERSION= 1.4d
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail
MASTER_SITES= SF
diff --git a/mail/spamprobe/files/patch-src_database_FrequencyCBImpl_pbl.cc b/mail/spamprobe/files/patch-src_database_FrequencyCBImpl_pbl.cc
new file mode 100644
index 000000000000..dcbe2d89dc87
--- /dev/null
+++ b/mail/spamprobe/files/patch-src_database_FrequencyCBImpl_pbl.cc
@@ -0,0 +1,21 @@
+--- src/database/FrequencyDBImpl_pbl.cc 2006-11-17 02:24:48.000000000 -0500
++++ src/database/FrequencyDBImpl_pbl.cc 2009-09-30 16:08:39.000000000 -0400
+@@ -45,6 +45,6 @@
+ const char *FrequencyDBImpl_pbl::SEARCH_SUFFIX("pkey");
+
+-inline int throw_on_error(const char *function_name,
+- int rc)
++inline long throw_on_error(const char *function_name,
++ long rc)
+ {
+ if (rc >= 0) {
+@@ -261,6 +261,6 @@
+ {
+ char key[BUFFER_SIZE];
+- int keylen = 0;
+- int rc = 0;
++ size_t keylen;
++ int rc;
+
+ switch (pbl_code) {
+