aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-03-04 03:38:13 +0800
committerjbeich <jbeich@FreeBSD.org>2017-03-04 03:38:13 +0800
commit0f03a2eb907ae62aaa94d52053c334290a5fcd84 (patch)
tree7d3284e05228817e5a098f0866e33d8843538a73 /mail
parent65465b5dfd10d04bfe8bcedc24b16f547b617c60 (diff)
downloadfreebsd-ports-gnome-0f03a2eb907ae62aaa94d52053c334290a5fcd84.tar.gz
freebsd-ports-gnome-0f03a2eb907ae62aaa94d52053c334290a5fcd84.tar.zst
freebsd-ports-gnome-0f03a2eb907ae62aaa94d52053c334290a5fcd84.zip
gecko: attempt to drop RPATH for libxul.so dependencies
Diffstat (limited to 'mail')
-rw-r--r--mail/thunderbird/Makefile1
-rw-r--r--mail/thunderbird/files/patch-bug133679121
2 files changed, 22 insertions, 0 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 9fdd19e2bc6f..2422498f8cce 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -3,6 +3,7 @@
PORTNAME= thunderbird
DISTVERSION= 45.7.1
+PORTREVISION= 1
CATEGORIES= mail news net-im ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
diff --git a/mail/thunderbird/files/patch-bug1336791 b/mail/thunderbird/files/patch-bug1336791
new file mode 100644
index 000000000000..04b014b8b361
--- /dev/null
+++ b/mail/thunderbird/files/patch-bug1336791
@@ -0,0 +1,21 @@
+# Allow readelf to print types without parentheses
+
+--- mozilla/toolkit/library/dependentlibs.py
++++ mozilla/toolkit/library/dependentlibs.py
+@@ -57,11 +57,15 @@ def dependentlibs_readelf(lib):
+ for line in proc.stdout:
+ # Each line has the following format:
+ # tag (TYPE) value
++ # or with BSD readelf:
++ # tag TYPE value
+ # Looking for NEEDED type entries
+ tmp = line.split(' ', 3)
+- if len(tmp) > 3 and tmp[2] == '(NEEDED)':
++ if len(tmp) > 3 and 'NEEDED' in tmp[2]:
+ # NEEDED lines look like:
+ # 0x00000001 (NEEDED) Shared library: [libname]
++ # or with BSD readelf:
++ # 0x00000001 NEEDED Shared library: [libname]
+ match = re.search('\[(.*)\]', tmp[3])
+ if match:
+ deps.append(match.group(1))