aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2003-06-08 14:54:25 +0800
committernork <nork@FreeBSD.org>2003-06-08 14:54:25 +0800
commit344dd479997927088df2d41e19801679e26212b1 (patch)
tree133d268a8fade1029bd8fe515137625310835b32 /mail
parentacabd727b1c5e86b7475967214822190fe2f98e0 (diff)
downloadfreebsd-ports-gnome-344dd479997927088df2d41e19801679e26212b1.tar.gz
freebsd-ports-gnome-344dd479997927088df2d41e19801679e26212b1.tar.zst
freebsd-ports-gnome-344dd479997927088df2d41e19801679e26212b1.zip
Add pear-Mail 1.0.2, pEAR class that provides multiple interfaces
for sending emails. PR: ports/52596 Submitted by: Thierry Thomas (<thierry@pompo.net>)
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/pear-Mail/Makefile26
-rw-r--r--mail/pear-Mail/distinfo1
-rw-r--r--mail/pear-Mail/pkg-descr9
-rw-r--r--mail/pear-Mail/pkg-plist8
5 files changed, 45 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 9a11593ee5d5..ec886aefb349 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -208,6 +208,7 @@
SUBDIR += pantomime
SUBDIR += pantomime-ssl
SUBDIR += pathalias
+ SUBDIR += pear-Mail
SUBDIR += pear-Mail_Mime
SUBDIR += pear-mailparse
SUBDIR += perdition
diff --git a/mail/pear-Mail/Makefile b/mail/pear-Mail/Makefile
new file mode 100644
index 000000000000..899789c2eabc
--- /dev/null
+++ b/mail/pear-Mail/Makefile
@@ -0,0 +1,26 @@
+# Ports collection makefile for: pear-Mail
+# Date created: 26 November 2002
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Mail
+PORTVERSION= 1.0.2
+CATEGORIES= mail www
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= PEAR class that provides multiple interfaces for sending emails
+
+BUILD_DEPENDS= ${PEARDIR}/Net/SMTP.php:${PORTSDIR}/net/pear-Net_SMTP
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
+
+do-install:
+ @${CP} -Rp ${WRKSRC}/* ${PEARDIR}
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/Mail*
+ @${CHMOD} a-x ${PEARDIR}/Mail.php
+
+.include <bsd.port.post.mk>
diff --git a/mail/pear-Mail/distinfo b/mail/pear-Mail/distinfo
new file mode 100644
index 000000000000..e0e26fdb3159
--- /dev/null
+++ b/mail/pear-Mail/distinfo
@@ -0,0 +1 @@
+MD5 (PEAR/Mail-1.0.2.tgz) = d146356060ec1e7bcf62120f62579088
diff --git a/mail/pear-Mail/pkg-descr b/mail/pear-Mail/pkg-descr
new file mode 100644
index 000000000000..172ef76a79b3
--- /dev/null
+++ b/mail/pear-Mail/pkg-descr
@@ -0,0 +1,9 @@
+The PEAR's Mail:: interface, defines the interface for implementing mailers
+under the PEAR hierarchy, and provides supporting functions useful in multiple
+mailer backends.
+
+Currently supported are native PHP mail() function, sendmail and SMTP.
+This package also provides a RFC 822 Email address list validation utility
+class.
+
+WWW: http://pear.php.net/package-info.php?package=Mail
diff --git a/mail/pear-Mail/pkg-plist b/mail/pear-Mail/pkg-plist
new file mode 100644
index 000000000000..f93aaa425f56
--- /dev/null
+++ b/mail/pear-Mail/pkg-plist
@@ -0,0 +1,8 @@
+%%PEARDIR%%/Mail/RFC822.php
+%%PEARDIR%%/Mail/mail.php
+%%PEARDIR%%/Mail/sendmail.php
+%%PEARDIR%%/Mail/smtp.php
+%%PEARDIR%%/Mail.php
+%%PKGREGDIR%%/package.xml
+@dirrm %%PEARDIR%%/Mail
+@dirrm %%PKGREGDIR%%