aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorpat <pat@FreeBSD.org>2002-03-13 18:20:56 +0800
committerpat <pat@FreeBSD.org>2002-03-13 18:20:56 +0800
commit359096f39a893a6ad7bfe455ac5f6a3b0c25fdc6 (patch)
treebafa2736ca8baa921f26ca32f8ceb328a58ab9f9 /mail
parenteb855c724e04930a9a4e2a9af93451bcfa6ce3a7 (diff)
downloadfreebsd-ports-gnome-359096f39a893a6ad7bfe455ac5f6a3b0c25fdc6.tar.gz
freebsd-ports-gnome-359096f39a893a6ad7bfe455ac5f6a3b0c25fdc6.tar.zst
freebsd-ports-gnome-359096f39a893a6ad7bfe455ac5f6a3b0c25fdc6.zip
Fix error check which cause problems with local mail delivery and
bump PORTREVISION. PR: 35835 Submitted by: maintainer
Diffstat (limited to 'mail')
-rw-r--r--mail/claws-mail/Makefile1
-rw-r--r--mail/claws-mail/files/patch-src-send.c11
-rw-r--r--mail/sylpheed-claws/Makefile1
-rw-r--r--mail/sylpheed-claws/files/patch-src-send.c11
4 files changed, 24 insertions, 0 deletions
diff --git a/mail/claws-mail/Makefile b/mail/claws-mail/Makefile
index bbf5ed56dab5..b17c0a8d213f 100644
--- a/mail/claws-mail/Makefile
+++ b/mail/claws-mail/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sylpheed-claws
PORTVERSION= 0.7.4
+PORTREVISION= 1
CATEGORIES= mail news ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sylpheed-claws
diff --git a/mail/claws-mail/files/patch-src-send.c b/mail/claws-mail/files/patch-src-send.c
new file mode 100644
index 000000000000..d111334248cb
--- /dev/null
+++ b/mail/claws-mail/files/patch-src-send.c
@@ -0,0 +1,11 @@
+--- src/send.c 10 Mar 2002 14:09:59 -0000 1.26
++++ src/send.c 13 Mar 2002 00:41:07 -0000
+@@ -234,7 +234,7 @@
+ }
+
+ r = pclose(pipefp);
+- if (r != 0) {
++ if (r > 0) {
+ g_warning(_("external command failed: %s\n"), command);
+ return -1;
+ }
diff --git a/mail/sylpheed-claws/Makefile b/mail/sylpheed-claws/Makefile
index bbf5ed56dab5..b17c0a8d213f 100644
--- a/mail/sylpheed-claws/Makefile
+++ b/mail/sylpheed-claws/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sylpheed-claws
PORTVERSION= 0.7.4
+PORTREVISION= 1
CATEGORIES= mail news ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sylpheed-claws
diff --git a/mail/sylpheed-claws/files/patch-src-send.c b/mail/sylpheed-claws/files/patch-src-send.c
new file mode 100644
index 000000000000..d111334248cb
--- /dev/null
+++ b/mail/sylpheed-claws/files/patch-src-send.c
@@ -0,0 +1,11 @@
+--- src/send.c 10 Mar 2002 14:09:59 -0000 1.26
++++ src/send.c 13 Mar 2002 00:41:07 -0000
+@@ -234,7 +234,7 @@
+ }
+
+ r = pclose(pipefp);
+- if (r != 0) {
++ if (r > 0) {
+ g_warning(_("external command failed: %s\n"), command);
+ return -1;
+ }